summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2004-06-08 05:43:30 +0000
committerNick Hadaway <raker@gentoo.org>2004-06-08 05:43:30 +0000
commite53c86d50bb44f97ae5999c2c4cd8668e2c5cfd5 (patch)
tree445e5a131b7fb6da544c505a2c071b0d985da825 /net-libs
parentFixes and updates as per bug #47947 comments 31,35,36 (Manifest recommit) (diff)
downloadgentoo-2-e53c86d50bb44f97ae5999c2c4cd8668e2c5cfd5.tar.gz
gentoo-2-e53c86d50bb44f97ae5999c2c4cd8668e2c5cfd5.tar.bz2
gentoo-2-e53c86d50bb44f97ae5999c2c4cd8668e2c5cfd5.zip
Added a patch for nsswitch.ldap so a files lookup is done before dns to resolve hosts.
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/nss_ldap/ChangeLog8
-rw-r--r--net-libs/nss_ldap/files/nsswitch.ldap.diff15
-rw-r--r--net-libs/nss_ldap/nss_ldap-215-r1.ebuild4
3 files changed, 25 insertions, 2 deletions
diff --git a/net-libs/nss_ldap/ChangeLog b/net-libs/nss_ldap/ChangeLog
index 496602e1cdd3..c923fb5f1a9d 100644
--- a/net-libs/nss_ldap/ChangeLog
+++ b/net-libs/nss_ldap/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/nss_ldap
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/nss_ldap/ChangeLog,v 1.25 2004/06/06 10:06:48 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/nss_ldap/ChangeLog,v 1.26 2004/06/08 05:43:30 raker Exp $
+
+ 08 Jun 2004; Nick Hadaway <raker@gentoo.org> nss_ldap-215-r1.ebuild,
+ files/nsswitch.ldap.diff :
+ adds a files lookup for hosts in /etc/nsswitch.ldap.
+ Many people do not have proper dns entries for their Base DN.
+ See bug #50830. Not bumping this as there is no recompile required.
06 Jun 2004; Guy Martin <gmsoft@gentoo.org> nss_ldap-215-r1.ebuild:
Marked stable on hppa.
diff --git a/net-libs/nss_ldap/files/nsswitch.ldap.diff b/net-libs/nss_ldap/files/nsswitch.ldap.diff
new file mode 100644
index 000000000000..a8e96e05e8d8
--- /dev/null
+++ b/net-libs/nss_ldap/files/nsswitch.ldap.diff
@@ -0,0 +1,15 @@
+--- nsswitch.ldap 2004-06-08 00:34:09.895330016 -0500
++++ nsswitch.ldap-modified 2004-06-08 00:35:21.518441648 -0500
+@@ -10,10 +10,10 @@
+ passwd: files ldap
+ group: files ldap
+
+-# consult DNS first, we will need it to resolve the LDAP host. (If we
++# consult files/dns first, we will need it to resolve the LDAP host. (If we
+ # can't resolve it, we're in infinite recursion, because libldap calls
+ # gethostbyname(). Careful!)
+-hosts: dns ldap
++hosts: files dns ldap
+
+ # LDAP is nominally authoritative for the following maps.
+ services: ldap [NOTFOUND=return] files
diff --git a/net-libs/nss_ldap/nss_ldap-215-r1.ebuild b/net-libs/nss_ldap/nss_ldap-215-r1.ebuild
index 632f2ee0dd8d..ec33932a8af0 100644
--- a/net-libs/nss_ldap/nss_ldap-215-r1.ebuild
+++ b/net-libs/nss_ldap/nss_ldap-215-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/nss_ldap/nss_ldap-215-r1.ebuild,v 1.6 2004/06/06 10:06:48 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/nss_ldap/nss_ldap-215-r1.ebuild,v 1.7 2004/06/08 05:43:30 raker Exp $
inherit fixheadtails eutils
@@ -21,6 +21,8 @@ src_unpack() {
unpack ${A}
# bug #34717
epatch ${FILESDIR}/db4_1.85.diff
+ cd ${S}
+ epatch ${FILESDIR}/nsswitch.ldap.diff
}
src_compile() {