summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorD.M.D. Ljungmark <spider@gentoo.org>2002-05-22 23:27:50 +0000
committerD.M.D. Ljungmark <spider@gentoo.org>2002-05-22 23:27:50 +0000
commitc2a2f6cf9e7fb900c0a011f43eca19029eff5db0 (patch)
treeb2073a2483e0b7c950732d6377a601df900b9148 /net-libs
parentadded xmms dual scope plugin (diff)
downloadgentoo-2-c2a2f6cf9e7fb900c0a011f43eca19029eff5db0.tar.gz
gentoo-2-c2a2f6cf9e7fb900c0a011f43eca19029eff5db0.tar.bz2
gentoo-2-c2a2f6cf9e7fb900c0a011f43eca19029eff5db0.zip
adding linc to portage
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/linc/ChangeLog9
-rw-r--r--net-libs/linc/files/digest-linc-0.1.21-r11
-rw-r--r--net-libs/linc/linc-0.1.21-r1.ebuild58
3 files changed, 68 insertions, 0 deletions
diff --git a/net-libs/linc/ChangeLog b/net-libs/linc/ChangeLog
new file mode 100644
index 000000000000..a69d344907e5
--- /dev/null
+++ b/net-libs/linc/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for net-libs/linc
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/linc/ChangeLog,v 1.1 2002/05/22 23:27:50 spider Exp $
+
+
+*linc-0.1.21-r1 (22 May 2002)
+ 22 May 2002; Spider <spider@gentoo.org> linc-0.1.21-r1.ebuild ChangeLog:
+ Added linc, a library that eases the writing of services that uses
+networking, needs ssl and is used in Gnome2
diff --git a/net-libs/linc/files/digest-linc-0.1.21-r1 b/net-libs/linc/files/digest-linc-0.1.21-r1
new file mode 100644
index 000000000000..0631c92ef69b
--- /dev/null
+++ b/net-libs/linc/files/digest-linc-0.1.21-r1
@@ -0,0 +1 @@
+MD5 2ade39312be6bfc7e85b2e106218c8c1 linc-0.1.21.tar.bz2 175550
diff --git a/net-libs/linc/linc-0.1.21-r1.ebuild b/net-libs/linc/linc-0.1.21-r1.ebuild
new file mode 100644
index 000000000000..e609b1103e28
--- /dev/null
+++ b/net-libs/linc/linc-0.1.21-r1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author: Spider <spider@gentoo.org>
+# Maintainer: Spider <spider@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-libs/linc/linc-0.1.21-r1.ebuild,v 1.1 2002/05/22 23:27:50 spider Exp $
+
+# Do _NOT_ strip symbols in the build! Need both lines for Portage 1.8.9+
+DEBUG="yes"
+RESTRICT="nostrip"
+# force debug information
+CFLAGS="${CFLAGS} -g"
+CXXFLAGS="${CXXFLAGS} -g"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A library to ease the writing of networked applications"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/pre-gnome2/sources/${PN}/${P}.tar.bz2"
+HOMEPAGE="http://www.gnome.org/"
+SLOT="0"
+LICENSE="LGPL-2.1"
+
+RDEPEND=">=dev-libs/glib-2.0.0
+ >=dev-libs/openssl-0.9.6"
+
+DEPEND="${RDEPEND}
+ doc? ( >=dev-util/gtk-doc-0.9-r2 )
+ >=dev-util/pkgconfig-0.12.0"
+
+src_compile() {
+# libtoolize --copy --force
+ local myconf
+ use doc && myconf="${myconf} --enable-gtk-doc" || myconf="${myconf} --disable-gtk-doc"
+
+ # if this is disabled (use) ORBit2 will fail to build. Just force it on
+ myconf="${myconf} --with-openssl"
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ ${myconf} \
+ --enable-debug=yes || die
+ emake || die
+}
+
+src_install() {
+ make prefix=${D}/usr \
+ sysconfdir=${D}/etc \
+ infodir=${D}/usr/share/info \
+ mandir=${D}/usr/share/man \
+ install || die
+
+ dodoc AUTHORS ChangeLog COPYING HACKING MAINTAINERS README* INSTALL NEWS TODO
+}
+
+
+
+
+