summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2005-03-15 07:50:41 +0000
committerAlin Năstac <mrness@gentoo.org>2005-03-15 07:50:41 +0000
commit91b42dacc4c63666dc9581bae1b57002bc7ab9e8 (patch)
tree6e39ec36304fe19996c0469c06022608b98d3a4b /net-libs
parentNew ebuild. (diff)
downloadgentoo-2-91b42dacc4c63666dc9581bae1b57002bc7ab9e8.tar.gz
gentoo-2-91b42dacc4c63666dc9581bae1b57002bc7ab9e8.tar.bz2
gentoo-2-91b42dacc4c63666dc9581bae1b57002bc7ab9e8.zip
fix broken build when pam not set
(Portage version: 2.0.51.19)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/wvstreams/ChangeLog6
-rw-r--r--net-libs/wvstreams/files/wvstreams-4.0.1-without-pam.patch12
-rw-r--r--net-libs/wvstreams/wvstreams-4.0.1-r2.ebuild5
3 files changed, 20 insertions, 3 deletions
diff --git a/net-libs/wvstreams/ChangeLog b/net-libs/wvstreams/ChangeLog
index 35038c5eecf2..d1b59b986793 100644
--- a/net-libs/wvstreams/ChangeLog
+++ b/net-libs/wvstreams/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-libs/wvstreams
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/wvstreams/ChangeLog,v 1.43 2005/03/14 20:08:28 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/wvstreams/ChangeLog,v 1.44 2005/03/15 07:50:41 mrness Exp $
+
+ 15 Mar 2005; Alin Nastac <mrness@gentoo.org>
+ +files/wvstreams-4.0.1-without-pam.patch, wvstreams-4.0.1-r2.ebuild:
+ Fix broken build when pam flag isn't set (#84817).
14 Mar 2005; Michael Hanselmann <hansmi@gentoo.org>
wvstreams-4.0.1-r2.ebuild:
diff --git a/net-libs/wvstreams/files/wvstreams-4.0.1-without-pam.patch b/net-libs/wvstreams/files/wvstreams-4.0.1-without-pam.patch
new file mode 100644
index 000000000000..7540ef0c4a0c
--- /dev/null
+++ b/net-libs/wvstreams/files/wvstreams-4.0.1-without-pam.patch
@@ -0,0 +1,12 @@
+diff -Nru wvstreams-4.0.1.orig/streams/wvpam.cc wvstreams-4.0.1/streams/wvpam.cc
+--- wvstreams-4.0.1.orig/streams/wvpam.cc 2004-11-18 16:15:05.000000000 +0200
++++ wvstreams-4.0.1/streams/wvpam.cc 2005-03-15 09:38:36.416927072 +0200
+@@ -68,7 +68,7 @@
+
+ bool WvPam::authenticate(WvStringParm rhost, WvStringParm user, WvStringParm password)
+ {
+- return fail;
++ return false;
+ }
+
+ WvString WvPam::getuser() const
diff --git a/net-libs/wvstreams/wvstreams-4.0.1-r2.ebuild b/net-libs/wvstreams/wvstreams-4.0.1-r2.ebuild
index f583c9db07fa..12eb8834f1c7 100644
--- a/net-libs/wvstreams/wvstreams-4.0.1-r2.ebuild
+++ b/net-libs/wvstreams/wvstreams-4.0.1-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/wvstreams/wvstreams-4.0.1-r2.ebuild,v 1.3 2005/03/14 20:08:28 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/wvstreams/wvstreams-4.0.1-r2.ebuild,v 1.4 2005/03/15 07:50:41 mrness Exp $
inherit eutils
@@ -38,7 +38,8 @@ DEPEND="${RDEPEND}
src_unpack() {
unpack ${A} ; cd ${S}
- epatch ${FILESDIR}/${P}-linux-serial.patch || die "failed to patch"
+ epatch ${FILESDIR}/${P}-linux-serial.patch
+ epatch ${FILESDIR}/${P}-without-pam.patch
if useq tcltk; then
epatch ${FILESDIR}/${P}-tcl_8_4.patch