summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2013-05-09 03:17:32 +0000
committerJeroen Roovers <jer@gentoo.org>2013-05-09 03:17:32 +0000
commit89a5fef4d1cb16a744d6cb1ab5cc0ae0dc2c02a9 (patch)
treeee63bdd33e72aa2290418453e8b06694bf2f0130 /net-libs
parentVersion bump. (diff)
downloadgentoo-2-89a5fef4d1cb16a744d6cb1ab5cc0ae0dc2c02a9.tar.gz
gentoo-2-89a5fef4d1cb16a744d6cb1ab5cc0ae0dc2c02a9.tar.bz2
gentoo-2-89a5fef4d1cb16a744d6cb1ab5cc0ae0dc2c02a9.zip
Version bump.
(Portage version: 2.2.0_alpha174/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libpcap/ChangeLog7
-rw-r--r--net-libs/libpcap/libpcap-1.4.0.ebuild63
2 files changed, 69 insertions, 1 deletions
diff --git a/net-libs/libpcap/ChangeLog b/net-libs/libpcap/ChangeLog
index 27b206594598..20056932d22d 100644
--- a/net-libs/libpcap/ChangeLog
+++ b/net-libs/libpcap/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/libpcap
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libpcap/ChangeLog,v 1.181 2013/02/20 22:57:19 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libpcap/ChangeLog,v 1.182 2013/05/09 03:17:32 jer Exp $
+
+*libpcap-1.4.0 (09 May 2013)
+
+ 09 May 2013; Jeroen Roovers <jer@gentoo.org> +libpcap-1.4.0.ebuild:
+ Version bump.
20 Feb 2013; Zac Medico <zmedico@gentoo.org> libpcap-1.3.0-r1.ebuild:
Add ~arm-linux keyword.
diff --git a/net-libs/libpcap/libpcap-1.4.0.ebuild b/net-libs/libpcap/libpcap-1.4.0.ebuild
new file mode 100644
index 000000000000..f8e78010a7c6
--- /dev/null
+++ b/net-libs/libpcap/libpcap-1.4.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libpcap/libpcap-1.4.0.ebuild,v 1.1 2013/05/09 03:17:32 jer Exp $
+
+EAPI=5
+inherit autotools eutils
+
+DESCRIPTION="A system-independent library for user-level network packet capture"
+HOMEPAGE="http://www.tcpdump.org/"
+SRC_URI="http://www.tcpdump.org/release/${P}.tar.gz
+ http://www.jp.tcpdump.org/release/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="bluetooth ipv6 netlink static-libs canusb"
+
+RDEPEND="
+ bluetooth? ( net-wireless/bluez )
+ netlink? ( dev-libs/libnl )
+ canusb? ( virtual/libusb )
+"
+DEPEND="${RDEPEND}
+ sys-devel/flex
+ virtual/yacc
+"
+
+DOCS=( CREDITS CHANGES VERSION TODO README{,.dag,.linux,.macosx,.septel} )
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.2.0-cross-linux.patch
+
+ # Prefix' Solaris uses GNU ld
+ sed -i -e 's/freebsd\*/freebsd*|solaris*/' \
+ -e 's/sparc64\*/sparc64*|sparcv9*/' aclocal.m4 || die
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable bluetooth) \
+ $(use_enable ipv6) \
+ $(use_enable canusb) \
+ $(use_with netlink libnl)
+}
+
+src_compile() {
+ emake all shared
+}
+
+src_install() {
+ default
+
+ # remove static libraries (--disable-static does not work)
+ prune_libtool_files
+
+ # We need this to build pppd on G/FBSD systems
+ if [[ "${USERLAND}" == "BSD" ]]; then
+ insinto /usr/include
+ doins pcap-int.h
+ fi
+}