summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2011-01-12 23:21:45 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2011-01-12 23:21:45 +0000
commit6c5187bac86754c187361b877b36b894ae1aace7 (patch)
tree68cea8ed860372a80b44d0249be2417ea1183136 /net-libs
parentVersion bump. Macro now exits when gob is not found and other minor updates. (diff)
downloadgentoo-2-6c5187bac86754c187361b877b36b894ae1aace7.tar.gz
gentoo-2-6c5187bac86754c187361b877b36b894ae1aace7.tar.bz2
gentoo-2-6c5187bac86754c187361b877b36b894ae1aace7.zip
Version bump; add patch to respect ldflags properly.
(Portage version: 2.2.0_alpha14/cvs/Linux x86_64)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/liboauth/ChangeLog10
-rw-r--r--net-libs/liboauth/files/liboauth-0.9.1-ldflags.patch13
-rw-r--r--net-libs/liboauth/liboauth-0.9.1.ebuild94
3 files changed, 115 insertions, 2 deletions
diff --git a/net-libs/liboauth/ChangeLog b/net-libs/liboauth/ChangeLog
index 37d8acc2e599..036347b9cdd6 100644
--- a/net-libs/liboauth/ChangeLog
+++ b/net-libs/liboauth/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/liboauth
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/liboauth/ChangeLog,v 1.4 2010/09/10 12:31:22 flameeyes Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/liboauth/ChangeLog,v 1.5 2011/01/12 23:21:44 flameeyes Exp $
+
+*liboauth-0.9.1 (12 Jan 2011)
+
+ 12 Jan 2011; Diego E. Pettenò <flameeyes@gentoo.org> +liboauth-0.9.1.ebuild,
+ +files/liboauth-0.9.1-ldflags.patch:
+ Version bump; add patch to respect ldflags properly.
*liboauth-0.9.0 (10 Sep 2010)
diff --git a/net-libs/liboauth/files/liboauth-0.9.1-ldflags.patch b/net-libs/liboauth/files/liboauth-0.9.1-ldflags.patch
new file mode 100644
index 000000000000..cff5d7887d61
--- /dev/null
+++ b/net-libs/liboauth/files/liboauth-0.9.1-ldflags.patch
@@ -0,0 +1,13 @@
+Index: liboauth-0.9.1/configure.ac
+===================================================================
+--- liboauth-0.9.1.orig/configure.ac
++++ liboauth-0.9.1/configure.ac
+@@ -81,7 +81,7 @@ LIBOAUTH_LDFLAGS="${LIBOAUTH_CFLAGS} -ex
+ #LIBOAUTH_CFLAGS="${LIBOAUTH_CFLAGS} -g -posix -std=c99 -pedantic"
+
+ AC_MSG_CHECKING([if -Wl,--as-needed works])
+-LFDLAGS_save=$LDFLAGS
++LDFLAGS_save=$LDFLAGS
+ LDFLAGS="$LDFLAGS -Wl,--as-needed"
+ AC_TRY_LINK([], [],
+ [
diff --git a/net-libs/liboauth/liboauth-0.9.1.ebuild b/net-libs/liboauth/liboauth-0.9.1.ebuild
new file mode 100644
index 000000000000..6a5e10315972
--- /dev/null
+++ b/net-libs/liboauth/liboauth-0.9.1.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/liboauth/liboauth-0.9.1.ebuild,v 1.1 2011/01/12 23:21:44 flameeyes Exp $
+
+EAPI=2
+
+inherit eutils autotools
+
+DESCRIPTION="C library implementing the OAuth secure authentication protocol"
+HOMEPAGE="http://liboauth.sourceforge.net/"
+SRC_URI="http://liboauth.sourceforge.net/pool/${P}.tar.gz"
+
+LICENSE="|| ( GPL-2 MIT )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="curl doc bindist +nss"
+
+CDEPEND="
+ nss? ( dev-libs/nss
+ curl? ( || ( net-misc/curl[ssl,nss,-gnutls] net-misc/curl[-ssl] ) )
+ )
+
+ bindist? ( dev-libs/nss
+ curl? ( || ( net-misc/curl[ssl,nss,-gnutls] net-misc/curl[-ssl] ) )
+ )
+
+ !bindist? (
+ !nss? ( dev-libs/openssl
+ curl? ( || ( net-misc/curl[ssl,-nss,-gnutls] net-misc/curl[-ssl] ) )
+ )
+ )
+
+ net-misc/curl
+"
+
+RDEPEND="${CDEPEND}"
+
+DEPEND="${CDEPEND}
+ doc? (
+ app-doc/doxygen
+ media-gfx/graphviz
+ media-fonts/freefont-ttf
+ )
+ dev-util/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-ldflags.patch"
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=
+
+ if use nss || use bindist; then
+ myconf="${myconf} --enable-nss"
+ else
+ myconf="${myconf} --disable-nss"
+ fi
+
+ econf \
+ --disable-dependency-tracking \
+ --enable-fast-install \
+ --disable-static \
+ $(use_enable !curl curl) \
+ $(use_enable curl libcurl) \
+ ${myconf}
+}
+
+src_compile() {
+ emake || die "emake failed"
+
+ if use doc ; then
+ # make sure fonts are found
+ export DOTFONTPATH=/usr/share/fonts/freefont-ttf
+ emake dox || die "emake dox failed"
+ fi
+}
+
+src_test() {
+ # explicitly allow parallel test build
+ emake check || die "emake check failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+
+ find "${D}" -name '*.la' -delete || die
+
+ dodoc AUTHORS ChangeLog LICENSE.OpenSSL NEWS README || die "dodoc failed"
+
+ if use doc; then
+ dohtml -r doc/html/* || die "dohtml failed"
+ fi
+}