summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEray Aslan <eras@gentoo.org>2011-12-18 14:35:28 +0000
committerEray Aslan <eras@gentoo.org>2011-12-18 14:35:28 +0000
commit682f0f783d044abe11f76928e0fe72430005fa67 (patch)
treeb07cd77ac5e5a836e5702c11791075b335a02731 /net-libs
parentRemove old versions. (diff)
downloadgentoo-2-682f0f783d044abe11f76928e0fe72430005fa67.tar.gz
gentoo-2-682f0f783d044abe11f76928e0fe72430005fa67.tar.bz2
gentoo-2-682f0f783d044abe11f76928e0fe72430005fa67.zip
version bump and remove old patches
(Portage version: 2.1.10.41/cvs/Linux x86_64)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/liblockfile/ChangeLog8
-rw-r--r--net-libs/liblockfile/files/liblockfile-1.06-glibc24.patch14
-rw-r--r--net-libs/liblockfile/liblockfile-1.09.ebuild36
3 files changed, 43 insertions, 15 deletions
diff --git a/net-libs/liblockfile/ChangeLog b/net-libs/liblockfile/ChangeLog
index fe976ee1a424..6cc6c7d41ce4 100644
--- a/net-libs/liblockfile/ChangeLog
+++ b/net-libs/liblockfile/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/liblockfile
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/liblockfile/ChangeLog,v 1.61 2011/06/08 07:50:30 eras Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/liblockfile/ChangeLog,v 1.62 2011/12/18 14:35:28 eras Exp $
+
+*liblockfile-1.09 (18 Dec 2011)
+
+ 18 Dec 2011; Eray Aslan <eras@gentoo.org>
+ -files/liblockfile-1.06-glibc24.patch, +liblockfile-1.09.ebuild:
+ version bump and remove old patches
08 Jun 2011; Eray Aslan <eras@gentoo.org> -liblockfile-1.06-r2.ebuild:
Remove old
diff --git a/net-libs/liblockfile/files/liblockfile-1.06-glibc24.patch b/net-libs/liblockfile/files/liblockfile-1.06-glibc24.patch
deleted file mode 100644
index 8d74decdad80..000000000000
--- a/net-libs/liblockfile/files/liblockfile-1.06-glibc24.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-Index: liblockfile-1.06/configure.in
-===================================================================
---- liblockfile-1.06.orig/configure.in
-+++ liblockfile-1.06/configure.in
-@@ -7,7 +7,7 @@ AC_PROG_CC
-
- dnl Set Default CFLAGS
- if test "$GCC" = "yes"; then
-- CFLAGS="$CFLAGS -Wall -D_GNU_SOURCE"
-+ CFLAGS="$CFLAGS -Wall"
- fi
-
- TARGETS="static"
-
diff --git a/net-libs/liblockfile/liblockfile-1.09.ebuild b/net-libs/liblockfile/liblockfile-1.09.ebuild
new file mode 100644
index 000000000000..d1d095be9139
--- /dev/null
+++ b/net-libs/liblockfile/liblockfile-1.09.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/liblockfile/liblockfile-1.09.ebuild,v 1.1 2011/12/18 14:35:28 eras Exp $
+
+EAPI=4
+
+inherit eutils multilib autotools
+
+DESCRIPTION="Implements functions designed to lock the standard mailboxes"
+HOMEPAGE="http://www.debian.org/"
+SRC_URI="mirror://debian/pool/main/libl/${PN}/${PN}_${PV}.orig.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE=""
+
+pkg_setup() {
+ enewgroup mail 12
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.06-respectflags.patch
+ epatch "${FILESDIR}"/${PN}-orphan-file.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf --with-mailgroup=mail --enable-shared
+}
+
+src_install() {
+ dodir /usr/{bin,include,$(get_libdir)} /usr/share/man/{man1,man3}
+ emake ROOT="${ED}" install
+ dodoc README Changelog
+}