summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2007-07-19 08:58:15 +0000
committerRaúl Porcel <armin76@gentoo.org>2007-07-19 08:58:15 +0000
commit093eadbf773ac6ba85f8de6fc6e9d73afce90a26 (patch)
tree9e89915e94fae9346b1e592698e55ec158db1d78 /net-libs
parentminor: fix indentation (diff)
downloadgentoo-2-093eadbf773ac6ba85f8de6fc6e9d73afce90a26.tar.gz
gentoo-2-093eadbf773ac6ba85f8de6fc6e9d73afce90a26.tar.bz2
gentoo-2-093eadbf773ac6ba85f8de6fc6e9d73afce90a26.zip
Version bump
(Portage version: 2.1.3_rc8)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/rb_libtorrent/ChangeLog8
-rw-r--r--net-libs/rb_libtorrent/files/digest-rb_libtorrent-0.13_pre14093
-rw-r--r--net-libs/rb_libtorrent/rb_libtorrent-0.13_pre1409.ebuild50
3 files changed, 60 insertions, 1 deletions
diff --git a/net-libs/rb_libtorrent/ChangeLog b/net-libs/rb_libtorrent/ChangeLog
index 4b877c12410e..94d23e3ad04a 100644
--- a/net-libs/rb_libtorrent/ChangeLog
+++ b/net-libs/rb_libtorrent/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/rb_libtorrent
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/ChangeLog,v 1.17 2007/06/27 17:58:44 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/ChangeLog,v 1.18 2007/07/19 08:58:15 armin76 Exp $
+
+*rb_libtorrent-0.13_pre1409 (19 Jul 2007)
+
+ 19 Jul 2007; Raúl Porcel <armin76@gentoo.org>
+ +rb_libtorrent-0.13_pre1409.ebuild:
+ Version bump
27 Jun 2007; Raúl Porcel <armin76@gentoo.org> -rb_libtorrent-0.11.ebuild:
old
diff --git a/net-libs/rb_libtorrent/files/digest-rb_libtorrent-0.13_pre1409 b/net-libs/rb_libtorrent/files/digest-rb_libtorrent-0.13_pre1409
new file mode 100644
index 000000000000..58657d5819e6
--- /dev/null
+++ b/net-libs/rb_libtorrent/files/digest-rb_libtorrent-0.13_pre1409
@@ -0,0 +1,3 @@
+MD5 15e8e2e5a914fda7e207d82dd56cc159 libtorrent-0.13_pre1409.tar.bz2 1439722
+RMD160 434efc9e8d1878150ab95456ec268119d2e4d645 libtorrent-0.13_pre1409.tar.bz2 1439722
+SHA256 7ba33c25eeeb16d715578663630ac62434e928af277f2d19362223478ebdb863 libtorrent-0.13_pre1409.tar.bz2 1439722
diff --git a/net-libs/rb_libtorrent/rb_libtorrent-0.13_pre1409.ebuild b/net-libs/rb_libtorrent/rb_libtorrent-0.13_pre1409.ebuild
new file mode 100644
index 000000000000..bc815ec5b54a
--- /dev/null
+++ b/net-libs/rb_libtorrent/rb_libtorrent-0.13_pre1409.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/rb_libtorrent-0.13_pre1409.ebuild,v 1.1 2007/07/19 08:58:15 armin76 Exp $
+
+WANT_AUTOCONF="latest"
+WANT_AUTOMAKE="latest"
+inherit eutils autotools
+
+MY_P="${P/rb_/}"
+
+DESCRIPTION="BitTorrent library written in C++ for *nix."
+HOMEPAGE="http://www.rasterbar.com/products/libtorrent/"
+SRC_URI="mirror://gentoo/${MY_P}.tar.bz2"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE="debug"
+
+DEPEND="dev-libs/boost
+ !net-libs/libtorrent"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ # We need boost built with threads
+ if ! has_version ">=dev-libs/boost-1.34_pre20061214" && \
+ ! built_with_use "dev-libs/boost" threads; then
+ eerror "${PN} needs dev-libs/boost built with threads USE flag"
+ die "dev-libs/boost is built without threads USE flag"
+ fi
+}
+
+src_compile() {
+ BOOST_LIBS="--with-boost-date-time=boost_date_time-mt \
+ --with-boost-filesystem=boost_filesystem-mt \
+ --with-boost-thread=boost_thread-mt \
+ --with-boost-regex=boost_regex-mt \
+ --with-boost-program_options=boost_program_options-mt"
+
+ econf $(use_enable debug) \
+ ${BOOST_LIBS} \
+ LDFLAGS="${LDFLAGS} -pthread" || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc ChangeLog AUTHORS NEWS README
+}