summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Ullmann <jokey@gentoo.org>2009-04-05 15:33:05 +0000
committerMarkus Ullmann <jokey@gentoo.org>2009-04-05 15:33:05 +0000
commit0dd75c963d4516b160f083c4072ecf62d85258c5 (patch)
treeace1bad98bfcac7b0c366559f339335e1e18dd73 /net-libs/webkit-gtk
parentMask newer webkit-gtk for soup dependency (diff)
downloadgentoo-2-0dd75c963d4516b160f083c4072ecf62d85258c5.tar.gz
gentoo-2-0dd75c963d4516b160f083c4072ecf62d85258c5.tar.bz2
gentoo-2-0dd75c963d4516b160f083c4072ecf62d85258c5.zip
Version bump
(Portage version: 2.2_rc28/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/webkit-gtk')
-rw-r--r--net-libs/webkit-gtk/ChangeLog8
-rw-r--r--net-libs/webkit-gtk/webkit-gtk-0_p42162.ebuild73
2 files changed, 80 insertions, 1 deletions
diff --git a/net-libs/webkit-gtk/ChangeLog b/net-libs/webkit-gtk/ChangeLog
index a965675797f9..d1722c53e07a 100644
--- a/net-libs/webkit-gtk/ChangeLog
+++ b/net-libs/webkit-gtk/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/webkit-gtk
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/webkit-gtk/ChangeLog,v 1.22 2009/03/20 23:26:44 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/webkit-gtk/ChangeLog,v 1.23 2009/04/05 15:33:05 jokey Exp $
+
+*webkit-gtk-0_p42162 (05 Apr 2009)
+
+ 05 Apr 2009; Markus Ullmann <jokey@gentoo.org>
+ +webkit-gtk-0_p42162.ebuild:
+ Version bump
20 Mar 2009; Markus Meier <maekke@gentoo.org> webkit-gtk-0_p40220.ebuild:
amd64/x86 stable, bug #246816
diff --git a/net-libs/webkit-gtk/webkit-gtk-0_p42162.ebuild b/net-libs/webkit-gtk/webkit-gtk-0_p42162.ebuild
new file mode 100644
index 000000000000..c850b458b6ea
--- /dev/null
+++ b/net-libs/webkit-gtk/webkit-gtk-0_p42162.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/webkit-gtk/webkit-gtk-0_p42162.ebuild,v 1.1 2009/04/05 15:33:05 jokey Exp $
+
+EAPI=2
+
+inherit autotools flag-o-matic
+
+MY_P="WebKit-r${PV/0\_p}"
+DESCRIPTION="Open source web browser engine"
+HOMEPAGE="http://www.webkit.org/"
+SRC_URI="http://nightly.webkit.org/files/trunk/src/${MY_P}.tar.bz2"
+
+LICENSE="LGPL-2 LGPL-2.1 BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 -ia64 ~ppc -sparc ~x86"
+IUSE="coverage debug gstreamer pango soup +sqlite svg xslt"
+
+RDEPEND=">=x11-libs/gtk+-2.8
+ >=dev-libs/icu-3.8.1-r1
+ >=net-misc/curl-7.15
+ media-libs/jpeg
+ media-libs/libpng
+ dev-libs/libxml2
+ sqlite? ( >=dev-db/sqlite-3 )
+ gstreamer? (
+ >=media-libs/gst-plugins-base-0.10
+ )
+ soup? ( >=net-libs/libsoup-2.26 )
+ xslt? ( dev-libs/libxslt )
+ pango? ( x11-libs/pango )"
+
+DEPEND="${RDEPEND}
+ >=sys-devel/flex-2.5.33
+ dev-util/gperf
+ dev-util/pkgconfig
+ virtual/perl-Text-Balanced
+ dev-util/gtk-doc"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ AT_M4DIR=./autotools
+ gtkdocize
+ eautoreconf
+}
+
+src_configure() {
+ # It doesn't compile on alpha without this LDFLAGS
+ use alpha && append-ldflags "-Wl,--no-relax"
+
+ local myconf
+ use pango && myconf="${myconf} --with-font-backend=pango"
+ use soup && myconf="${myconf} --with-http-backend=soup"
+
+ econf \
+ $(use_enable sqlite database) \
+ $(use_enable sqlite icon-database) \
+ $(use_enable sqlite dom-storage) \
+ $(use_enable sqlite offline-web-applications) \
+ $(use_enable gstreamer video) \
+ $(use_enable svg) \
+ $(use_enable debug) \
+ $(use_enable xslt) \
+ $(use_enable coverage) \
+ $(use_enable doc gtk-doc) \
+ ${myconf} \
+ || die "configure failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Install failed"
+}