summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2006-05-05 10:35:50 +0000
committerStefan Schweizer <genstef@gentoo.org>2006-05-05 10:35:50 +0000
commit53dd769c1001c3ef2a847c2e522f4cf2662ac4b6 (patch)
treecc773fe3dc3e625f8b1d56fe1fffb33e41c000bc /net-libs/ortp
parentinitial ebuild (diff)
downloadgentoo-2-53dd769c1001c3ef2a847c2e522f4cf2662ac4b6.tar.gz
gentoo-2-53dd769c1001c3ef2a847c2e522f4cf2662ac4b6.tar.bz2
gentoo-2-53dd769c1001c3ef2a847c2e522f4cf2662ac4b6.zip
Version bump thanks to Lukáš Polívka <lukas.polivka@gmail.com> in bug 132287
Diffstat (limited to 'net-libs/ortp')
-rw-r--r--net-libs/ortp/ortp-0.9.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/net-libs/ortp/ortp-0.9.1.ebuild b/net-libs/ortp/ortp-0.9.1.ebuild
new file mode 100644
index 000000000000..2fc89d987217
--- /dev/null
+++ b/net-libs/ortp/ortp-0.9.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/ortp/ortp-0.9.1.ebuild,v 1.1 2006/05/05 10:35:50 genstef Exp $
+
+DESCRIPTION="Open Real-time Transport Protocol (RTP) stack"
+HOMEPAGE="http://www.linphone.org/ortp/"
+SRC_URI="http://www.linphone.org/ortp/sources/${P}.tar.gz"
+
+IUSE="ipv6"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~amd64"
+
+DEPEND="=dev-libs/glib-2*
+ >=dev-util/pkgconfig-0.9.0"
+RDEPEND="=dev-libs/glib-2*"
+
+src_compile() {
+ econf --disable-ewarning \
+ $(use_enable ipv6) || die 'configure failed'
+ emake || die 'make compile failed'
+}
+
+src_install() {
+ emake DESTDIR=${D} install || die "Make install failed"
+ sed -i -e "s:^\(#include <\)\(glib\.h>\)$:\1glib-2.0/\2:" ${D}/usr/include/ortp/rtpport.h
+
+ dodoc README ChangeLog AUTHORS TODO NEWS
+ dodoc docs/*.txt
+}