summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-10-28 14:35:43 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-10-28 14:35:43 +0000
commitd6b4cbe72e2b918f22a9346d1162624a15fe4da7 (patch)
tree3a966af3b6090014b0b782b6f9d6ca8225470300 /net-libs/openh323
parentold (diff)
downloadgentoo-2-d6b4cbe72e2b918f22a9346d1162624a15fe4da7.tar.gz
gentoo-2-d6b4cbe72e2b918f22a9346d1162624a15fe4da7.tar.bz2
gentoo-2-d6b4cbe72e2b918f22a9346d1162624a15fe4da7.zip
quoting
(Portage version: 2.2.0_alpha1/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/openh323')
-rw-r--r--net-libs/openh323/openh323-1.18.0.ebuild22
1 files changed, 11 insertions, 11 deletions
diff --git a/net-libs/openh323/openh323-1.18.0.ebuild b/net-libs/openh323/openh323-1.18.0.ebuild
index cc3dd43e38a4..ac7544363a82 100644
--- a/net-libs/openh323/openh323-1.18.0.ebuild
+++ b/net-libs/openh323/openh323-1.18.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/openh323/openh323-1.18.0.ebuild,v 1.9 2009/03/12 19:36:43 klausman Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/openh323/openh323-1.18.0.ebuild,v 1.10 2010/10/28 14:35:43 ssuominen Exp $
inherit eutils flag-o-matic multilib
@@ -27,13 +27,13 @@ pkg_setup() {
}
src_unpack() {
- tar -xzf ${DISTDIR}/${A} -C ${WORKDIR} || die "Unpacking failed"
+ tar -xzf "${DISTDIR}"/${A} -C "${WORKDIR}" || die
- cd ${S}
+ cd "${S}"
# Makefile does not work correctly, fix
- epatch ${FILESDIR}/${PN}-1.18.0-install.diff
+ epatch "${FILESDIR}"/${PN}-1.18.0-install.diff
# Do not include compiler.h, bug #168791
- epatch "${FILESDIR}/${P}-compilerh.patch"
+ epatch "${FILESDIR}"/${P}-compilerh.patch
}
src_compile() {
@@ -51,16 +51,16 @@ src_compile() {
}
src_install() {
- emake ${makeopts} PREFIX=/usr DESTDIR=${D} install || die "emake install failed"
+ emake ${makeopts} PREFIX=/usr DESTDIR="${D}" install || die
###
# Compatibility "hacks"
#
# debug / no debug use different suffixes - some packages build with only one
- for i in ${D}/usr/lib/libh323_linux_x86_*; do
- use debug && ln -s ${D}/usr/lib/libh323_linux_x86_*.so.*.*.* ${i/_r/_n} \
- || ln -s ${D}/usr/lib/libh323_linux_x86_*.so.*.*.* ${i/_n/_r}
+ for i in "${D}"/usr/lib/libh323_linux_x86_*; do
+ use debug && ln -s "${D}"/usr/lib/libh323_linux_x86_*.so.*.*.* ${i/_r/_n} \
+ || ln -s "${D}"/usr/lib/libh323_linux_x86_*.so.*.*.* ${i/_n/_r}
done
# set notrace corerctly
@@ -69,7 +69,7 @@ src_install() {
# mod to keep gnugk happy
insinto /usr/share/openh323/src
echo -e "opt:\n\t:" > ${T}/Makefile
- doins ${T}/Makefile
+ doins "${T}"/Makefile
# these should point to the right directories,
# openh323.org apps and others need this