summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Loeser <halcy0n@gentoo.org>2006-05-01 18:06:17 +0000
committerMark Loeser <halcy0n@gentoo.org>2006-05-01 18:06:17 +0000
commit1df7c73f7e64d977de1ab45871034d03a67df9bc (patch)
treed44593b4011aa117b97c697b05795499d580308b /net-libs/openh323
parentAdded to ~ppc, bug #131814 (diff)
downloadgentoo-2-1df7c73f7e64d977de1ab45871034d03a67df9bc.tar.gz
gentoo-2-1df7c73f7e64d977de1ab45871034d03a67df9bc.tar.bz2
gentoo-2-1df7c73f7e64d977de1ab45871034d03a67df9bc.zip
Add patch to fix compilation with gcc-4.1 by Åsmund Grammeltvedt <grammel@online.no>; bug #129447
(Portage version: 2.1_pre9-r5)
Diffstat (limited to 'net-libs/openh323')
-rw-r--r--net-libs/openh323/ChangeLog9
-rw-r--r--net-libs/openh323/files/digest-openh323-1.15.62
-rw-r--r--net-libs/openh323/files/openh323-1.15.6-gcc4.diff33
-rw-r--r--net-libs/openh323/openh323-1.15.6.ebuild7
4 files changed, 46 insertions, 5 deletions
diff --git a/net-libs/openh323/ChangeLog b/net-libs/openh323/ChangeLog
index 589363b04500..f4ab14ca3bbc 100644
--- a/net-libs/openh323/ChangeLog
+++ b/net-libs/openh323/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/openh323
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/openh323/ChangeLog,v 1.70 2005/09/16 01:37:39 agriffis Exp $
+# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/openh323/ChangeLog,v 1.71 2006/05/01 18:06:15 halcy0n Exp $
+
+ 01 May 2006; Mark Loeser <halcy0n@gentoo.org>
+ +files/openh323-1.15.6-gcc4.diff, openh323-1.15.6.ebuild:
+ Add patch to fix compilation with gcc-4.1 by Åsmund Grammeltvedt
+ <grammel@online.no>; bug #129447
15 Sep 2005; Aron Griffis <agriffis@gentoo.org> openh323-1.15.3.ebuild:
Mark 1.15.3 stable on alpha
diff --git a/net-libs/openh323/files/digest-openh323-1.15.6 b/net-libs/openh323/files/digest-openh323-1.15.6
index c8340dc764fd..c8854dc1c0b3 100644
--- a/net-libs/openh323/files/digest-openh323-1.15.6
+++ b/net-libs/openh323/files/digest-openh323-1.15.6
@@ -1 +1,3 @@
MD5 6c49f41c4cec39172000586a26b98c48 openh323-1.15.6.tar.gz 3739001
+RMD160 1242cc978a9145d5ec206656849f4ac34fcef8af openh323-1.15.6.tar.gz 3739001
+SHA256 3c1d58d999aa45f0099bf2761f1d7cf858aa9d2039056377416a79aac1327569 openh323-1.15.6.tar.gz 3739001
diff --git a/net-libs/openh323/files/openh323-1.15.6-gcc4.diff b/net-libs/openh323/files/openh323-1.15.6-gcc4.diff
new file mode 100644
index 000000000000..277c250ec52b
--- /dev/null
+++ b/net-libs/openh323/files/openh323-1.15.6-gcc4.diff
@@ -0,0 +1,33 @@
+--- openh323-1.15.6/include/ixjlid.h 2004-08-22 06:21:06.000000000 +0200
++++ openh323-1.15.6-gcc4/include/ixjlid.h 2006-04-11 20:48:51.000000000 +0200
+@@ -836,7 +836,7 @@
+ };
+
+ static void SignalHandler(int sig);
+- ExceptionInfo * OpalIxJDevice::GetException();
++ ExceptionInfo * GetException();
+ int GetOSHandle() { return os_handle; }
+
+ protected:
+--- openh323-1.15.6/src/vic/p64.cxx 2003-03-14 08:25:55.000000000 +0100
++++ openh323-1.15.6-gcc4/src/vic/p64.cxx 2006-04-11 20:49:41.000000000 +0200
+@@ -1125,7 +1125,7 @@
+ * If input buffer not aligned, prime bit-buffer
+ * with 8 bits; otherwise, prime it with a 16.
+ */
+- if ((int)bp & 1) {
++ if ((long)bp & 1) {
+ bs_ = (u_short*)(bp + 1);
+ bb_ = *bp;
+ nbb_ = 8 - sbit;
+--- openh323-1.15.6/plugins/audio/Speex/speexcodec.cxx 2006-04-11 21:32:34.000000000 +0200
++++ openh323-1.15.6-gcc4/plugins/audio/Speex/speexcodec.cxx 2006-04-11 20:48:51.000000000 +0200
+@@ -112,7 +112,7 @@
+
+ static void * create_encoder(const struct PluginCodec_Definition * codec)
+ {
+- int mode = (int)(codec->userData);
++ int mode = (long)(codec->userData);
+
+ struct PluginSpeexContext * context = new PluginSpeexContext;
+ context->bits = new SpeexBits;
diff --git a/net-libs/openh323/openh323-1.15.6.ebuild b/net-libs/openh323/openh323-1.15.6.ebuild
index 1bad03656c50..662821701bc2 100644
--- a/net-libs/openh323/openh323-1.15.6.ebuild
+++ b/net-libs/openh323/openh323-1.15.6.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/openh323/openh323-1.15.6.ebuild,v 1.1 2005/09/12 20:06:58 stkn Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/openh323/openh323-1.15.6.ebuild,v 1.2 2006/05/01 18:06:17 halcy0n Exp $
inherit eutils flag-o-matic multilib
@@ -28,7 +28,8 @@ src_unpack() {
cd ${S}
# Makefile is currently broken with NOTRACE=1, fix that
- epatch ${FILESDIR}/${PN}-1.15.2-notrace.diff
+ epatch "${FILESDIR}"/${PN}-1.15.2-notrace.diff
+ epatch "${FILESDIR}"/${P}-gcc4.diff
}
src_compile() {