summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Knoblich <stkn@gentoo.org>2005-02-03 20:11:08 +0000
committerStefan Knoblich <stkn@gentoo.org>2005-02-03 20:11:08 +0000
commit1108e249da95d0565c3ba51cc11008739988fcfa (patch)
tree3597c0dba1f0356d1ab64c6f8490b6f6b7d84b0e /net-libs/openh323
parentadded ~amd64 to KEYWORDS. fixes #75613 (diff)
downloadgentoo-2-1108e249da95d0565c3ba51cc11008739988fcfa.tar.gz
gentoo-2-1108e249da95d0565c3ba51cc11008739988fcfa.tar.bz2
gentoo-2-1108e249da95d0565c3ba51cc11008739988fcfa.zip
Cleanups and important amd64 fixes
(Portage version: 2.0.51-r15)
Diffstat (limited to 'net-libs/openh323')
-rw-r--r--net-libs/openh323/ChangeLog8
-rw-r--r--net-libs/openh323/files/digest-openh323-1.13.2-r21
-rw-r--r--net-libs/openh323/files/digest-openh323-1.13.5-r11
-rw-r--r--net-libs/openh323/files/digest-openh323-1.15.2-r11
-rw-r--r--net-libs/openh323/openh323-1.13.2-r2.ebuild137
-rw-r--r--net-libs/openh323/openh323-1.13.5-r1.ebuild138
-rw-r--r--net-libs/openh323/openh323-1.15.2-r1.ebuild142
7 files changed, 427 insertions, 1 deletions
diff --git a/net-libs/openh323/ChangeLog b/net-libs/openh323/ChangeLog
index 5ff055e06d08..2f4f5b346e90 100644
--- a/net-libs/openh323/ChangeLog
+++ b/net-libs/openh323/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/openh323
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/openh323/ChangeLog,v 1.61 2005/01/14 17:07:15 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/openh323/ChangeLog,v 1.62 2005/02/03 20:11:08 stkn Exp $
+
+*openh323-1.15.2-r1 (03 Feb 2005)
+
+ 03 Feb 2005; Stefan Knoblich <stkn@gentoo.org> +openh323-1.13.2-r2.ebuild,
+ +openh323-1.13.5-r1.ebuild, +openh323-1.15.2-r1.ebuild:
+ Cleanups and important amd64 fixes.
14 Jan 2005; <avatar@gentoo.org> openh323-1.15.2.ebuild:
Added to ~ppc.
diff --git a/net-libs/openh323/files/digest-openh323-1.13.2-r2 b/net-libs/openh323/files/digest-openh323-1.13.2-r2
new file mode 100644
index 000000000000..2f836c8e94ca
--- /dev/null
+++ b/net-libs/openh323/files/digest-openh323-1.13.2-r2
@@ -0,0 +1 @@
+MD5 b63e0ae7555facdbeab5be8b407d09b6 openh323-1.13.2.tar.gz 2197100
diff --git a/net-libs/openh323/files/digest-openh323-1.13.5-r1 b/net-libs/openh323/files/digest-openh323-1.13.5-r1
new file mode 100644
index 000000000000..8ef463ce574e
--- /dev/null
+++ b/net-libs/openh323/files/digest-openh323-1.13.5-r1
@@ -0,0 +1 @@
+MD5 c8b2bd20f1cb38796fbda554903fd6bd openh323-v1_13_5-src.tar.gz 2216406
diff --git a/net-libs/openh323/files/digest-openh323-1.15.2-r1 b/net-libs/openh323/files/digest-openh323-1.15.2-r1
new file mode 100644
index 000000000000..3b4c43407ba9
--- /dev/null
+++ b/net-libs/openh323/files/digest-openh323-1.15.2-r1
@@ -0,0 +1 @@
+MD5 53086e76eb4e2ff2a3b77f1d4e9acaa8 openh323-v1_15_2-src-tar.gz 3735815
diff --git a/net-libs/openh323/openh323-1.13.2-r2.ebuild b/net-libs/openh323/openh323-1.13.2-r2.ebuild
new file mode 100644
index 000000000000..36d8722c0700
--- /dev/null
+++ b/net-libs/openh323/openh323-1.13.2-r2.ebuild
@@ -0,0 +1,137 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/openh323/openh323-1.13.2-r2.ebuild,v 1.1 2005/02/03 20:11:08 stkn Exp $
+
+inherit eutils flag-o-matic multilib
+
+S=${WORKDIR}/${PN}
+DESCRIPTION="Open Source implementation of the ITU H.323 teleconferencing protocol"
+HOMEPAGE="http://www.openh323.org/"
+SRC_URI="http://www.gnomemeeting.org/admin/downloads/latest/sources/sources/${P}.tar.gz"
+
+LICENSE="MPL-1.1"
+SLOT="0"
+KEYWORDS="x86 sparc amd64 ppc"
+IUSE="ssl"
+
+DEPEND=">=sys-apps/sed-4
+ ~dev-libs/pwlib-1.6.3
+ >=media-video/ffmpeg-0.4.7
+ ssl? ( dev-libs/openssl )"
+
+pkg_setup() {
+ # to prevent merge problems with broken makefiles from old
+ # pwlib versions, we double-check here.
+
+ if [ "` fgrep '\$(OPENSSLDIR)/include' /usr/share/pwlib/make/unix.mak`" ]
+ then
+ # patch unix.mak so it doesn't require annoying
+ # unmerge/merge cycle to upgrade
+ einfo "Fixing broken pwlib makefile."
+ cd /usr/share/pwlib/make
+ sed -i \
+ -e "s:-DP_SSL -I\$(OPENSSLDIR)/include -I\$(OPENSSLDIR)/crypto:-DP_SSL:" \
+ -e "s:^LDFLAGS.*\+= -L\$(OPENSSLDIR)/$(get_libdir) -L\$(OPENSSLDIR):LDFLAGS +=:" \
+ unix.mak
+ fi
+
+ if has_version ">=sys-devel/gcc-3.3.2"; then
+ ewarn "If you are experiencing problems emerging openh323 with gcc-3.3.2"
+ ewarn "please try using CFLAGS=\"-O1\" when emerging"
+ ewarn "we are currently investigating this problem..."
+ ewarn ""
+ ewarn "<sleeping 10 seconds...>"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ # fix and enable ffmpeg/h263 support (bug #32754)
+ epatch ${FILESDIR}/openh323-${PV}-ffmpeg.diff
+
+ # fix include order (bug #32522)
+ epatch ${FILESDIR}/openh323-${PV}-include-order.diff
+
+ # fix to compile on gcc-3.4 (bug #56951)
+ epatch ${FILESDIR}/${P}-gcc34.diff
+
+ # fix for 2.6 headers (bug #72448)
+ epatch ${FILESDIR}/${P}-ixjuser.diff
+
+ # fix a typo
+ sed -i -e "s:\$(DESDIR):\$(DESTDIR):" \
+ Makefile.in
+}
+
+src_compile() {
+ local makeopts
+
+ export PWLIBDIR=/usr/share/pwlib
+ export PTLIB_CONFIG=/usr/bin/ptlib-config
+ export OPENH323DIR=${S}
+
+ # NOTRACE avoid compilation problems, we disable PTRACING using NOTRACE=1
+ makeopts="${makeopts} ASNPARSER=/usr/bin/asnparser LDFLAGS=-L${S}/lib NOTRACE=1"
+
+ if use ssl; then
+ export OPENSSLFLAG=1
+ export OPENSSLDIR=/usr
+ export OPENSSLLIBS="-lssl -lcrypt"
+ fi
+
+ append-flags -fPIC
+
+ # use shipped speex version
+ econf \
+ --enable-localspeex || die
+
+ emake -j1 ${makeopts} opt || die "make failed"
+}
+
+src_install() {
+ local OPENH323_ARCH ALT_ARCH
+ # make NOTRACE=1 opt ==> linux_$ARCH_n
+ # make opt ==> linux_$ARCH_r
+
+ # amd64 needs special treatment
+ if [ ${ARCH} = "amd64" ]; then
+ OPENH323_ARCH="linux_x86_64_n"
+ else
+ OPENH323_ARCH="linux_${ARCH}_n"
+ fi
+
+ make PREFIX=/usr DESTDIR=${D} install || die "install failed"
+ dobin ${S}/samples/simple/obj_${OPENH323_ARCH}/simph323
+
+ # mod to keep gnugk happy
+ insinto /usr/share/openh323/src
+ newins ${FILESDIR}/openh323-1.11.7-emptyMakefile Makefile
+
+ # install version.h into $OPENH323DIR
+ insinto /usr/share/openh323
+ doins version.h
+
+ rm ${D}/usr/$(get_libdir)/libopenh323.so
+ dosym /usr/$(get_libdir)/libh323_${OPENH323_ARCH}.so.${PV} /usr/$(get_libdir)/libopenh323.so
+
+ # for backwards compatibility with _r versioned libraries
+ # (this might not work...)
+ ALT_ARCH=${OPENH323_ARCH/_n/_r}
+ for pv in ${PV} ${PV%.[0-9]} ${PV%.[0-9]*.[0-9]}; do
+ einfo "creating /usr/$(get_libdir)/libh323_${ALT_ARCH}.so.${pv} symlink"
+ dosym /usr/$(get_libdir)/libh323_${OPENH323_ARCH}.so.${PV} /usr/$(get_libdir)/libh323_${ALT_ARCH}.so.${pv}
+ done
+ dosym /usr/$(get_libdir)/libh323_${OPENH323_ARCH}.so.${PV} /usr/$(get_libdir)/libh323_${ALT_ARCH}.so
+
+ # these should point to the right directories,
+ # openh323.org apps and others need this
+ dosed "s:^OH323_LIBDIR = \$(OPENH323DIR).*:OH323_LIBDIR = /usr/$(get_libdir):" \
+ /usr/share/openh323/openh323u.mak
+ dosed "s:^OH323_INCDIR = \$(OPENH323DIR).*:OH323_INCDIR = /usr/include/openh323:" \
+ /usr/share/openh323/openh323u.mak
+ # this is hardcoded now? nice...
+ dosed "s:^\(OPENH323DIR[ \t]\+=\) ${S}:\1 /usr/share/openh323:" \
+ /usr/share/openh323/openh323u.mak
+}
diff --git a/net-libs/openh323/openh323-1.13.5-r1.ebuild b/net-libs/openh323/openh323-1.13.5-r1.ebuild
new file mode 100644
index 000000000000..cd6b095b848d
--- /dev/null
+++ b/net-libs/openh323/openh323-1.13.5-r1.ebuild
@@ -0,0 +1,138 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/openh323/openh323-1.13.5-r1.ebuild,v 1.1 2005/02/03 20:11:08 stkn Exp $
+
+IUSE="ssl"
+
+inherit eutils flag-o-matic multilib
+
+MY_P="${PN}-v${PV//./_}"
+
+S=${WORKDIR}/${PN}
+DESCRIPTION="Open Source implementation of the ITU H.323 teleconferencing protocol"
+HOMEPAGE="http://www.openh323.org/"
+SRC_URI="mirror://sourceforge/openh323/${MY_P}-src.tar.gz"
+
+SLOT="0"
+LICENSE="MPL-1.1"
+KEYWORDS="~x86 ppc ~amd64 ~sparc ~alpha"
+
+DEPEND=">=sys-apps/sed-4
+ >=dev-libs/pwlib-1.6.6
+ >=media-video/ffmpeg-0.4.7
+ ssl? ( dev-libs/openssl )"
+
+pkg_setup() {
+ # to prevent merge problems with broken makefiles from old
+ # pwlib versions, we double-check here.
+
+ if [ "` fgrep '\$(OPENSSLDIR)/include' /usr/share/pwlib/make/unix.mak`" ]
+ then
+ # patch unix.mak so it doesn't require annoying
+ # unmerge/merge cycle to upgrade
+ einfo "Fixing broken pwlib makefile."
+ cd /usr/share/pwlib/make
+ sed -i \
+ -e "s:-DP_SSL -I\$(OPENSSLDIR)/include -I\$(OPENSSLDIR)/crypto:-DP_SSL:" \
+ -e "s:^LDFLAGS.*\+= -L\$(OPENSSLDIR)/$(get_libdir) -L\$(OPENSSLDIR):LDFLAGS +=:" \
+ unix.mak
+ fi
+
+ if has_version ">=sys-devel/gcc-3.3.2"; then
+ ewarn "If you are experiencing problems emerging openh323 with gcc-3.3.2"
+ ewarn "please try using CFLAGS=\"-O1\" when emergeing"
+ ewarn "we are currently investigating this problem..."
+ ewarn ""
+ ewarn "<sleeping 10 seconds...>"
+ epause 10
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ # fix and enable ffmpeg/h263 support (bug #32754)
+ epatch ${FILESDIR}/openh323-${PV}-ffmpeg.diff
+
+ # fix include order (bug #32522)
+ epatch ${FILESDIR}/openh323-${PV}-include-order.diff
+
+ # fix to compile on gcc-3.4 (bug #56951)
+ epatch ${FILESDIR}/${PN}-1.13.2-gcc34.diff
+
+ # fix ixjuser.h problems
+ epatch ${FILESDIR}/${PN}-1.13.2-ixjuser.diff
+}
+
+src_compile() {
+ local makeopts
+
+ # remove -fstack-protector, may cause problems (bug #75259)
+ filter-flags -fstack-protector
+
+ export PWLIBDIR=/usr/share/pwlib
+ export PTLIB_CONFIG=/usr/bin/ptlib-config
+ export OPENH323DIR=${S}
+
+ # NOTRACE avoid compilation problems, we disable PTRACING using NOTRACE=1
+ makeopts="${makeopts} ASNPARSER=/usr/bin/asnparser LDFLAGS=-L${S}/lib NOTRACE=1"
+
+ if use ssl; then
+ export OPENSSLFLAG=1
+ export OPENSSLDIR=/usr
+ export OPENSSLLIBS="-lssl -lcrypt"
+ fi
+
+ # use shipped speex version
+ econf \
+ --enable-localspeex || die
+
+ emake -j1 ${makeopts} opt || die "make failed"
+}
+
+src_install() {
+ local OPENH323_ARCH ALT_ARCH
+ # make NOTRACE=1 opt ==> linux_$ARCH_n
+ # make opt ==> linux_$ARCH_r
+
+ # amd64 needs special treatment
+ if [ ${ARCH} = "amd64" ]; then
+ OPENH323_ARCH="linux_x86_64_n"
+ else
+ OPENH323_ARCH="linux_${ARCH}_n"
+ fi
+
+ make PREFIX=/usr DESTDIR=${D} install || die "install failed"
+ dobin ${S}/samples/simple/obj_${OPENH323_ARCH}/simph323
+
+ # mod to keep gnugk happy
+ insinto /usr/share/openh323/src
+ newins ${FILESDIR}/openh323-1.11.7-emptyMakefile Makefile
+
+ # install version.h into $OPENH323DIR
+ insinto /usr/share/openh323
+ doins version.h
+
+ rm ${D}/usr/$(get_libdir)/libopenh323.so
+ dosym /usr/$(get_libdir)/libh323_${OPENH323_ARCH}.so.${PV} /usr/$(get_libdir)/libopenh323.so
+
+ # for backwards compatibility with _r versioned libraries
+ # (this might not work...)
+ ALT_ARCH=${OPENH323_ARCH/_n/_r}
+ for pv in ${PV} ${PV%.[0-9]} ${PV%.[0-9]*.[0-9]}; do
+ einfo "creating /usr/$(get_libdir)/libh323_${ALT_ARCH}.so.${pv} symlink"
+ dosym /usr/$(get_libdir)/libh323_${OPENH323_ARCH}.so.${PV} /usr/$(get_libdir)/libh323_${ALT_ARCH}.so.${pv}
+ done
+ dosym /usr/$(get_libdir)/libh323_${OPENH323_ARCH}.so.${PV} /usr/$(get_libdir)/libh323_${ALT_ARCH}.so
+
+ # these should point to the right directories,
+ # openh323.org apps and others need this
+ dosed "s:^OH323_LIBDIR = \$(OPENH323DIR).*:OH323_LIBDIR = /usr/$(get_libdir):" \
+ /usr/share/openh323/openh323u.mak
+ dosed "s:^OH323_INCDIR = \$(OPENH323DIR).*:OH323_INCDIR = /usr/include/openh323:" \
+ /usr/share/openh323/openh323u.mak
+ # this is hardcoded now? nice...
+ dosed "s:^\(OPENH323DIR[ \t]\+=\) ${S}:\1 /usr/share/openh323:" \
+ /usr/share/openh323/openh323u.mak
+}
diff --git a/net-libs/openh323/openh323-1.15.2-r1.ebuild b/net-libs/openh323/openh323-1.15.2-r1.ebuild
new file mode 100644
index 000000000000..4f59a0c5a2b8
--- /dev/null
+++ b/net-libs/openh323/openh323-1.15.2-r1.ebuild
@@ -0,0 +1,142 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/openh323/openh323-1.15.2-r1.ebuild,v 1.1 2005/02/03 20:11:08 stkn Exp $
+
+IUSE="ssl novideo noaudio debug"
+
+inherit eutils flag-o-matic multilib
+
+MY_P="${PN}-v${PV//./_}"
+
+S=${WORKDIR}/${PN}
+DESCRIPTION="Open Source implementation of the ITU H.323 teleconferencing protocol"
+HOMEPAGE="http://www.openh323.org/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}-src-tar.gz"
+
+SLOT="0"
+LICENSE="MPL-1.1"
+KEYWORDS="~x86 ~sparc ~alpha ~ppc ~amd64"
+
+DEPEND=">=sys-apps/sed-4
+ >=dev-libs/pwlib-1.8.3
+ >=media-video/ffmpeg-0.4.7
+ ssl? ( dev-libs/openssl )"
+
+src_unpack() {
+ # currently complaining to UPSTREAM about new naming scheme
+ tar -C ${WORKDIR} -xzf ${DISTDIR}/${MY_P}-src-tar.gz || die "Unpacking of ${PF} failed"
+
+ cd ${S}
+ # Makefile is currently broken with NOTRACE=1, fix that
+ epatch ${FILESDIR}/${PN}-1.15.2-notrace.diff
+}
+
+src_compile() {
+ local makeopts
+ local myconf
+
+ # remove -fstack-protector, may cause problems (bug #75259)
+ filter-flags -fstack-protector
+
+ export PWLIBDIR=/usr/share/pwlib
+ export PTLIB_CONFIG=/usr/bin/ptlib-config
+ export OPENH323DIR=${S}
+
+ makeopts="${makeopts} ASNPARSER=/usr/bin/asnparser LDFLAGS=-L${S}/lib"
+
+ # NOTRACE avoid compilation problems, we disable PTRACING using NOTRACE=1
+ # compile with PTRACING if the user wants to debug stuff
+ if ! use debug; then
+ makeopts="${makeopts} NOTRACE=1"
+ fi
+
+ if use ssl; then
+ export OPENSSLFLAG=1
+ export OPENSSLDIR=/usr
+ export OPENSSLLIBS="-lssl -lcrypt"
+ fi
+
+ use novideo \
+ && myconf="${myconf} --disable-video"
+
+ use noaudio \
+ && myconf="${myconf} --disable-audio"
+
+ econf ${myconf} || die "configure failed"
+ emake ${makeopts} opt || die "make failed"
+}
+
+src_install() {
+ local OPENH323_ARCH ALT_ARCH OPENH323_SUFFIX
+ local makeopts
+ # make NOTRACE=1 opt ==> linux_$ARCH_n
+ # make opt ==> linux_$ARCH_r
+ if ! use debug; then
+ OPENH323_SUFFIX="n"
+ makeopts="NOTRACE=1"
+ else
+ OPENH323_SUFFIX="r"
+ fi
+
+ # amd64 needs special treatment
+ if use amd64; then
+ OPENH323_ARCH="linux_x86_64_${OPENH323_SUFFIX}"
+ else
+ OPENH323_ARCH="linux_${ARCH}_${OPENH323_SUFFIX}"
+ fi
+
+ # set ALT_ARCH
+ if use debug; then
+ ALT_ARCH=${OPENH323_ARCH/_r/_n}
+ else
+ ALT_ARCH=${OPENH323_ARCH/_n/_r}
+ fi
+
+ ###
+ # Install stuff
+ #
+ make PREFIX=/usr DESTDIR=${D} \
+ OH323_FILE="libh323_${OPENH323_ARCH}.so.${PV}" \
+ ${makeopts} install || die "install failed"
+
+ # workaround: don't install libh323*.so and libh323.so.${PV}
+ if [[ -f ${D}/usr/$(get_libdir)/libh323_${OPENH323_ARCH}.so ]]; then
+ # libh323*.so is a file... replace it w/ a symlink
+ rm -f ${D}/usr/$(get_libdir)/libh323_${OPENH323_ARCH}.so
+
+ dosym /usr/$(get_libdir)/libh323_${OPENH323_ARCH}.so.${PV} \
+ /usr/$(get_libdir)/libh323_${OPENH323_ARCH}.so
+ fi
+
+ ###
+ # Compatibility "hacks"
+ #
+
+ # mod to keep gnugk happy
+ insinto /usr/share/openh323/src
+ newins ${FILESDIR}/openh323-1.11.7-emptyMakefile Makefile
+
+ # install version.h into $OPENH323DIR
+ insinto /usr/share/openh323
+ doins version.h
+
+ rm ${D}/usr/$(get_libdir)/libopenh323.so
+ dosym /usr/$(get_libdir)/libh323_${OPENH323_ARCH}.so.${PV} /usr/$(get_libdir)/libopenh323.so
+
+ # for backwards compatibility with _r versioned libraries
+ for pv in ${PV} ${PV%.[0-9]} ${PV%.[0-9]*.[0-9]}; do
+ einfo "creating /usr/$(get_libdir)/libh323_${ALT_ARCH}.so.${pv} symlink"
+ dosym /usr/$(get_libdir)/libh323_${OPENH323_ARCH}.so.${PV} /usr/$(get_libdir)/libh323_${ALT_ARCH}.so.${pv}
+ done
+ dosym /usr/$(get_libdir)/libh323_${OPENH323_ARCH}.so.${PV} /usr/$(get_libdir)/libh323_${ALT_ARCH}.so
+
+ # these should point to the right directories,
+ # openh323.org apps and others need this
+ dosed "s:^OH323_LIBDIR = \$(OPENH323DIR).*:OH323_LIBDIR = /usr/$(get_libdir):" \
+ /usr/share/openh323/openh323u.mak
+ dosed "s:^OH323_INCDIR = \$(OPENH323DIR).*:OH323_INCDIR = /usr/include/openh323:" \
+ /usr/share/openh323/openh323u.mak
+ # this is hardcoded now?
+ dosed "s:^\(OPENH323DIR[ \t]\+=\) ${S}:\1 /usr/share/openh323:" \
+ /usr/share/openh323/openh323u.mak
+}