summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2011-10-31 20:28:13 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2011-10-31 20:28:13 +0000
commita955bcf5b16fb25a77e7c18c8ec63c1fb221aad6 (patch)
treeabe2aa55da15727ca6ab9fb6d43c1d7b9441d885 /net-libs/net6
parentUpdate to EAPI=2 to keep down differences with newer openssl ebuilds, and fix... (diff)
downloadgentoo-2-a955bcf5b16fb25a77e7c18c8ec63c1fb221aad6.tar.gz
gentoo-2-a955bcf5b16fb25a77e7c18c8ec63c1fb221aad6.tar.bz2
gentoo-2-a955bcf5b16fb25a77e7c18c8ec63c1fb221aad6.zip
Version bump, contains fixes for CVE-2011-4093 and CVE-2011-4091, drop old
(Portage version: 2.2.0_alpha72/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/net6')
-rw-r--r--net-libs/net6/ChangeLog8
-rw-r--r--net-libs/net6/files/net6-1.3.13-gnutls3.patch35
-rw-r--r--net-libs/net6/net6-1.3.14.ebuild (renamed from net-libs/net6/net6-1.3.13.ebuild)10
3 files changed, 10 insertions, 43 deletions
diff --git a/net-libs/net6/ChangeLog b/net-libs/net6/ChangeLog
index 6a300a51133e..715d6a0a0ee5 100644
--- a/net-libs/net6/ChangeLog
+++ b/net-libs/net6/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/net6
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/net6/ChangeLog,v 1.41 2011/10/30 09:08:38 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/net6/ChangeLog,v 1.42 2011/10/31 20:28:13 xarthisius Exp $
+
+*net6-1.3.14 (31 Oct 2011)
+
+ 31 Oct 2011; Kacper Kowalik <xarthisius@gentoo.org> -net6-1.3.13.ebuild,
+ -files/net6-1.3.13-gnutls3.patch, +net6-1.3.14.ebuild:
+ Version bump, contains fixes for CVE-2011-4093 and CVE-2011-4091, drop old
30 Oct 2011; Kacper Kowalik <xarthisius@gentoo.org> net6-1.3.13.ebuild,
+net6-1.3.13-gnutls3.patch:
diff --git a/net-libs/net6/files/net6-1.3.13-gnutls3.patch b/net-libs/net6/files/net6-1.3.13-gnutls3.patch
deleted file mode 100644
index 4e2757b339bc..000000000000
--- a/net-libs/net6/files/net6-1.3.13-gnutls3.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-Backporting upstream patch to fix build failure with gnutls-3
-
-https://bugs.gentoo.org/show_bug.cgi?id=388897
-
---- a/inc/encrypt.hpp
-+++ b/inc/encrypt.hpp
-@@ -34,7 +34,6 @@
- typedef gnutls_anon_server_credentials gnutls_anon_server_credentials_t;
- typedef gnutls_transport_ptr gnutls_transport_ptr_t;
- typedef gnutls_dh_params gnutls_dh_params_t;
--typedef gnutls_connection_end gnutls_connection_end_t;
-
- class dh_params: private net6::non_copyable
- {
---- a/src/encrypt.cpp
-+++ b/src/encrypt.cpp
-@@ -25,7 +25,7 @@
- {
- const unsigned int DH_BITS = 1024;
-
-- net6::gnutls_session_t create_session(net6::gnutls_connection_end_t end)
-+ net6::gnutls_session_t create_session(gnutls_connection_end_t end)
- {
- net6::gnutls_session_t session;
- gnutls_init(&session, end);
-@@ -202,7 +202,9 @@
- );
- #endif
-
-+#if GNUTLS_VERSION_NUMBER < 0x030003
- gnutls_transport_set_lowat(session, 0);
-+#endif
- }
-
- net6::tcp_encrypted_socket_base::~tcp_encrypted_socket_base()
diff --git a/net-libs/net6/net6-1.3.13.ebuild b/net-libs/net6/net6-1.3.14.ebuild
index 2a36b2e16704..7299caceb831 100644
--- a/net-libs/net6/net6-1.3.13.ebuild
+++ b/net-libs/net6/net6-1.3.14.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/net6/net6-1.3.13.ebuild,v 1.3 2011/10/30 09:06:00 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/net6/net6-1.3.14.ebuild,v 1.1 2011/10/31 20:28:13 xarthisius Exp $
EAPI=4
-inherit eutils multilib
+inherit multilib
DESCRIPTION="Network access framework for IPv4/IPv6 written in C++"
HOMEPAGE="http://gobby.0x539.de/"
@@ -23,10 +23,6 @@ DEPEND="${RDEPEND}
DOCS=( AUTHORS ChangeLog NEWS README )
-src_prepare() {
- epatch "${FILESDIR}"/${P}-gnutls3.patch
-}
-
src_configure() {
econf $(use_enable nls) \
$(use_enable static-libs static)
@@ -34,5 +30,5 @@ src_configure() {
src_install() {
default
- use static-libs || rm -f "${D}"/usr/$(get_libdir)/${PN}.la
+ use static-libs || rm -f "${D}"/usr/$(get_libdir)/lib${PN}.la
}