summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Sachau <tommy@gentoo.org>2010-09-04 19:55:18 +0000
committerThomas Sachau <tommy@gentoo.org>2010-09-04 19:55:18 +0000
commit470ce74d0f9a9aff2d5b4e213f7dc28924d1b525 (patch)
tree831fcdbc51922798202145535d6f61c833779e4f /net-libs/nativebiginteger
parentBump (diff)
downloadgentoo-2-470ce74d0f9a9aff2d5b4e213f7dc28924d1b525.tar.gz
gentoo-2-470ce74d0f9a9aff2d5b4e213f7dc28924d1b525.tar.bz2
gentoo-2-470ce74d0f9a9aff2d5b4e213f7dc28924d1b525.zip
Revision bump to fix bug 335682
(Portage version: 2.2_rc75-r1/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/nativebiginteger')
-rw-r--r--net-libs/nativebiginteger/ChangeLog11
-rw-r--r--net-libs/nativebiginteger/files/nativebiginteger-0.6.4-ldflags.patch16
-rw-r--r--net-libs/nativebiginteger/nativebiginteger-0.6.4-r1.ebuild36
3 files changed, 61 insertions, 2 deletions
diff --git a/net-libs/nativebiginteger/ChangeLog b/net-libs/nativebiginteger/ChangeLog
index 95c5e47bf05c..5b79cf201280 100644
--- a/net-libs/nativebiginteger/ChangeLog
+++ b/net-libs/nativebiginteger/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-libs/nativebiginteger
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/nativebiginteger/ChangeLog,v 1.3 2009/03/09 22:39:12 maekke Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/nativebiginteger/ChangeLog,v 1.4 2010/09/04 19:55:18 tommy Exp $
+
+*nativebiginteger-0.6.4-r1 (04 Sep 2010)
+
+ 04 Sep 2010; Thomas Sachau (Tommy[D]) <tommy@gentoo.org>
+ +nativebiginteger-0.6.4-r1.ebuild,
+ +files/nativebiginteger-0.6.4-ldflags.patch:
+ Revision bump to fix bug 335682
09 Mar 2009; Markus Meier <maekke@gentoo.org>
nativebiginteger-0.6.4.ebuild:
diff --git a/net-libs/nativebiginteger/files/nativebiginteger-0.6.4-ldflags.patch b/net-libs/nativebiginteger/files/nativebiginteger-0.6.4-ldflags.patch
new file mode 100644
index 000000000000..c9638a7d0bb4
--- /dev/null
+++ b/net-libs/nativebiginteger/files/nativebiginteger-0.6.4-ldflags.patch
@@ -0,0 +1,16 @@
+--- Makefile 2008-11-06 21:09:54.000000000 +0100
++++ Makefile.new 2010-09-04 21:48:57.941604821 +0200
+@@ -1,11 +1,11 @@
+ libjbigi:
+ cd jbigi && rm -f jbigi.o libjbigi.so && $(CC) $(CFLAGS) -c -I. -Ijbigi/include -I$(JAVA_HOME)/include -I$(JAVA_HOME)/include/linux \
+- jbigi/src/jbigi.c && $(CC) -shared -Wl,-soname,libjbigi.so -I. -Ijbigi/include -I$(JAVA_HOME)/include -I$(JAVA_HOME)/include/linux -lgmp \
++ jbigi/src/jbigi.c && $(CC) ${LDFLAGS} -shared -Wl,-soname,libjbigi.so -I. -Ijbigi/include -I$(JAVA_HOME)/include -I$(JAVA_HOME)/include/linux -lgmp \
+ -o libjbigi.so jbigi.o
+
+
+ libjcpuid:
+- cd jcpuid && $(CC) $(CFLAGS) -shared -Wl,-soname,libjbigi-x86-linux.so -I. -Iinclude -I$(JAVA_HOME)/include -I$(JAVA_HOME)/include/linux \
++ cd jcpuid && $(CC) $(CFLAGS) ${LDFLAGS} -shared -Wl,-soname,libjbigi-x86-linux.so -I. -Iinclude -I$(JAVA_HOME)/include -I$(JAVA_HOME)/include/linux \
+ src/*.c -o libjcpuid-x86-linux.so
+
+ install:
diff --git a/net-libs/nativebiginteger/nativebiginteger-0.6.4-r1.ebuild b/net-libs/nativebiginteger/nativebiginteger-0.6.4-r1.ebuild
new file mode 100644
index 000000000000..793c8f4c52d0
--- /dev/null
+++ b/net-libs/nativebiginteger/nativebiginteger-0.6.4-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/nativebiginteger/nativebiginteger-0.6.4-r1.ebuild,v 1.1 2010/09/04 19:55:18 tommy Exp $
+
+EAPI=2
+
+inherit flag-o-matic multilib toolchain-funcs java-pkg-2
+
+DESCRIPTION="NativeBigInteger libs for Freenet taken from i2p"
+HOMEPAGE="http://www.i2p2.de"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="|| ( public-domain BSD MIT )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-libs/gmp
+ >=virtual/jdk-1.4"
+RDEPEND="dev-libs/gmp"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-ldflags.patch
+}
+
+src_compile() {
+ append-flags -fPIC
+ tc-export CC
+ emake libjbigi || die
+ use x86 && filter-flags -fPIC -nopie
+ emake libjcpuid || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" LIBDIR=$(get_libdir) install || die
+}