summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-09-10 17:54:27 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-09-10 17:54:27 +0000
commitc4ccb9099069f7c9a7a4b80417039fc1a0b2a4d4 (patch)
treec596f34f7c0e039d2f94d02c52ad01004dce8476 /net-libs/libtorrent
parentwhitespace (diff)
downloadgentoo-2-c4ccb9099069f7c9a7a4b80417039fc1a0b2a4d4.tar.gz
gentoo-2-c4ccb9099069f7c9a7a4b80417039fc1a0b2a4d4.tar.bz2
gentoo-2-c4ccb9099069f7c9a7a4b80417039fc1a0b2a4d4.zip
Bump to 0.12.5, fixes half of #278660. Thanks to Shark for testing.
(Portage version: 2.2_rc40/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/libtorrent')
-rw-r--r--net-libs/libtorrent/ChangeLog7
-rw-r--r--net-libs/libtorrent/libtorrent-0.12.5.ebuild49
2 files changed, 55 insertions, 1 deletions
diff --git a/net-libs/libtorrent/ChangeLog b/net-libs/libtorrent/ChangeLog
index f112b496e69b..69af45c8204a 100644
--- a/net-libs/libtorrent/ChangeLog
+++ b/net-libs/libtorrent/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/libtorrent
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libtorrent/ChangeLog,v 1.139 2009/06/05 15:52:09 loki_val Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libtorrent/ChangeLog,v 1.140 2009/09/10 17:54:27 patrick Exp $
+
+*libtorrent-0.12.5 (10 Sep 2009)
+
+ 10 Sep 2009; Patrick Lauer <patrick@gentoo.org> +libtorrent-0.12.5.ebuild:
+ Bump to 0.12.5, fixes half of #278660. Thanks to Shark for testing.
05 Jun 2009; Peter Alfredsen <loki_val@gentoo.org> metadata.xml:
Retiring, bug 220219.
diff --git a/net-libs/libtorrent/libtorrent-0.12.5.ebuild b/net-libs/libtorrent/libtorrent-0.12.5.ebuild
new file mode 100644
index 000000000000..3c8ff323eb5e
--- /dev/null
+++ b/net-libs/libtorrent/libtorrent-0.12.5.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libtorrent/libtorrent-0.12.5.ebuild,v 1.1 2009/09/10 17:54:27 patrick Exp $
+
+inherit base eutils toolchain-funcs flag-o-matic libtool
+
+DESCRIPTION="LibTorrent is a BitTorrent library written in C++ for *nix."
+HOMEPAGE="http://libtorrent.rakshasa.no/"
+SRC_URI="http://libtorrent.rakshasa.no/downloads/${P}.tar.gz"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+IUSE="debug ipv6"
+
+RDEPEND=">=dev-libs/libsigc++-2.2.2"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_unpack() {
+ base_src_unpack
+ cd "${S}"
+ elibtoolize #Don't remove. Needed for *bsd.
+}
+
+src_compile() {
+ replace-flags -Os -O2
+
+ if [[ $(tc-arch) = "x86" ]]; then
+ filter-flags -fomit-frame-pointer -fforce-addr
+ fi
+
+ econf \
+ $(use_enable debug) \
+ $(use_enable ipv6) \
+ --enable-aligned \
+ --enable-static \
+ --enable-shared \
+ --with-posix-fallocate \
+ --disable-dependency-tracking \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS NEWS README
+}