summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-09-26 22:16:18 +0000
committerTim Harder <radhermit@gentoo.org>2011-09-26 22:16:18 +0000
commit96be3ed2f47a986fc2b68534235ce06124a80c5f (patch)
tree5acd796204ff33ebec4a722fb293858abebd72c2 /net-libs/libnxml
parentUpdate HOMEPAGE and SRC_URI. (diff)
downloadgentoo-2-96be3ed2f47a986fc2b68534235ce06124a80c5f.tar.gz
gentoo-2-96be3ed2f47a986fc2b68534235ce06124a80c5f.tar.bz2
gentoo-2-96be3ed2f47a986fc2b68534235ce06124a80c5f.zip
Update to EAPI 4 and add static-libs use flag.
(Portage version: 2.2.0_alpha59/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/libnxml')
-rw-r--r--net-libs/libnxml/ChangeLog5
-rw-r--r--net-libs/libnxml/libnxml-0.18.3.ebuild18
2 files changed, 16 insertions, 7 deletions
diff --git a/net-libs/libnxml/ChangeLog b/net-libs/libnxml/ChangeLog
index 20b88ad130d7..449d076f6e01 100644
--- a/net-libs/libnxml/ChangeLog
+++ b/net-libs/libnxml/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-libs/libnxml
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libnxml/ChangeLog,v 1.15 2011/09/26 22:12:40 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libnxml/ChangeLog,v 1.16 2011/09/26 22:16:18 radhermit Exp $
+
+ 26 Sep 2011; Tim Harder <radhermit@gentoo.org> libnxml-0.18.3.ebuild:
+ Update to EAPI 4 and add static-libs use flag.
26 Sep 2011; Tim Harder <radhermit@gentoo.org> libnxml-0.17.1.ebuild,
libnxml-0.18.0.ebuild, libnxml-0.18.2.ebuild, libnxml-0.18.3.ebuild:
diff --git a/net-libs/libnxml/libnxml-0.18.3.ebuild b/net-libs/libnxml/libnxml-0.18.3.ebuild
index 1669afdfa7a1..a283b828e894 100644
--- a/net-libs/libnxml/libnxml-0.18.3.ebuild
+++ b/net-libs/libnxml/libnxml-0.18.3.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libnxml/libnxml-0.18.3.ebuild,v 1.2 2011/09/26 22:12:40 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libnxml/libnxml-0.18.3.ebuild,v 1.3 2011/09/26 22:16:18 radhermit Exp $
-EAPI="2"
+EAPI="4"
DESCRIPTION="A C-library for parsing and writing XML 1.0/1.1 files or streams"
HOMEPAGE="http://www.autistici.org/bakunin/libnxml/doc/"
@@ -11,14 +11,19 @@ SRC_URI="http://www.autistici.org/bakunin/${PN}/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-IUSE="doc examples"
+IUSE="doc examples static-libs"
RDEPEND="net-misc/curl"
DEPEND="${RDEPEND}
doc? ( app-doc/doxygen )"
+src_configure() {
+ econf \
+ $(use_enable static-libs static)
+}
+
src_compile() {
- emake || die "make failed"
+ emake
if use doc; then
ebegin "Creating documentation"
@@ -28,8 +33,7 @@ src_compile() {
}
src_install() {
- emake DESTDIR="${D}" install || die "make install failed"
- dodoc AUTHORS ChangeLog NEWS README
+ default
if use doc; then
dohtml doc/html/*
@@ -39,4 +43,6 @@ src_install() {
insinto /usr/share/doc/${PF}/test
doins test/*.c
fi
+
+ find "${D}" -name '*.la' -exec rm -f {} +
}