summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2014-04-02 14:06:01 +0000
committerAnthony G. Basile <blueness@gentoo.org>2014-04-02 14:06:01 +0000
commit31bcc8b3c864f88c798a60c0eadc7b60fc0660df (patch)
tree2b6197b961607f7546b42e56e1f9c88af2a9f0f2 /net-libs/libnatpmp/files
parentdisable the forcing of ld.gold in the mozilla build system, bug 494364 (diff)
downloadgentoo-2-31bcc8b3c864f88c798a60c0eadc7b60fc0660df.tar.gz
gentoo-2-31bcc8b3c864f88c798a60c0eadc7b60fc0660df.tar.bz2
gentoo-2-31bcc8b3c864f88c798a60c0eadc7b60fc0660df.zip
Version bump
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'net-libs/libnatpmp/files')
-rw-r--r--net-libs/libnatpmp/files/respect-FLAGS-20140401.patch36
1 files changed, 36 insertions, 0 deletions
diff --git a/net-libs/libnatpmp/files/respect-FLAGS-20140401.patch b/net-libs/libnatpmp/files/respect-FLAGS-20140401.patch
new file mode 100644
index 000000000000..0a007b169a79
--- /dev/null
+++ b/net-libs/libnatpmp/files/respect-FLAGS-20140401.patch
@@ -0,0 +1,36 @@
+diff -Naur libnatpmp-20140401.orig/Makefile libnatpmp-20140401/Makefile
+--- libnatpmp-20140401.orig/Makefile 2013-12-09 15:52:28.000000000 -0500
++++ libnatpmp-20140401/Makefile 2014-04-02 10:03:42.128609226 -0400
+@@ -5,7 +5,7 @@
+ # http://miniupnp.free.fr/libnatpmp.html
+
+ OS = $(shell uname -s)
+-CC = gcc
++CC ?= gcc
+ INSTALL = install -p
+ ARCH = $(shell uname -m | sed -e s/i.86/i686/)
+ VERSION = $(shell cat VERSION)
+@@ -153,19 +153,19 @@
+ $(CC) $(LDFLAGS) -o $@ $^ $(EXTRA_LD)
+
+ natpmpc-static: natpmpc.o $(STATICLIB)
+- $(CC) $(LDFLAGS) -o $@ $^ $(EXTRA_LD)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $^ $(EXTRA_LD)
+
+ natpmpc-shared: natpmpc.o $(SHAREDLIB)
+- $(CC) $(LDFLAGS) -o $@ $^ $(EXTRA_LD)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $^ $(EXTRA_LD)
+
+ $(STATICLIB): $(LIBOBJS)
+ $(AR) crs $@ $?
+
+ $(SHAREDLIB): $(LIBOBJS)
+ ifeq ($(OS), Darwin)
+- $(CC) -dynamiclib -Wl,-install_name,$(SONAME) -o $@ $^
++ $(CC) $(CFLAGS) $(LDFLAGS) -dynamiclib -Wl,-install_name,$(SONAME) -o $@ $^
+ else
+- $(CC) -shared -Wl,-soname,$(SONAME) -o $@ $^ $(EXTRA_LD)
++ $(CC) $(CFLAGS) $(LDFLAGS) -shared -Wl,-soname,$(SONAME) -o $@ $^ $(EXTRA_LD)
+ endif
+
+