summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2012-06-09 22:35:42 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2012-06-09 22:35:42 +0000
commitb6c81eab21bfb0bbeafdd79de0fbeb599116de8a (patch)
tree949490b438f448a7914434c5928cc54d9e49f350 /net-libs/libmicrohttpd
parentfix for games.eclass wrt bug #336626 #c21 (diff)
downloadgentoo-2-b6c81eab21bfb0bbeafdd79de0fbeb599116de8a.tar.gz
gentoo-2-b6c81eab21bfb0bbeafdd79de0fbeb599116de8a.tar.bz2
gentoo-2-b6c81eab21bfb0bbeafdd79de0fbeb599116de8a.zip
Version bump. Drop runtime dependency on curl, bug #417911. Update for new use_expand, bug #412445.
(Portage version: 2.2.0_alpha109/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/libmicrohttpd')
-rw-r--r--net-libs/libmicrohttpd/ChangeLog9
-rw-r--r--net-libs/libmicrohttpd/libmicrohttpd-0.9.20.ebuild48
2 files changed, 56 insertions, 1 deletions
diff --git a/net-libs/libmicrohttpd/ChangeLog b/net-libs/libmicrohttpd/ChangeLog
index 132a5a4084c4..4a3e3bcb2998 100644
--- a/net-libs/libmicrohttpd/ChangeLog
+++ b/net-libs/libmicrohttpd/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-libs/libmicrohttpd
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libmicrohttpd/ChangeLog,v 1.12 2012/05/22 22:54:13 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libmicrohttpd/ChangeLog,v 1.13 2012/06/09 22:35:42 chithanh Exp $
+
+*libmicrohttpd-0.9.20 (09 Jun 2012)
+
+ 09 Jun 2012; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ +libmicrohttpd-0.9.20.ebuild:
+ Version bump. Drop runtime dependency on curl, bug #417911. Update for new
+ use_expand, bug #412445.
22 May 2012; Jeff Horelick <jdhore@gentoo.org> libmicrohttpd-0.9.19.ebuild:
marked x86 per bug 415907
diff --git a/net-libs/libmicrohttpd/libmicrohttpd-0.9.20.ebuild b/net-libs/libmicrohttpd/libmicrohttpd-0.9.20.ebuild
new file mode 100644
index 000000000000..106675fd341a
--- /dev/null
+++ b/net-libs/libmicrohttpd/libmicrohttpd-0.9.20.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libmicrohttpd/libmicrohttpd-0.9.20.ebuild,v 1.1 2012/06/09 22:35:42 chithanh Exp $
+
+EAPI=4
+
+MY_P=${P/_/}
+
+DESCRIPTION="A small C library that makes it easy to run an HTTP server as part of another application."
+HOMEPAGE="http://gnunet.org/libmicrohttpd/"
+SRC_URI="mirror://gnu/${PN}/${MY_P}.tar.gz"
+
+IUSE="messages ssl static-libs test"
+KEYWORDS="~amd64 ~x86"
+LICENSE="LGPL-2.1"
+SLOT="0"
+
+RDEPEND="ssl? (
+ dev-libs/libgcrypt
+ net-libs/gnutls
+ )"
+# Some tests fail if curl is built against nss, bug #334067
+DEPEND="${RDEPEND}
+ test? (
+ ssl? ( || (
+ >=net-misc/curl-7.21[ssl,-nss(-),-curl_ssl_nss(-)]
+ >=net-misc/curl-7.21[ssl,gnutls]
+ ) )
+ )"
+
+S=${WORKDIR}/${MY_P}
+
+DOCS="AUTHORS NEWS README ChangeLog"
+
+src_configure() {
+ econf \
+ $(use_enable test curl) \
+ $(use_enable messages) \
+ $(use_enable ssl https) \
+ $(use_with ssl gnutls) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+
+ use static-libs || find "${ED}" -name '*.la' -exec rm -f {} +
+}