summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2012-07-20 20:00:25 +0000
committerAnthony G. Basile <blueness@gentoo.org>2012-07-20 20:00:25 +0000
commitb5135e73c42beb273d9486bc2e01779b9626ef5e (patch)
tree595aa2e425d4baf8784bfff8bd50f18ffd1fc759 /net-libs/libmicrohttpd
parent0.8.61 version bump. (diff)
downloadgentoo-2-b5135e73c42beb273d9486bc2e01779b9626ef5e.tar.gz
gentoo-2-b5135e73c42beb273d9486bc2e01779b9626ef5e.tar.bz2
gentoo-2-b5135e73c42beb273d9486bc2e01779b9626ef5e.zip
Version bump, bug #334067 no longer valid
(Portage version: 2.1.10.65/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/libmicrohttpd')
-rw-r--r--net-libs/libmicrohttpd/ChangeLog8
-rw-r--r--net-libs/libmicrohttpd/libmicrohttpd-0.9.21.ebuild45
2 files changed, 52 insertions, 1 deletions
diff --git a/net-libs/libmicrohttpd/ChangeLog b/net-libs/libmicrohttpd/ChangeLog
index cdc0bb143801..ca76945f0ca8 100644
--- a/net-libs/libmicrohttpd/ChangeLog
+++ b/net-libs/libmicrohttpd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/libmicrohttpd
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libmicrohttpd/ChangeLog,v 1.15 2012/06/25 01:00:16 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libmicrohttpd/ChangeLog,v 1.16 2012/07/20 20:00:25 blueness Exp $
+
+*libmicrohttpd-0.9.21 (20 Jul 2012)
+
+ 20 Jul 2012; Anthony G. Basile <blueness@gentoo.org>
+ +libmicrohttpd-0.9.21.ebuild:
+ Version bump, bug #334067 no longer valid
25 Jun 2012; Anthony G. Basile <blueness@gentoo.org>
libmicrohttpd-0.9.19.ebuild, libmicrohttpd-0.9.20.ebuild:
diff --git a/net-libs/libmicrohttpd/libmicrohttpd-0.9.21.ebuild b/net-libs/libmicrohttpd/libmicrohttpd-0.9.21.ebuild
new file mode 100644
index 000000000000..31063a60a94b
--- /dev/null
+++ b/net-libs/libmicrohttpd/libmicrohttpd-0.9.21.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libmicrohttpd/libmicrohttpd-0.9.21.ebuild,v 1.1 2012/07/20 20:00:25 blueness Exp $
+
+EAPI="4"
+
+MY_P="${P/_/}"
+
+DESCRIPTION="A small C library that makes it easy to run an HTTP server as part of another application."
+HOMEPAGE="http://www.gnu.org/software/libmicrohttpd/"
+SRC_URI="mirror://gnu/${PN}/${MY_P}.tar.gz"
+
+IUSE="messages ssl static-libs test"
+KEYWORDS="~amd64 ~x86"
+LICENSE="LGPL-2.1"
+SLOT="0"
+
+RDEPEND="ssl? (
+ dev-libs/libgcrypt
+ net-libs/gnutls
+ )"
+
+DEPEND="${RDEPEND}
+ test? (
+ ssl? ( >=net-misc/curl-7.25.0-r1[ssl] )
+ )"
+
+S=${WORKDIR}/${MY_P}
+
+DOCS="AUTHORS NEWS README ChangeLog"
+
+src_configure() {
+ econf \
+ $(use_enable test curl) \
+ $(use_enable messages) \
+ $(use_enable ssl https) \
+ $(use_with ssl gnutls) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+
+ use static-libs || find "${ED}" -name '*.la' -exec rm -f {} +
+}