summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2011-12-30 22:58:46 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2011-12-30 22:58:46 +0000
commite52fa65424c537141eeccb9d31bf8d39b9f0eee5 (patch)
treeb4385a04e616b7c17f85d8cb5747c9d348a2ddf4 /net-libs/libktorrent/libktorrent-1.1.3.ebuild
parentDrop old atheme-services-6.0.8-r2. (diff)
downloadgentoo-2-e52fa65424c537141eeccb9d31bf8d39b9f0eee5.tar.gz
gentoo-2-e52fa65424c537141eeccb9d31bf8d39b9f0eee5.tar.bz2
gentoo-2-e52fa65424c537141eeccb9d31bf8d39b9f0eee5.zip
Version bump
(Portage version: 2.1.10.41/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/libktorrent/libktorrent-1.1.3.ebuild')
-rw-r--r--net-libs/libktorrent/libktorrent-1.1.3.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/net-libs/libktorrent/libktorrent-1.1.3.ebuild b/net-libs/libktorrent/libktorrent-1.1.3.ebuild
new file mode 100644
index 000000000000..014d8d4737bd
--- /dev/null
+++ b/net-libs/libktorrent/libktorrent-1.1.3.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libktorrent/libktorrent-1.1.3.ebuild,v 1.1 2011/12/30 22:58:46 dilfridge Exp $
+
+EAPI=4
+
+KDE_SCM="git"
+if [[ ${PV} != 9999* ]]; then
+ inherit versionator
+ # upstream likes to skip that _ in beta releases
+ MY_PV="${PV/_/}"
+ KTORRENT_VERSION=$(($(get_major_version)+3)).$(get_version_component_range 2-3 ${MY_PV})
+ MY_P="${PN}-${MY_PV}"
+ KDE_HANDBOOK="optional"
+ KDE_DOC_DIRS="doc"
+
+ KDE_LINGUAS="ar ast be bg ca ca@valencia cs da de el en_GB eo es et eu
+ fi fr ga gl hi hne hr hu is it ja km ku lt lv ms nb nds nl nn oc pl
+ pt pt_BR ro ru se si sk sl sr sr@ijekavian sr@ijekavianlatin
+ sr@latin sv tr uk zh_CN zh_TW"
+ SRC_URI="http://ktorrent.org/downloads/${KTORRENT_VERSION}/${MY_P}.tar.bz2"
+ S="${WORKDIR}"/"${MY_P}"
+
+ KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+else
+ KEYWORDS=""
+fi
+VIRTUALX_REQUIRED=test
+inherit kde4-base
+
+DESCRIPTION="A BitTorrent library based on KDE Platform"
+HOMEPAGE="http://ktorrent.org/"
+
+LICENSE="GPL-2"
+SLOT="4"
+IUSE="debug"
+
+RDEPEND="
+ app-crypt/qca:2
+ dev-libs/gmp
+"
+DEPEND="${RDEPEND}
+ dev-libs/boost
+ sys-devel/gettext
+"
+
+src_prepare() {
+ kde4-base_src_prepare
+ # do not build non-installed example binary
+ sed -i -e '/add_subdirectory(examples)/d' CMakeLists.txt || die
+}