summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2010-12-20 13:53:31 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2010-12-20 13:53:31 +0000
commit7075f886f49a0d6503cdd222c106dac1af2395f1 (patch)
tree333dd5880c0e4e32bf236c994c644e7d6a75fec7 /net-libs/libisds
parentVersion bump, thank krigstask for report. Note, shared roster ldap module (US... (diff)
downloadgentoo-2-7075f886f49a0d6503cdd222c106dac1af2395f1.tar.gz
gentoo-2-7075f886f49a0d6503cdd222c106dac1af2395f1.tar.bz2
gentoo-2-7075f886f49a0d6503cdd222c106dac1af2395f1.zip
Remove old. Fix tests and use autotools-utils eclass.
(Portage version: 2.2.0_alpha9/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/libisds')
-rw-r--r--net-libs/libisds/ChangeLog6
-rw-r--r--net-libs/libisds/libisds-0.3.1.ebuild54
-rw-r--r--net-libs/libisds/libisds-0.4.ebuild26
-rw-r--r--net-libs/libisds/libisds-9999.ebuild26
4 files changed, 41 insertions, 71 deletions
diff --git a/net-libs/libisds/ChangeLog b/net-libs/libisds/ChangeLog
index 59d77d7c2a37..bbefed54fbf7 100644
--- a/net-libs/libisds/ChangeLog
+++ b/net-libs/libisds/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-libs/libisds
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libisds/ChangeLog,v 1.5 2010/12/20 10:57:48 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libisds/ChangeLog,v 1.6 2010/12/20 13:53:30 scarabeus Exp $
+
+ 20 Dec 2010; Tomáš Chvátal <scarabeus@gentoo.org> -libisds-0.3.1.ebuild,
+ libisds-0.4.ebuild, libisds-9999.ebuild:
+ Remove old. Fix tests and use autotools-utils eclass.
*libisds-0.4 (20 Dec 2010)
diff --git a/net-libs/libisds/libisds-0.3.1.ebuild b/net-libs/libisds/libisds-0.3.1.ebuild
deleted file mode 100644
index cfb140399986..000000000000
--- a/net-libs/libisds/libisds-0.3.1.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libisds/libisds-0.3.1.ebuild,v 1.4 2010/07/09 10:37:37 scarabeus Exp $
-
-EAPI=3
-
-[[ ${PV} = 9999* ]] && GIT="git autotools"
-EGIT_REPO_URI="git://repo.or.cz/${PN}.git"
-inherit base ${GIT}
-
-DESCRIPTION="Client library for accessing ISDS Soap services"
-HOMEPAGE="http://xpisar.wz.cz/libisds/"
-if [[ ${PV} = 9999* ]]; then
- SRC_URI=""
- KEYWORDS=""
-else
- SRC_URI="http://xpisar.wz.cz/${PN}/dist/${P}.tar.bz2"
- KEYWORDS="~amd64 ~x86"
-fi
-
-LICENSE="LGPL-3"
-SLOT="0"
-IUSE="debug nls static-libs test"
-
-COMMON_DEPEND="
- app-crypt/gpgme
- dev-libs/expat
- dev-libs/libgcrypt
- dev-libs/libxml2
- net-misc/curl[ssl]
-"
-DEPEND="${COMMON_DEPEND}
- dev-util/pkgconfig
- nls? ( sys-devel/gettext )
-"
-RDEPEND="${COMMON_DEPEND}
- >=app-crypt/gnupg-2
-"
-
-DOCS=( "NEWS" "README" "AUTHORS" "ChangeLog" )
-
-src_prepare() {
- base_src_prepare
- [[ ${PV} = 9999* ]] && eautoreconf
-}
-
-src_configure() {
- econf \
- --disable-fatalwarnings \
- $(use_enable debug) \
- $(use_enable nls) \
- $(use_enable static-libs static) \
- $(use_enable test)
-}
diff --git a/net-libs/libisds/libisds-0.4.ebuild b/net-libs/libisds/libisds-0.4.ebuild
index 35561f38f4d1..8e2b35f5175f 100644
--- a/net-libs/libisds/libisds-0.4.ebuild
+++ b/net-libs/libisds/libisds-0.4.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libisds/libisds-0.4.ebuild,v 1.1 2010/12/20 10:57:48 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libisds/libisds-0.4.ebuild,v 1.2 2010/12/20 13:53:30 scarabeus Exp $
EAPI=3
[[ ${PV} = 9999* ]] && GIT="git autotools"
EGIT_REPO_URI="git://repo.or.cz/${PN}.git"
-inherit base ${GIT}
+inherit autotools-utils ${GIT}
DESCRIPTION="Client library for accessing ISDS Soap services"
HOMEPAGE="http://xpisar.wz.cz/libisds/"
@@ -40,15 +40,25 @@ RDEPEND="${COMMON_DEPEND}
DOCS=( "NEWS" "README" "AUTHORS" "ChangeLog" )
src_prepare() {
- base_src_prepare
+ autotools-utils_src_prepare
[[ ${PV} = 9999* ]] && eautoreconf
}
src_configure() {
- econf \
- --disable-fatalwarnings \
- $(use_enable debug) \
- $(use_enable nls) \
- $(use_enable static-libs static) \
+ local myeconfargs=(
+ "--disable-fatalwarnings"
+ $(use_enable debug)
+ $(use_enable nls)
+ $(use_enable static-libs static)
$(use_enable test)
+ )
+
+ autotools-utils_src_configure
+}
+
+src_test() {
+ # hack for failing gnupg testing
+ export HOME="${T}"
+ mkdir "${HOME}/.gnupg"
+ autotools-utils_src_test
}
diff --git a/net-libs/libisds/libisds-9999.ebuild b/net-libs/libisds/libisds-9999.ebuild
index e777d503b85b..db8d0d727bc8 100644
--- a/net-libs/libisds/libisds-9999.ebuild
+++ b/net-libs/libisds/libisds-9999.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libisds/libisds-9999.ebuild,v 1.5 2010/12/20 10:57:48 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libisds/libisds-9999.ebuild,v 1.6 2010/12/20 13:53:30 scarabeus Exp $
EAPI=3
[[ ${PV} = 9999* ]] && GIT="git autotools"
EGIT_REPO_URI="git://repo.or.cz/${PN}.git"
-inherit base ${GIT}
+inherit autotools-utils ${GIT}
DESCRIPTION="Client library for accessing ISDS Soap services"
HOMEPAGE="http://xpisar.wz.cz/libisds/"
@@ -40,15 +40,25 @@ RDEPEND="${COMMON_DEPEND}
DOCS=( "NEWS" "README" "AUTHORS" "ChangeLog" )
src_prepare() {
- base_src_prepare
+ autotools-utils_src_prepare
[[ ${PV} = 9999* ]] && eautoreconf
}
src_configure() {
- econf \
- --disable-fatalwarnings \
- $(use_enable debug) \
- $(use_enable nls) \
- $(use_enable static-libs static) \
+ local myeconfargs=(
+ "--disable-fatalwarnings"
+ $(use_enable debug)
+ $(use_enable nls)
+ $(use_enable static-libs static)
$(use_enable test)
+ )
+
+ autotools-utils_src_configure
+}
+
+src_test() {
+ # hack for failing gnupg testing
+ export HOME="${T}"
+ mkdir "${HOME}/.gnupg"
+ autotools-utils_src_test
}