summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Martin <slarti@gentoo.org>2006-01-27 14:27:31 +0000
committerTom Martin <slarti@gentoo.org>2006-01-27 14:27:31 +0000
commitafb5029e4387c71016ea3aa05c9ed8e1f2bce135 (patch)
treef60ec82bfbd80b22f0066a4b8b4ecc5f74149422 /net-libs/libesmtp/libesmtp-1.0.3.ebuild
parentVersion bump to 0.7 (bug #120487), add bash and zsh completion, emacs mode (b... (diff)
downloadgentoo-2-afb5029e4387c71016ea3aa05c9ed8e1f2bce135.tar.gz
gentoo-2-afb5029e4387c71016ea3aa05c9ed8e1f2bce135.tar.bz2
gentoo-2-afb5029e4387c71016ea3aa05c9ed8e1f2bce135.zip
Big tidy, resolving multilib errors and other QA faults.
(Portage version: 2.1_pre3-r1)
Diffstat (limited to 'net-libs/libesmtp/libesmtp-1.0.3.ebuild')
-rw-r--r--net-libs/libesmtp/libesmtp-1.0.3.ebuild35
1 files changed, 14 insertions, 21 deletions
diff --git a/net-libs/libesmtp/libesmtp-1.0.3.ebuild b/net-libs/libesmtp/libesmtp-1.0.3.ebuild
index cb7675355551..cb92628069a6 100644
--- a/net-libs/libesmtp/libesmtp-1.0.3.ebuild
+++ b/net-libs/libesmtp/libesmtp-1.0.3.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libesmtp/libesmtp-1.0.3.ebuild,v 1.8 2005/05/16 09:49:35 ticho Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libesmtp/libesmtp-1.0.3.ebuild,v 1.9 2006/01/27 14:27:31 slarti Exp $
-inherit toolchain-funcs eutils gnuconfig libtool
+inherit toolchain-funcs eutils
MY_P="${P}r1"
DESCRIPTION="libESMTP is a library that implements the client side of the SMTP protocol"
@@ -10,38 +10,31 @@ SRC_URI="http://www.stafford.uklinux.net/${PN}/${MY_P}.tar.bz2"
HOMEPAGE="http://www.stafford.uklinux.net/libesmtp/"
LICENSE="LGPL-2.1 GPL-2"
-RDEPEND="ssl? ( >=dev-libs/openssl-0.9.6b )"
+DEPEND=">=sys-devel/libtool-1.4.1
+ >=sys-apps/sed-4
+ ssl? ( >=dev-libs/openssl-0.9.6b )"
-DEPEND="${RDEPEND}
- >=sys-devel/libtool-1.4.1
- >=sys-apps/sed-4"
-
-IUSE="ssl"
+IUSE="ssl debug"
SLOT="0"
KEYWORDS="alpha ~amd64 ia64 ppc sparc x86"
S="${WORKDIR}/${MY_P}"
src_compile() {
- gnuconfig_update
-
- elibtoolize
-
local myconf
- use ssl || myconf="${myconf} --without-openssl"
-
- if [ "`gcc-major-version`" -eq "2" ]; then
+ if [[ $(gcc-major-version) == 2 ]]; then
myconf="${myconf} --disable-isoc"
fi
- ./configure \
- --prefix=/usr \
+ econf \
--enable-all \
--enable-threads \
+ $(use_with ssl) \
+ $(use_enable debug) \
${myconf} || die "configure failed"
- if [ "`gcc-major-version`" -eq "3" ] && [ "`gcc-minor-version`" -ge "3" ]; then
+ if [[ $(gcc-major-version) == 3 ]] && [[ $(gcc-minor-version) == 3 ]]; then
sed -i "s:-Wsign-promo::g" Makefile
fi
@@ -50,8 +43,8 @@ src_compile() {
src_install () {
- make prefix=${D}/usr install || die "make install failed"
- dodoc AUTHORS COPYING COPYING.GPL INSTALL ChangeLog NEWS Notes README TODO
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS INSTALL ChangeLog NEWS Notes README TODO
dohtml doc/api.xml
}