summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2011-10-09 22:41:00 +0000
committerPacho Ramos <pacho@gentoo.org>2011-10-09 22:41:00 +0000
commitf16a68fcafcbbd84d9c6804fe55866aff0ac5ecf (patch)
treea93b954cb4456811aff616d3cb68f5e13429b83e /net-libs/libepc/libepc-0.4.1.ebuild
parentRemove old. (diff)
downloadgentoo-2-f16a68fcafcbbd84d9c6804fe55866aff0ac5ecf.tar.gz
gentoo-2-f16a68fcafcbbd84d9c6804fe55866aff0ac5ecf.tar.bz2
gentoo-2-f16a68fcafcbbd84d9c6804fe55866aff0ac5ecf.zip
Version bump.
(Portage version: 2.1.10.22/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/libepc/libepc-0.4.1.ebuild')
-rw-r--r--net-libs/libepc/libepc-0.4.1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/net-libs/libepc/libepc-0.4.1.ebuild b/net-libs/libepc/libepc-0.4.1.ebuild
new file mode 100644
index 000000000000..c5edd4146bf3
--- /dev/null
+++ b/net-libs/libepc/libepc-0.4.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libepc/libepc-0.4.1.ebuild,v 1.1 2011/10/09 22:41:00 pacho Exp $
+
+EAPI="4"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2
+
+DESCRIPTION="Easy Publish and Consume library for network discovered services"
+HOMEPAGE="http://live.gnome.org/libepc/"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND=">=net-dns/avahi-0.6[dbus,gtk3]
+ >=dev-libs/glib-2.15.1
+ >=net-libs/gnutls-1.4
+ >=sys-libs/e2fsprogs-libs-1.36
+ >=x11-libs/gtk+-3.0:3
+ >=net-libs/libsoup-2.3:2.4"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.14
+ >=dev-util/intltool-0.35.0
+ doc? ( >=dev-util/gtk-doc-1.4 )"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+# FIXME: 2 out of 16 tests fail, upstream bug #578792
+RESTRICT="test"
+
+src_test() {
+ unset DBUS_SYSTEM_BUS_ADDRESS
+ emake check || die "emake check failed"
+}