summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2014-05-31 10:05:41 +0000
committerPacho Ramos <pacho@gentoo.org>2014-05-31 10:05:41 +0000
commit750fae4a171b2a10a826e8eb9072ef762ff62569 (patch)
tree8c6bb444d07af93e7e8d9b219115a58439591473 /net-libs/gupnp
parentVersion bump (diff)
downloadgentoo-2-750fae4a171b2a10a826e8eb9072ef762ff62569.tar.gz
gentoo-2-750fae4a171b2a10a826e8eb9072ef762ff62569.tar.bz2
gentoo-2-750fae4a171b2a10a826e8eb9072ef762ff62569.zip
Version bump
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'net-libs/gupnp')
-rw-r--r--net-libs/gupnp/ChangeLog7
-rw-r--r--net-libs/gupnp/gupnp-0.20.11.ebuild69
2 files changed, 75 insertions, 1 deletions
diff --git a/net-libs/gupnp/ChangeLog b/net-libs/gupnp/ChangeLog
index ecc180cc72c9..d85daf10db40 100644
--- a/net-libs/gupnp/ChangeLog
+++ b/net-libs/gupnp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/gupnp
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/gupnp/ChangeLog,v 1.82 2014/04/26 06:36:11 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gupnp/ChangeLog,v 1.83 2014/05/31 10:05:41 pacho Exp $
+
+*gupnp-0.20.11 (31 May 2014)
+
+ 31 May 2014; Pacho Ramos <pacho@gentoo.org> +gupnp-0.20.11.ebuild:
+ Version bump
26 Apr 2014; Pacho Ramos <pacho@gentoo.org> -gupnp-0.18.4.ebuild,
-gupnp-0.20.8.ebuild:
diff --git a/net-libs/gupnp/gupnp-0.20.11.ebuild b/net-libs/gupnp/gupnp-0.20.11.ebuild
new file mode 100644
index 000000000000..f986dfd1ab56
--- /dev/null
+++ b/net-libs/gupnp/gupnp-0.20.11.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gupnp/gupnp-0.20.11.ebuild,v 1.1 2014/05/31 10:05:41 pacho Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+VALA_MIN_API_VERSION="0.14"
+VALA_USE_DEPEND="vapigen"
+# FIXME: Claims to works with python3 but appears to be wishful thinking
+PYTHON_COMPAT=( python{2_6,2_7} )
+PYTHON_REQ_USE="xml"
+
+inherit gnome2 python-r1 vala
+
+DESCRIPTION="An object-oriented framework for creating UPnP devs and control points"
+HOMEPAGE="https://wiki.gnome.org/Projects/GUPnP"
+
+LICENSE="LGPL-2"
+SLOT="0/4"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="connman +introspection kernel_linux networkmanager"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ >=net-libs/gssdp-0.13.0:0=[introspection?]
+ >=net-libs/libsoup-2.28.2:2.4[introspection?]
+ >=dev-libs/glib-2.24:2
+ dev-libs/libxml2
+ || (
+ >=sys-apps/util-linux-2.16
+ <sys-libs/e2fsprogs-libs-1.41.8 )
+ introspection? (
+ >=dev-libs/gobject-introspection-0.6.4
+ $(vala_depend) )
+ connman? (
+ >=dev-libs/glib-2.28:2
+ >=net-misc/connman-0.80 )
+ networkmanager? ( >=dev-libs/glib-2.26:2 )
+ !net-libs/gupnp-vala
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ use introspection && vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ local backend=unix
+ use kernel_linux && backend=linux
+ use connman && backend=connman
+ use networkmanager && backend=network-manager
+
+ gnome2_src_configure \
+ $(use_enable introspection) \
+ --disable-static \
+ --with-context-manager=${backend}
+}
+
+src_install() {
+ gnome2_src_install
+ python_parallel_foreach_impl python_doscript tools/gupnp-binding-tool
+}