summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2013-09-08 15:28:17 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2013-09-08 15:28:17 +0000
commiteeef2ebb2318603cfb2df999275bd0f684de07c6 (patch)
tree923bcddc976b1f58a359291ed29f9b9ee201114b /net-libs/gssdp
parentVersion bump. Drop USE=doc conditionals, it wasn't used and always installed ... (diff)
downloadgentoo-2-eeef2ebb2318603cfb2df999275bd0f684de07c6.tar.gz
gentoo-2-eeef2ebb2318603cfb2df999275bd0f684de07c6.tar.bz2
gentoo-2-eeef2ebb2318603cfb2df999275bd0f684de07c6.zip
Version bump.
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key C6085806)
Diffstat (limited to 'net-libs/gssdp')
-rw-r--r--net-libs/gssdp/ChangeLog7
-rw-r--r--net-libs/gssdp/gssdp-0.14.5.ebuild49
2 files changed, 55 insertions, 1 deletions
diff --git a/net-libs/gssdp/ChangeLog b/net-libs/gssdp/ChangeLog
index 873452a5adf5..e2ef8690f673 100644
--- a/net-libs/gssdp/ChangeLog
+++ b/net-libs/gssdp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/gssdp
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/gssdp/ChangeLog,v 1.58 2013/08/01 18:44:53 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gssdp/ChangeLog,v 1.59 2013/09/08 15:28:17 eva Exp $
+
+*gssdp-0.14.5 (08 Sep 2013)
+
+ 08 Sep 2013; Gilles Dartiguelongue <eva@gentoo.org> +gssdp-0.14.5.ebuild:
+ Version bump.
*gssdp-0.14.4 (01 Aug 2013)
diff --git a/net-libs/gssdp/gssdp-0.14.5.ebuild b/net-libs/gssdp/gssdp-0.14.5.ebuild
new file mode 100644
index 000000000000..f395c000ca18
--- /dev/null
+++ b/net-libs/gssdp/gssdp-0.14.5.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gssdp/gssdp-0.14.5.ebuild,v 1.1 2013/09/08 15:28:17 eva Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+VALA_MIN_API_VERSION="0.14"
+VALA_USE_DEPEND="vapigen"
+
+inherit gnome2 vala
+
+DESCRIPTION="A GObject-based API for handling resource discovery and announcement over SSDP"
+HOMEPAGE="http://gupnp.org/"
+
+LICENSE="LGPL-2"
+SLOT="0/3"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="+introspection +gtk"
+
+RDEPEND="
+ >=dev-libs/glib-2.32:2
+ >=net-libs/libsoup-2.26.1:2.4[introspection?]
+ gtk? ( >=x11-libs/gtk+-3.0:3 )
+ introspection? (
+ $(vala_depend)
+ >=dev-libs/gobject-introspection-0.6.7 )
+ !<net-libs/gupnp-vala-0.10.3
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.10
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ # Disable functional test as it requires port that might be used by rygel to
+ # be free of use
+ sed 's/\(check_PROGRAMS.*\)test-functional$(EXEEXT)/\1/' \
+ -i "${S}"/tests/gtest/Makefile.in || die
+ use introspection && vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_enable introspection) \
+ $(use_with gtk) \
+ --disable-static
+}