summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2013-10-18 11:39:55 +0000
committerLars Wendler <polynomial-c@gentoo.org>2013-10-18 11:39:55 +0000
commit4c769fe373ce2b6d782282ae051693efaf29c067 (patch)
tree0d9c1286e18fd98263ccf2f6b63d7dfa85e5a913 /net-libs/gsoap
parent1.7 version bump. (diff)
downloadgentoo-2-4c769fe373ce2b6d782282ae051693efaf29c067.tar.gz
gentoo-2-4c769fe373ce2b6d782282ae051693efaf29c067.tar.bz2
gentoo-2-4c769fe373ce2b6d782282ae051693efaf29c067.zip
Readded gsoap-2.8.12 for bug #456354
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0x981CA6FC)
Diffstat (limited to 'net-libs/gsoap')
-rw-r--r--net-libs/gsoap/ChangeLog6
-rw-r--r--net-libs/gsoap/gsoap-2.8.12.ebuild75
2 files changed, 80 insertions, 1 deletions
diff --git a/net-libs/gsoap/ChangeLog b/net-libs/gsoap/ChangeLog
index 6547aaf6e1c7..82b1e8b675f1 100644
--- a/net-libs/gsoap/ChangeLog
+++ b/net-libs/gsoap/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-libs/gsoap
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/gsoap/ChangeLog,v 1.28 2013/09/20 12:41:21 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gsoap/ChangeLog,v 1.29 2013/10/18 11:39:55 polynomial-c Exp $
+
+ 18 Oct 2013; Lars Wendler <polynomial-c@gentoo.org> +gsoap-2.8.12.ebuild:
+ Readded gsoap-2.8.12 as this is the last version working with
+ app-emulation/virtualbox[vboxwebsrv] (bug #456354).
20 Sep 2013; Lars Wendler <polynomial-c@gentoo.org> -gsoap-2.8.14.ebuild:
Removed old.
diff --git a/net-libs/gsoap/gsoap-2.8.12.ebuild b/net-libs/gsoap/gsoap-2.8.12.ebuild
new file mode 100644
index 000000000000..e84ccee0278e
--- /dev/null
+++ b/net-libs/gsoap/gsoap-2.8.12.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gsoap/gsoap-2.8.12.ebuild,v 1.3 2013/10/18 11:39:55 polynomial-c Exp $
+
+EAPI=4
+
+inherit autotools eutils
+
+MY_P="${PN}-2.8"
+
+DESCRIPTION="A cross-platform open source C and C++ SDK to ease the development of SOAP/XML Web services"
+HOMEPAGE="http://gsoap2.sourceforge.net"
+SRC_URI="mirror://sourceforge/gsoap2/gsoap_${PV}.zip"
+
+LICENSE="GPL-2 gSOAP"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc debug examples ipv6 gnutls +ssl"
+
+DEPEND="app-arch/unzip
+ sys-devel/flex
+ sys-devel/bison
+ sys-libs/zlib
+ gnutls? ( net-libs/gnutls )
+ ssl? ( dev-libs/openssl )"
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ # Fix Pre-ISO headers
+ epatch "${FILESDIR}/${PN}-2.7.10-fedora-install_soapcpp2_wsdl2h_aux.patch"
+
+ # Fix configure.in for >=automake-1.13
+ sed 's@AM_CONFIG_HEADER@AC_CONFIG_HEADERS@' -i configure.in || die
+
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=
+ use ssl || myconf+="--disable-ssl "
+ use gnutls && myconf+="--enable-gnutls "
+ use ipv6 && myconf+="--enable-ipv6 "
+ econf \
+ ${myconf} \
+ $(use_enable debug) \
+ $(use_enable examples samples)
+}
+
+src_compile() {
+ emake -j1
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ # yes, we also install the license-file since
+ # it contains info about how to apply the licenses
+ dodoc *.txt
+
+ dohtml changelog.html
+
+ find "${D}"/usr/ -name "*.la" -exec rm {} \;
+
+ if use examples; then
+ rm -rf gsoap/samples/Makefile* gsoap/samples/*/Makefile* gsoap/samples/*/*.o
+ insinto /usr/share/doc/${PF}/examples
+ doins -r gsoap/samples/*
+ fi
+
+ if use doc; then
+ dohtml -r gsoap/doc/*
+ fi
+}