summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2012-10-18 21:34:31 +0000
committerAnthony G. Basile <blueness@gentoo.org>2012-10-18 21:34:31 +0000
commit054a2e771b068b80f9d4a74c454558b539e966b5 (patch)
treeff55cf63205fc3174e9cdbe64cbfff21d71b8faf /net-libs/cyassl
parentsci-libs/cbflib: Remove virtual/fortran and always call fortran-2_pkg_setup a... (diff)
downloadgentoo-2-054a2e771b068b80f9d4a74c454558b539e966b5.tar.gz
gentoo-2-054a2e771b068b80f9d4a74c454558b539e966b5.tar.bz2
gentoo-2-054a2e771b068b80f9d4a74c454558b539e966b5.zip
Version bump
(Portage version: 2.1.11.9/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/cyassl')
-rw-r--r--net-libs/cyassl/ChangeLog9
-rw-r--r--net-libs/cyassl/cyassl-2.4.0.ebuild110
-rw-r--r--net-libs/cyassl/files/cyassl-2.4.0-fix-missing-DYNAMIC_TYPE_LIBZ.patch21
3 files changed, 138 insertions, 2 deletions
diff --git a/net-libs/cyassl/ChangeLog b/net-libs/cyassl/ChangeLog
index 8c03e9e7fd5c..67371bcad443 100644
--- a/net-libs/cyassl/ChangeLog
+++ b/net-libs/cyassl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/cyassl
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/cyassl/ChangeLog,v 1.17 2012/09/06 10:27:49 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/cyassl/ChangeLog,v 1.18 2012/10/18 21:34:31 blueness Exp $
+
+*cyassl-2.4.0 (18 Oct 2012)
+
+ 18 Oct 2012; Anthony G. Basile <blueness@gentoo.org> +cyassl-2.4.0.ebuild,
+ +files/cyassl-2.4.0-fix-missing-DYNAMIC_TYPE_LIBZ.patch:
+ Version bump
06 Sep 2012; Anthony G. Basile <blueness@gentoo.org> cyassl-2.2.0.ebuild:
Stable ppc64, bug #421479
@@ -70,4 +76,3 @@
+files/cyassl-2.0.8-disable-testsuit-ifnothreads.patch,
+files/cyassl-2.0.8-fix-gnustack.patch, +metadata.xml:
Initial commit
-
diff --git a/net-libs/cyassl/cyassl-2.4.0.ebuild b/net-libs/cyassl/cyassl-2.4.0.ebuild
new file mode 100644
index 000000000000..a2bf9d520ab1
--- /dev/null
+++ b/net-libs/cyassl/cyassl-2.4.0.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/cyassl/cyassl-2.4.0.ebuild,v 1.1 2012/10/18 21:34:31 blueness Exp $
+
+EAPI="4"
+
+inherit eutils
+
+DESCRIPTION="Lightweight SSL/TLS library targeted at embedded and RTOS environments"
+HOMEPAGE="http://www.yassl.com/yaSSL/Home.html"
+SRC_URI="http://dev.gentoo.org/~blueness/${PN}/${P}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~x86"
+
+#Add CRYPTO_OPTS=ecc when fixed
+CACHE_SIZE="small big +huge"
+CRYPTO_OPTS="aes-gcm aes-ni +hc128 md2 +psk +ripemd sha512"
+CERT_OPTS="ocsp crl crl-monitor +sessioncerts +testcert"
+IUSE="debug -dtls ipv6 +httpd +sniffer static-libs threads +zlib cyassl-hardening ${CACHE_SIZE} ${CRYPTO_OPTS} ${CERT_OPTS}"
+
+#You can only pick one cach size
+#sha512 is broken on x86
+#Testing freezes with dtls
+REQUIRED_USE="^^ ( small big huge )
+ test? ( !dtls )"
+
+DEPEND="app-arch/unzip
+ sniffer? ( net-libs/libpcap )
+ zlib? ( sys-libs/zlib )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.0.8-disable-testsuit-ifnothreads.patch
+
+ #Apply unconditionally, but only triggered if USE="aes-ni"
+ epatch "${FILESDIR}"/${PN}-2.0.8-fix-gnustack.patch
+
+ # https://sourceforge.net/tracker/?func=detail&atid=714511&aid=3576451&group_id=129181
+ epatch "${FILESDIR}"/${P}-fix-missing-DYNAMIC_TYPE_LIBZ.patch
+}
+
+src_configure() {
+ local myconf=()
+
+ if use threads; then
+ myconf+=( --disable-singleThreaded )
+ else
+ myconf+=( --enable-singleThreaded )
+ fi
+
+ if use amd64; then
+ myconf+=( --enable-fastmath --enable-fasthugemath --enable-bump )
+ elif use x86; then
+ #not pie friendly, sorry x86, no fast math for you :(
+ myconf+=( --disable-fastmath --disable-fasthugemath --disable-bump )
+ fi
+
+ #There are lots of options, so we'll force a few reasonable
+ #We may change this in the future, in particular ecc needs to be fixed
+ econf \
+ --enable-opensslExtra \
+ --enable-fortress \
+ --enable-keygen \
+ --enable-certgen \
+ --disable-debug \
+ --disable-ecc \
+ --disable-small \
+ --disable-ntru \
+ --disable-noFilesystem \
+ --disable-noInline \
+ $(use_enable debug) \
+ $(use_enable small smallcache) \
+ $(use_enable big bigcache) \
+ $(use_enable huge hugecache) \
+ $(use_enable aes-gcm aesgcm) \
+ $(use_enable aes-ni aesni) \
+ $(use_enable hc128) \
+ $(use_enable md2) \
+ $(use_enable psk) \
+ $(use_enable ripemd) \
+ $(use_enable sha512) \
+ $(use_enable dtls) \
+ $(use_enable ipv6) \
+ $(use_enable httpd webServer) \
+ $(use_enable ocsp) \
+ $(use_enable crl) \
+ $(use_enable crl-monitor) \
+ $(use_enable sessioncerts) \
+ $(use_enable sniffer) \
+ $(use_enable testcert) \
+ $(use_enable static-libs static) \
+ $(use_enable cyassl-hardening gcc-hardening) \
+ $(use_with zlib libz) \
+ "${myconf[@]}"
+}
+
+src_test() {
+ "${S}"/tests/unit
+ "${S}"/ctaocrypt/benchmark/benchmark
+}
+
+src_install() {
+ default
+
+ mv "${D}"/usr/share/doc/"${PN}"/* \
+ "${D}"/usr/share/doc/"${P}"/
+ rmdir "${D}"/usr/share/doc/"${PN}"/
+}
diff --git a/net-libs/cyassl/files/cyassl-2.4.0-fix-missing-DYNAMIC_TYPE_LIBZ.patch b/net-libs/cyassl/files/cyassl-2.4.0-fix-missing-DYNAMIC_TYPE_LIBZ.patch
new file mode 100644
index 000000000000..dfa8903d95d4
--- /dev/null
+++ b/net-libs/cyassl/files/cyassl-2.4.0-fix-missing-DYNAMIC_TYPE_LIBZ.patch
@@ -0,0 +1,21 @@
+Fixes build error with missing DYNAMIC_TYPE_LIBZ
+
+Bug: https://sourceforge.net/tracker/?func=detail&atid=714511&aid=3576451&group_id=129181
+Patch: git://github.com/cyassl/cyassl.git
+Commit: ef47f1a25eab16e5d59fc4118c7b704eb5c07711
+
+--
+diff --git a/cyassl/ctaocrypt/types.h b/cyassl/ctaocrypt/types.h
+index cfe2fea..3c171ec 100644
+--- a/cyassl/ctaocrypt/types.h
++++ b/cyassl/ctaocrypt/types.h
+@@ -221,7 +221,8 @@ enum {
+ DYNAMIC_TYPE_RNG = 32,
+ DYNAMIC_TYPE_ARRAYS = 33,
+ DYNAMIC_TYPE_DTLS_POOL = 34,
+- DYNAMIC_TYPE_SOCKADDR = 35
++ DYNAMIC_TYPE_SOCKADDR = 35,
++ DYNAMIC_TYPE_LIBZ = 36
+ };
+
+ /* stack protection */