summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandon Low <lostlogic@gentoo.org>2002-10-11 15:46:43 +0000
committerBrandon Low <lostlogic@gentoo.org>2002-10-11 15:46:43 +0000
commitf09a2a9eba3b7799ae431cfdf346fd1d8a30000f (patch)
treeb94040b42ceb54142de9f760aa7ffb04865ff732 /net-irc
parentadded ppc to keywords (diff)
downloadgentoo-2-f09a2a9eba3b7799ae431cfdf346fd1d8a30000f.tar.gz
gentoo-2-f09a2a9eba3b7799ae431cfdf346fd1d8a30000f.tar.bz2
gentoo-2-f09a2a9eba3b7799ae431cfdf346fd1d8a30000f.zip
yes.
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/xchat/ChangeLog10
-rw-r--r--net-irc/xchat/files/digest-xchat-1.9.3-r11
-rw-r--r--net-irc/xchat/xchat-1.9.3-r1.ebuild99
3 files changed, 108 insertions, 2 deletions
diff --git a/net-irc/xchat/ChangeLog b/net-irc/xchat/ChangeLog
index 4a59415d6412..184b1b8c53e7 100644
--- a/net-irc/xchat/ChangeLog
+++ b/net-irc/xchat/ChangeLog
@@ -1,10 +1,16 @@
# ChangeLog for net-irc/xchat
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/ChangeLog,v 1.22 2002/10/11 15:01:47 lostlogic Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/ChangeLog,v 1.23 2002/10/11 15:46:43 lostlogic Exp $
+
+*xchat-1.9.3-r1.ebuild (11 Oct 2002)
+
+ 11 Oct 2002; Brandon Low <lostlogic@gentoo.org> xchat-1.9.3-r1.ebuild:
+
+ Fix for location and name of plugins now installed to /usr/lib/xchat-2
*xchat-1.9.3.ebuild (11 Oct 2002)
- 11 Oct 2002; Brandon Low <lostlogic@gentoo.org> xchat-1.9.3.ebuild/xchat-1.9.3.ebuild:
+ 11 Oct 2002; Brandon Low <lostlogic@gentoo.org> xchat-1.9.3.ebuild:
Add another masked version in the gtk2 series.
diff --git a/net-irc/xchat/files/digest-xchat-1.9.3-r1 b/net-irc/xchat/files/digest-xchat-1.9.3-r1
new file mode 100644
index 000000000000..634374dec87b
--- /dev/null
+++ b/net-irc/xchat/files/digest-xchat-1.9.3-r1
@@ -0,0 +1 @@
+MD5 7fbb3d96ab4b288343a6d9cf9e597d25 xchat-1.9.3.tar.bz2 701422
diff --git a/net-irc/xchat/xchat-1.9.3-r1.ebuild b/net-irc/xchat/xchat-1.9.3-r1.ebuild
new file mode 100644
index 000000000000..b45cfc766057
--- /dev/null
+++ b/net-irc/xchat/xchat-1.9.3-r1.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/xchat-1.9.3-r1.ebuild,v 1.1 2002/10/11 15:46:43 lostlogic Exp $
+
+IUSE="ssl nls gnome ipv6 mmx python gtk perl"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="X-Chat is a graphical IRC client for UNIX operating systems."
+SRC_URI="http://www.xchat.org/files/source/1.9/${P}.tar.bz2"
+HOMEPAGE="http://www.xchat.org/"
+
+LICENSE="GPL-2"
+SLOT="1"
+KEYWORDS="x86 ppc sparc sparc64"
+
+RDEPEND=">=dev-libs/glib-2.0.4
+ >=x11-libs/gtk+-2.0.5
+ perl? ( >=sys-devel/perl-5.6.1 )
+ gnome? ( >=x11-libs/libzvt-2.0.1
+ >=gnome-base/libgnome-2.0.1
+ >=gnome-base/gnome-applets-2.0.0
+ >=gnome-base/gnome-panel-2.0.1 )
+ ssl? ( >=dev-libs/openssl-0.9.6d )"
+
+DEPEND="${RDEPEND}
+ nls? ( >=sys-devel/gettext-0.10.38 )"
+
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+}
+
+
+# From the xchat 1.9.2 README_FIRST file:
+# (one of the) REMAINING PROBLEMS:
+# * can't compile with gnome, panel and zvt support *
+# stroke
+
+src_compile() {
+
+ local myopts myflags
+
+ if [ ! `use perl` ] ; then
+ use gnome \
+ && myopts="${myopts} --enable-gnome --enable-panel" \
+ || myopts="${myopts} --enable-gtkfe --disable-gnome --disable-zvt"
+
+ use gnome \
+ && CFLAGS="${CFLAGS} -I/usr/include/orbit-2.0" \
+ || myopts="${myopts} --disable-gnome"
+ fi
+
+ use gtk \
+ || myopts="${myopts} --disable-gtkfe"
+
+ use ssl \
+ && myopts="${myopts} --enable-openssl"
+
+ use perl \
+ || myopts="${myopts} --disable-perl"
+
+ use python \
+ || myopts="${myopts} --disable-python"
+
+ use nls \
+ && myopts="${myopts} --enable-hebrew --enable-japanese-conv" \
+ || myopts="${myopts} --disable-nls"
+
+ use mmx \
+ && myopts="${myopts} --enable-mmx" \
+ || myopts="${myopts} --disable-mmx"
+
+ use ipv6 \
+ && myopts="${myopts} --enable-ipv6"
+
+
+ econf \
+ --program-suffix=-2 \
+ ${myopts} || die "Configure failed"
+
+ MAKEOPTS="-j1" emake || die "Compile failed"
+}
+
+src_install() {
+
+ einstall utildir=${D}${KDEDIR}/share/applnk/Internet install || die "Install failed"
+
+ mv ${D}usr/lib/xchat ${D}usr/lib/xchat-2 || die
+ for file in ${D}usr/lib/xchat-2/plugins/* ;do
+ mv ${file} ${file/.so-2/}.so || die
+ done
+
+ use gnome &&
+ ( insinto /usr/share/gnome/apps/Internet
+ doins xchat.desktop )
+
+ dodoc AUTHORS COPYING ChangeLog README
+}