summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNathan Phillip Brink <binki@gentoo.org>2011-10-20 18:14:07 +0000
committerNathan Phillip Brink <binki@gentoo.org>2011-10-20 18:14:07 +0000
commitc92e4f42572e608bc9664ca2ce2d8a310fd25498 (patch)
tree0f0aabbbf4f78fc9789a57f34cb077672164ced4 /net-irc
parentMarking make-3.82-r1 ppc for bug 381199 (diff)
downloadgentoo-2-c92e4f42572e608bc9664ca2ce2d8a310fd25498.tar.gz
gentoo-2-c92e4f42572e608bc9664ca2ce2d8a310fd25498.tar.bz2
gentoo-2-c92e4f42572e608bc9664ca2ce2d8a310fd25498.zip
Bump to ii-1.6 for bug #387907 by Richard Anderson. Install query.sh as ii-query, bump to EAPI=4.
(Portage version: 2.2.0_alpha67-r1/cvs/Linux x86_64)
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/ii/ChangeLog11
-rw-r--r--net-irc/ii/ii-1.4.ebuild37
-rw-r--r--net-irc/ii/ii-1.6.ebuild40
3 files changed, 49 insertions, 39 deletions
diff --git a/net-irc/ii/ChangeLog b/net-irc/ii/ChangeLog
index 9836da4b538a..931094f5b691 100644
--- a/net-irc/ii/ChangeLog
+++ b/net-irc/ii/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-irc/ii
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/ii/ChangeLog,v 1.6 2008/11/27 09:59:06 armin76 Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/ii/ChangeLog,v 1.7 2011/10/20 18:14:07 binki Exp $
+
+*ii-1.6 (20 Oct 2011)
+
+ 20 Oct 2011; Nathan Phillip Brink <binki@gentoo.org> -ii-1.4.ebuild,
+ +ii-1.6.ebuild:
+ Bump to ii-1.6 for bug #387907 by Richard Anderson. Install query.sh as
+ ii-query, bump to EAPI=4.
*ii-1.4 (27 Nov 2008)
diff --git a/net-irc/ii/ii-1.4.ebuild b/net-irc/ii/ii-1.4.ebuild
deleted file mode 100644
index 3ba44cb4b03f..000000000000
--- a/net-irc/ii/ii-1.4.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/ii/ii-1.4.ebuild,v 1.1 2008/11/27 09:59:06 armin76 Exp $
-
-inherit toolchain-funcs
-
-DESCRIPTION="A minimalist FIFO and filesystem-based IRC client"
-HOMEPAGE="http://www.suckless.org/programs/ii.html"
-SRC_URI="http://code.suckless.org/dl/tools/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-DEPEND=""
-RDEPEND=""
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- sed -i \
- -e "s/CFLAGS = -g -O0/CFLAGS += -g/" \
- -e "s/LDFLAGS =/LDFLAGS +=/" \
- config.mk || die "sed failed"
-}
-
-src_compile() {
- emake CC=$(tc-getCC) || die "emake failed"
-}
-
-src_install() {
- dobin ii
- dodoc README FAQ
- doman *.1
-}
diff --git a/net-irc/ii/ii-1.6.ebuild b/net-irc/ii/ii-1.6.ebuild
new file mode 100644
index 000000000000..9b328cd2f229
--- /dev/null
+++ b/net-irc/ii/ii-1.6.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/ii/ii-1.6.ebuild,v 1.1 2011/10/20 18:14:07 binki Exp $
+
+EAPI=4
+
+inherit fixheadtails toolchain-funcs
+
+DESCRIPTION="A minimalist FIFO and filesystem-based IRC client"
+HOMEPAGE="http://tools.suckless.org/ii/"
+SRC_URI="http://dl.suckless.org/tools/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_prepare() {
+ sed -i \
+ -e "s/CFLAGS = -g -O0/CFLAGS += /" \
+ -e "s/LDFLAGS =/LDFLAGS +=/" \
+ -e /^LIBS/d \
+ config.mk || die "sed failed to fix {C,LD}FLAGS"
+
+ ht_fix_file query.sh
+}
+
+src_compile() {
+ emake CC=$(tc-getCC)
+}
+
+src_install() {
+ dobin ii
+ newbin query.sh ii-query
+ dodoc CHANGES FAQ README
+ doman *.1
+}