summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBjarke Istrup Pedersen <gurligebis@gentoo.org>2010-07-22 11:43:47 +0000
committerBjarke Istrup Pedersen <gurligebis@gentoo.org>2010-07-22 11:43:47 +0000
commita6d935a829947f3abebdcfce06aa4d78565c6178 (patch)
treefe6737b52c7b975d4eaec25c619c9bdea99987b2 /net-irc
parentBumping to 0.9.20 (diff)
downloadgentoo-2-a6d935a829947f3abebdcfce06aa4d78565c6178.tar.gz
gentoo-2-a6d935a829947f3abebdcfce06aa4d78565c6178.tar.bz2
gentoo-2-a6d935a829947f3abebdcfce06aa4d78565c6178.zip
Bumping to 1.8.4
(Portage version: 2.2_rc67/cvs/Linux i686)
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/anope/ChangeLog10
-rw-r--r--net-irc/anope/anope-1.8.4.ebuild157
2 files changed, 165 insertions, 2 deletions
diff --git a/net-irc/anope/ChangeLog b/net-irc/anope/ChangeLog
index f30ad1867eba..75cb637ad3d3 100644
--- a/net-irc/anope/ChangeLog
+++ b/net-irc/anope/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-irc/anope
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/anope/ChangeLog,v 1.15 2009/06/27 11:04:34 patrick Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/anope/ChangeLog,v 1.16 2010/07/22 11:43:47 gurligebis Exp $
+
+*anope-1.8.4 (22 Jul 2010)
+
+ 22 Jul 2010; Bjarke Istrup Pedersen <gurligebis@gentoo.org>
+ +anope-1.8.4.ebuild:
+ Bumping to 1.8.4
*anope-1.8.0 (27 Jun 2009)
diff --git a/net-irc/anope/anope-1.8.4.ebuild b/net-irc/anope/anope-1.8.4.ebuild
new file mode 100644
index 000000000000..3d36e405ea20
--- /dev/null
+++ b/net-irc/anope/anope-1.8.4.ebuild
@@ -0,0 +1,157 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/anope/anope-1.8.4.ebuild,v 1.1 2010/07/22 11:43:47 gurligebis Exp $
+
+inherit eutils versionator
+
+MY_PV=$(replace_version_separator 3 '-')
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+DESCRIPTION="Anope IRC Services"
+HOMEPAGE="http://www.anope.org"
+SRC_URI="mirror://sourceforge/${PN}/${PN}-${MY_PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="mysql"
+
+DEPEND="mysql? ( virtual/mysql )"
+
+INSTALL_DIR="/opt/anope"
+
+pkg_setup() {
+ enewgroup anope
+ enewuser anope -1 -1 "${INSTALL_DIR}" anope
+ if has_version net-irc/anope ; then
+ ewarn
+ ewarn "Make backups before updating as they will be overwritten"
+ ewarn
+ ebeep 10
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/pid-patch.diff
+}
+
+src_compile() {
+ local myconf
+ if ! use mysql; then
+ myconf="${myconf} --without-mysql"
+ fi
+
+ econf \
+ ${myconf} \
+ --bindir ${INSTALL_DIR} \
+ --with-bindir=${INSTALL_DIR} \
+ --with-datadir=${INSTALL_DIR}/data \
+ --with-modules=${INSTALL_DIR}/modules \
+ --with-encryption \
+ --with-rungroup=anope \
+ --with-permissions=077 \
+ || die "Configuration failed."
+
+ sed -i -e "/^build:/s:$: language:g" "${S}"/Makefile || die "sed failed"
+
+ emake || die "Make failed."
+}
+
+src_install() {
+ dodir ${INSTALL_DIR}
+ dodir ${INSTALL_DIR}/data
+ dodir ${INSTALL_DIR}/data/logs
+ dodir ${INSTALL_DIR}/data/languages
+ dodir ${INSTALL_DIR}/data/modules
+ dodir ${INSTALL_DIR}/data/modules/runtime
+
+ dodir /var/run/anope
+ fowners anope:anope /var/run/anope
+ keepdir /var/run/anope
+
+ fowners anope:anope ${INSTALL_DIR}
+ fowners anope:anope ${INSTALL_DIR}/data
+ fowners anope:anope ${INSTALL_DIR}/data/logs
+ fowners anope:anope ${INSTALL_DIR}/data/languages
+ fowners anope:anope ${INSTALL_DIR}/data/modules
+ fowners anope:anope ${INSTALL_DIR}/data/modules/runtime
+
+ exeinto ${INSTALL_DIR}
+ doexe src/services
+ insinto ${INSTALL_DIR}/data
+ newins data/example.conf services.conf.example
+
+ newinitd "${FILESDIR}"/anope.initd anope
+ newconfd "${FILESDIR}"/anope.confd anope
+
+ insinto ${INSTALL_DIR}/data/modules
+ doins src/modules/*.so
+
+ keepdir ${INSTALL_DIR}/data/logs
+
+ insinto ${INSTALL_DIR}/data/languages
+ doins lang/cat
+ doins lang/de
+ doins lang/en_us
+ doins lang/es
+ doins lang/fr
+ doins lang/gr
+ doins lang/hun
+ doins lang/it
+ doins lang/nl
+ doins lang/pl
+ doins lang/pt
+ doins lang/ru
+ doins lang/tr
+
+ keepdir ${INSTALL_DIR}/data/modules/runtime
+
+ insinto ${INSTALL_DIR}/data/modules
+ doins src/protocol/*.so
+ doins src/core/*.so
+
+ fowners anope:anope ${INSTALL_DIR}/services
+ fowners anope:anope ${INSTALL_DIR}/data/languages/cat
+ fowners anope:anope ${INSTALL_DIR}/data/languages/de
+ fowners anope:anope ${INSTALL_DIR}/data/languages/en_us
+ fowners anope:anope ${INSTALL_DIR}/data/languages/fr
+ fowners anope:anope ${INSTALL_DIR}/data/languages/gr
+ fowners anope:anope ${INSTALL_DIR}/data/languages/hun
+ fowners anope:anope ${INSTALL_DIR}/data/languages/it
+ fowners anope:anope ${INSTALL_DIR}/data/languages/nl
+ fowners anope:anope ${INSTALL_DIR}/data/languages/pl
+ fowners anope:anope ${INSTALL_DIR}/data/languages/pt
+ fowners anope:anope ${INSTALL_DIR}/data/languages/ru
+ fowners anope:anope ${INSTALL_DIR}/data/languages/tr
+
+ dodoc Changes Changes.conf Changes.lang Changes.mysql docs/*
+
+ use mysql && dodoc data/tables.sql
+}
+
+pkg_preinst() {
+ if has_version net-irc/anope ; then
+ elog "Making a backup of your config to data/pre-update"
+ mkdir "${ROOT}"opt/anope/data/pre-update
+ cp "${ROOT}"opt/anope/data/* "${ROOT}"opt/anope/data/pre-update
+ fi
+}
+
+pkg_postinst() {
+ echo
+ ewarn "Anope won't run out of the box, you still have to configure it to match your IRCDs configuration."
+ ewarn "Edit ${INSTALL_DIR}/data/services.conf to configure Anope."
+ echo
+ ewarn "!!! ATTENTION !!!"
+ ewarn "Be sure to read Changes.mysql to update your MySQL"
+ ewarn "tables or anope will break after restart"
+ ewarn "!!! ATTENTION !!!"
+
+ if use mysql; then
+ einfo "The mysql script for updating the tables is located in the"
+ einfo "/usr/share/doc/${P} directory"
+ fi
+}