summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2011-07-11 13:29:09 +0000
committerLars Wendler <polynomial-c@gentoo.org>2011-07-11 13:29:09 +0000
commit9b0dc2d4bc0b1f87930fdd1f5e23e5b317c06bd1 (patch)
treeb3aab2ccacb174b121a7a1ab77a412cd1a78e921 /net-irc
parentamd64 stable wrt #374689 (diff)
downloadgentoo-2-9b0dc2d4bc0b1f87930fdd1f5e23e5b317c06bd1.tar.gz
gentoo-2-9b0dc2d4bc0b1f87930fdd1f5e23e5b317c06bd1.tar.bz2
gentoo-2-9b0dc2d4bc0b1f87930fdd1f5e23e5b317c06bd1.zip
Fixed segfault with "+dbus -gtk" USE flags being set (bug #373975)
(Portage version: 2.2.0_alpha43/cvs/Linux x86_64)
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/xchat/ChangeLog8
-rw-r--r--net-irc/xchat/files/xchat-2.8.8-dbus.patch17
-rw-r--r--net-irc/xchat/xchat-2.8.8-r1.ebuild5
-rw-r--r--net-irc/xchat/xchat-2.8.8-r2.ebuild9
4 files changed, 32 insertions, 7 deletions
diff --git a/net-irc/xchat/ChangeLog b/net-irc/xchat/ChangeLog
index 675710c57f95..b209f46dc91f 100644
--- a/net-irc/xchat/ChangeLog
+++ b/net-irc/xchat/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-irc/xchat
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/ChangeLog,v 1.300 2011/07/11 00:01:13 mattst88 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/ChangeLog,v 1.301 2011/07/11 13:29:09 polynomial-c Exp $
+
+ 11 Jul 2011; Lars Wendler <polynomial-c@gentoo.org> xchat-2.8.8-r1.ebuild,
+ xchat-2.8.8-r2.ebuild, +files/xchat-2.8.8-dbus.patch:
+ Fixed segfault with "+dbus -gtk" USE flags being set. Thanks to Claudio
+ Roberto França Pereira who reported this issue in bug #373975 and to Nathan
+ Phillip Brink for a working patch.
11 Jul 2011; Matt Turner <mattst88@gentoo.org> xchat-2.8.8-r2.ebuild:
Added ~mips, bug 313589
diff --git a/net-irc/xchat/files/xchat-2.8.8-dbus.patch b/net-irc/xchat/files/xchat-2.8.8-dbus.patch
new file mode 100644
index 000000000000..7cbb7b27899f
--- /dev/null
+++ b/net-irc/xchat/files/xchat-2.8.8-dbus.patch
@@ -0,0 +1,17 @@
+From: Nathan Phillip Brink <binki@gentoo.org>
+Date: 2011-07-08
+Subject: Initialize gobject-types in dbus-plugin, fixes segfault when
+ GTK+ is disabled (and thus g_type_init() isn't implicitly
+ called by some gtk+ initialization function.)
+
+--- a/src/common/dbus/dbus-plugin.c
++++ b/src/common/dbus/dbus-plugin.c
+@@ -889,6 +889,8 @@
+ guint request_name_result;
+ GError *error = NULL;
+
++ g_type_init();
++
+ dbus_g_object_type_install_info (REMOTE_TYPE_OBJECT,
+ &dbus_glib_remote_object_object_info);
+
diff --git a/net-irc/xchat/xchat-2.8.8-r1.ebuild b/net-irc/xchat/xchat-2.8.8-r1.ebuild
index 7c7da28ad5ab..1667ef978059 100644
--- a/net-irc/xchat/xchat-2.8.8-r1.ebuild
+++ b/net-irc/xchat/xchat-2.8.8-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/xchat-2.8.8-r1.ebuild,v 1.7 2011/03/22 09:54:15 nirbheek Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/xchat-2.8.8-r1.ebuild,v 1.8 2011/07/11 13:29:09 polynomial-c Exp $
EAPI=2
@@ -42,7 +42,8 @@ pkg_setup() {
}
src_prepare() {
- epatch "${FILESDIR}"/${PN}-input-box4.patch
+ epatch "${FILESDIR}"/${PN}-input-box4.patch \
+ "${FILESDIR}"/${P}-dbus.patch
use xchatdccserver && epatch "${DISTDIR}"/xchat-dccserver-0.6.patch.bz2
diff --git a/net-irc/xchat/xchat-2.8.8-r2.ebuild b/net-irc/xchat/xchat-2.8.8-r2.ebuild
index 8871bac312bb..ed7338f3ad97 100644
--- a/net-irc/xchat/xchat-2.8.8-r2.ebuild
+++ b/net-irc/xchat/xchat-2.8.8-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/xchat-2.8.8-r2.ebuild,v 1.5 2011/07/11 00:01:13 mattst88 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/xchat-2.8.8-r2.ebuild,v 1.6 2011/07/11 13:29:09 polynomial-c Exp $
EAPI=3
@@ -44,9 +44,10 @@ pkg_setup() {
}
src_prepare() {
- epatch "${FILESDIR}"/${PN}-input-box4.patch
- epatch "${FILESDIR}"/${PN}-2.8.4-interix.patch
- epatch "${FILESDIR}"/${P}-libnotify07.patch
+ epatch "${FILESDIR}"/${PN}-input-box4.patch \
+ "${FILESDIR}"/${PN}-2.8.4-interix.patch \
+ "${FILESDIR}"/${P}-libnotify07.patch \
+ "${FILESDIR}"/${P}-dbus.patch
use xchatdccserver && epatch "${DISTDIR}"/xchat-dccserver-0.6.patch.bz2