summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2004-07-24 01:35:18 +0000
committerSven Wegener <swegener@gentoo.org>2004-07-24 01:35:18 +0000
commit7c61d81282954e14d50b6026d5fdc3f4df61bde2 (patch)
treeebefea12799dc55cb67dc146af3cf243ed30d24a /net-irc
parentx11-wm/gnustep-env -> gnustep-base/gnustep-env (diff)
downloadgentoo-2-7c61d81282954e14d50b6026d5fdc3f4df61bde2.tar.gz
gentoo-2-7c61d81282954e14d50b6026d5fdc3f4df61bde2.tar.bz2
gentoo-2-7c61d81282954e14d50b6026d5fdc3f4df61bde2.zip
Tidied the ebuilds.
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/irssi-recode/ChangeLog6
-rw-r--r--net-irc/irssi-recode/irssi-recode-1.36.ebuild26
-rw-r--r--net-irc/irssi-recode/irssi-recode-1.5.ebuild27
3 files changed, 36 insertions, 23 deletions
diff --git a/net-irc/irssi-recode/ChangeLog b/net-irc/irssi-recode/ChangeLog
index d237a9788d51..3cfcfaaa77f2 100644
--- a/net-irc/irssi-recode/ChangeLog
+++ b/net-irc/irssi-recode/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-irc/irssi-recode
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/irssi-recode/ChangeLog,v 1.5 2004/06/24 23:06:17 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/irssi-recode/ChangeLog,v 1.6 2004/07/24 01:35:18 swegener Exp $
+
+ 24 Jul 2004; Sven Wegener <swegener@gentoo.org> irssi-recode-1.36.ebuild,
+ irssi-recode-1.5.ebuild:
+ Tidied the ebuilds.
18 Jun 2004; Sven Wegener <swegener@gentoo.org> irssi-recode-1.36.ebuild,
irssi-recode-1.5.ebuild:
diff --git a/net-irc/irssi-recode/irssi-recode-1.36.ebuild b/net-irc/irssi-recode/irssi-recode-1.36.ebuild
index 253b594caaff..398ba6c76932 100644
--- a/net-irc/irssi-recode/irssi-recode-1.36.ebuild
+++ b/net-irc/irssi-recode/irssi-recode-1.36.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/irssi-recode/irssi-recode-1.36.ebuild,v 1.4 2004/06/24 23:06:17 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/irssi-recode/irssi-recode-1.36.ebuild,v 1.5 2004/07/24 01:35:18 swegener Exp $
+
+inherit gcc flag-o-matic
IRSSI="0.8.6"
@@ -10,8 +12,6 @@ HOMEPAGE="http://lefort.be.eu.org/irssi/"
DEPEND=">=net-irc/irssi-${IRSSI}
>=dev-libs/glib-2.0"
-RDEPEND=">=net-irc/irssi-${IRSSI}
- >=dev-libs/glib-2.0"
#Irssi needs to be compiled with glib-2
SLOT="0"
@@ -19,20 +19,24 @@ LICENSE="BSD"
KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ~mips ~amd64 ~ia64"
IUSE=""
+S=${WORKDIR}
+
src_compile() {
+ append-flags -fPIC
+
touch ${WORKDIR}/irssi-${IRSSI}/config.h &&
- gcc -g -shared -DHAVE_CONFIG_H -I${WORKDIR}/irssi-${IRSSI} -I${WORKDIR}/irssi-${IRSSI}/src \
- -I${WORKDIR}/irssi-${IRSSI}/src/core -I${WORKDIR}/irssi-${IRSSI}/src/fe-common/core -I${WORKDIR}/irssi-${IRSSI}/src/irc/core \
- -I${WORKDIR}/irssi-${IRSSI}/src/irc/dcc `pkg-config --cflags glib-2.0` -o ${T}/librecode.so ${FILESDIR}/recode.c || die
+ $(gcc-getCC) -g -shared ${CFLAGS} -DHAVE_CONFIG_H -I${WORKDIR}/irssi-${IRSSI} -I${WORKDIR}/irssi-${IRSSI}/src \
+ -I${WORKDIR}/irssi-${IRSSI}/src/core -I${WORKDIR}/irssi-${IRSSI}/src/fe-common/core -I${WORKDIR}/irssi-${IRSSI}/src/irc/core \
+ -I${WORKDIR}/irssi-${IRSSI}/src/irc/dcc `pkg-config --cflags glib-2.0` -o ${T}/librecode.so ${FILESDIR}/recode.c || die "compile failed"
}
src_install() {
- insinto /usr/lib/irssi/modules
- doins ${T}/librecode.so
+ exeinto /usr/lib/irssi/modules
+ doexe ${T}/librecode.so
}
pkg_postinst() {
-einfo ""
-einfo ""/load recode" in Irssi and type "/help recode" for help"
-einfo ""
+ einfo ""
+ einfo ""/load recode" in Irssi and type "/help recode" for help"
+ einfo ""
}
diff --git a/net-irc/irssi-recode/irssi-recode-1.5.ebuild b/net-irc/irssi-recode/irssi-recode-1.5.ebuild
index c89533087595..6085ecf8abe0 100644
--- a/net-irc/irssi-recode/irssi-recode-1.5.ebuild
+++ b/net-irc/irssi-recode/irssi-recode-1.5.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/irssi-recode/irssi-recode-1.5.ebuild,v 1.3 2004/06/24 23:06:17 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/irssi-recode/irssi-recode-1.5.ebuild,v 1.4 2004/07/24 01:35:18 swegener Exp $
+
+inherit gcc flag-o-matic
IRSSI="0.8.6"
@@ -10,7 +12,6 @@ HOMEPAGE="http://lefort.be.eu.org/irssi/"
DEPEND=">=net-irc/irssi-${IRSSI}
>=dev-libs/glib-2.0"
-RDEPEND=""
#Irssi needs to be compiled with glib-2
SLOT="0"
@@ -18,21 +19,25 @@ LICENSE="BSD"
KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ~mips ~amd64 ~ia64"
IUSE=""
+S=${WORKDIR}
+
src_compile() {
+ append-flags -fPIC
+
touch ${WORKDIR}/irssi-${IRSSI}/config.h &&
- gcc -g -shared -DHAVE_CONFIG_H -I${WORKDIR}/irssi-${IRSSI} -I${WORKDIR}/irssi-${IRSSI}/src \
- -I${WORKDIR}/irssi-${IRSSI}/src/core -I${WORKDIR}/irssi-${IRSSI}/src/fe-common/core \
- `pkg-config --cflags glib-2.0` -o ${T}/librecode.so ${FILESDIR}/recode.c || die
+ $(gcc-getCC) -g -shared ${CFLAGS} -DHAVE_CONFIG_H -I${WORKDIR}/irssi-${IRSSI} -I${WORKDIR}/irssi-${IRSSI}/src \
+ -I${WORKDIR}/irssi-${IRSSI}/src/core -I${WORKDIR}/irssi-${IRSSI}/src/fe-common/core \
+ `pkg-config --cflags glib-2.0` -o ${T}/librecode.so ${FILESDIR}/recode.c || die
}
src_install() {
- insinto /usr/lib/irssi/modules
- doins ${T}/librecode.so
+ exeinto /usr/lib/irssi/modules
+ doexe ${T}/librecode.so
}
pkg_postinst() {
-einfo ""
-einfo "Type /load recode in Irssi to load this module."
-einfo "See ${FILESDIR}/recode.c for more information."
-einfo ""
+ einfo ""
+ einfo "Type /load recode in Irssi to load this module."
+ einfo "See ${FILESDIR}/recode.c for more information."
+ einfo ""
}