summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2007-06-11 11:47:40 +0000
committerRaúl Porcel <armin76@gentoo.org>2007-06-11 11:47:40 +0000
commit1a9bebec90caaeec021f5d133b7b450ffeb67417 (patch)
treecef67eba864a15de1236177c473497981b666612 /net-irc
parentFix bug number. (diff)
downloadgentoo-2-1a9bebec90caaeec021f5d133b7b450ffeb67417.tar.gz
gentoo-2-1a9bebec90caaeec021f5d133b7b450ffeb67417.tar.bz2
gentoo-2-1a9bebec90caaeec021f5d133b7b450ffeb67417.zip
Revbump straight to stable to add a patch from upstream
(Portage version: 2.1.2.9)
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/xchat/ChangeLog9
-rw-r--r--net-irc/xchat/files/digest-xchat-2.8.2-r1 (renamed from net-irc/xchat/files/digest-xchat-2.8.2)0
-rw-r--r--net-irc/xchat/files/xc282-fixtrayzombies.diff14
-rw-r--r--net-irc/xchat/xchat-2.8.2-r1.ebuild (renamed from net-irc/xchat/xchat-2.8.2.ebuild)3
4 files changed, 24 insertions, 2 deletions
diff --git a/net-irc/xchat/ChangeLog b/net-irc/xchat/ChangeLog
index 2c12af319e85..625cdbb798b4 100644
--- a/net-irc/xchat/ChangeLog
+++ b/net-irc/xchat/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-irc/xchat
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/ChangeLog,v 1.249 2007/05/28 18:24:42 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/ChangeLog,v 1.250 2007/06/11 11:47:40 armin76 Exp $
+
+*xchat-2.8.2-r1 (11 Jun 2007)
+
+ 11 Jun 2007; Raúl Porcel <armin76@gentoo.org>
+ +files/xc282-fixtrayzombies.diff, -xchat-2.8.2.ebuild,
+ +xchat-2.8.2-r1.ebuild:
+ Revbump straight to stable to add a patch from upstream
28 May 2007; Raúl Porcel <armin76@gentoo.org>
-files/xchat-2.6.6-suffix.patch, -files/xc280-fix-back.diff,
diff --git a/net-irc/xchat/files/digest-xchat-2.8.2 b/net-irc/xchat/files/digest-xchat-2.8.2-r1
index 78769b5d086e..78769b5d086e 100644
--- a/net-irc/xchat/files/digest-xchat-2.8.2
+++ b/net-irc/xchat/files/digest-xchat-2.8.2-r1
diff --git a/net-irc/xchat/files/xc282-fixtrayzombies.diff b/net-irc/xchat/files/xc282-fixtrayzombies.diff
new file mode 100644
index 000000000000..69a6050c812c
--- /dev/null
+++ b/net-irc/xchat/files/xc282-fixtrayzombies.diff
@@ -0,0 +1,14 @@
+#
+# Fix defunc processes created by opening tray balloons
+#
+--- xchat-2.8.2/src/fe-gtk/plugin-tray.c 20 May 2007 11:08:03 -0000 1.21
++++ xchat-2.8.2p1/src/fe-gtk/plugin-tray.c 31 May 2007 13:12:19 -0000
+@@ -148,7 +148,7 @@
+ argv[5] = title;
+ argv[6] = text = strip_color (text, -1, STRIP_ALL);
+ argv[7] = NULL;
+- util_execv (argv);
++ xchat_execv (argv);
+ g_free ((char *)path);
+ free ((char *)text);
+ }
diff --git a/net-irc/xchat/xchat-2.8.2.ebuild b/net-irc/xchat/xchat-2.8.2-r1.ebuild
index d9e20b52502b..a143f89ed922 100644
--- a/net-irc/xchat/xchat-2.8.2.ebuild
+++ b/net-irc/xchat/xchat-2.8.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/xchat-2.8.2.ebuild,v 1.13 2007/05/27 08:22:21 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/xchat-2.8.2-r1.ebuild,v 1.1 2007/06/11 11:47:40 armin76 Exp $
inherit eutils versionator gnome2
@@ -43,6 +43,7 @@ src_unpack() {
fi
epatch "${FILESDIR}"/${PV}-fe-text-vartype.patch
+ epatch "${FILESDIR}"/xc282-fixtrayzombies.diff
}
src_compile() {