summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason A. Donenfeld <zx2c4@gentoo.org>2014-02-13 13:44:55 +0000
committerJason A. Donenfeld <zx2c4@gentoo.org>2014-02-13 13:44:55 +0000
commite12f3d01e3ed205e1d074b20b74fb69b129030fa (patch)
tree0b3b4e30859329b9d38ac3b10ad46abaabc1ea8f /net-irc/weechat/files
parentCleanup. (diff)
downloadgentoo-2-e12f3d01e3ed205e1d074b20b74fb69b129030fa.tar.gz
gentoo-2-e12f3d01e3ed205e1d074b20b74fb69b129030fa.tar.bz2
gentoo-2-e12f3d01e3ed205e1d074b20b74fb69b129030fa.zip
Fix crash with gnutls and pthreaded plugins.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, RepoMan options: --force, signed Manifest commit with key A5DE03AE)
Diffstat (limited to 'net-irc/weechat/files')
-rw-r--r--net-irc/weechat/files/weechat-0.4.3-always-link-against-pthreads.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/net-irc/weechat/files/weechat-0.4.3-always-link-against-pthreads.patch b/net-irc/weechat/files/weechat-0.4.3-always-link-against-pthreads.patch
new file mode 100644
index 000000000000..2a3bc8807a49
--- /dev/null
+++ b/net-irc/weechat/files/weechat-0.4.3-always-link-against-pthreads.patch
@@ -0,0 +1,28 @@
+From 30073b511397646b9ef06ed657fda157dd8c6209 Mon Sep 17 00:00:00 2001
+From: "Jason A. Donenfeld" <Jason@zx2c4.com>
+Date: Thu, 13 Feb 2014 14:36:23 +0100
+Subject: [PATCH] Link against pthread on all platforms.
+
+Signed-off-by: Jason A. Donenfeld <Jason@zx2c4.com>
+---
+ src/gui/curses/CMakeLists.txt | 4 +---
+ 1 file changed, 1 insertion(+), 3 deletions(-)
+
+diff --git a/src/gui/curses/CMakeLists.txt b/src/gui/curses/CMakeLists.txt
+index 325c611..a8927bc 100644
+--- a/src/gui/curses/CMakeLists.txt
++++ b/src/gui/curses/CMakeLists.txt
+@@ -53,9 +53,7 @@ IF(${CMAKE_SYSTEM_NAME} STREQUAL "FreeBSD")
+ ENDIF(HAVE_BACKTRACE)
+ ENDIF(${CMAKE_SYSTEM_NAME} STREQUAL "FreeBSD")
+
+-IF(${CMAKE_SYSTEM_NAME} STREQUAL "OpenBSD")
+- LIST(APPEND EXTRA_LIBS "pthread")
+-ENDIF(${CMAKE_SYSTEM_NAME} STREQUAL "OpenBSD")
++LIST(APPEND EXTRA_LIBS "pthread")
+
+ IF(ICONV_LIBRARY)
+ LIST(APPEND EXTRA_LIBS ${ICONV_LIBRARY})
+--
+1.8.5.4
+