summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2007-03-13 19:14:02 +0000
committerRaúl Porcel <armin76@gentoo.org>2007-03-13 19:14:02 +0000
commit3fc1ddf5d49faf466cb51877bcf9277945fde052 (patch)
treea6285c739375458a29826616cadcb2d0fc2055ce /net-irc/onis/onis-0.8.2.ebuild
parentStable on sparc wrt #170475 (diff)
downloadgentoo-2-3fc1ddf5d49faf466cb51877bcf9277945fde052.tar.gz
gentoo-2-3fc1ddf5d49faf466cb51877bcf9277945fde052.tar.bz2
gentoo-2-3fc1ddf5d49faf466cb51877bcf9277945fde052.zip
Version bump, drop old
(Portage version: 2.1.2.2)
Diffstat (limited to 'net-irc/onis/onis-0.8.2.ebuild')
-rw-r--r--net-irc/onis/onis-0.8.2.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/net-irc/onis/onis-0.8.2.ebuild b/net-irc/onis/onis-0.8.2.ebuild
new file mode 100644
index 000000000000..981b6532201e
--- /dev/null
+++ b/net-irc/onis/onis-0.8.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/onis/onis-0.8.2.ebuild,v 1.1 2007/03/13 19:14:02 armin76 Exp $
+
+inherit eutils
+
+DESCRIPTION="onis not irc stats"
+HOMEPAGE="http://verplant.org/onis/"
+SRC_URI="http://verplant.org/${PN}/${P}.tar.bz2"
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+IUSE=""
+
+RDEPEND="dev-lang/perl"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/0.6.0-nochdir.patch
+
+ sed -i -e s:lang/:/usr/share/onis/lang/: onis.conf || die "sed failed"
+}
+
+src_install () {
+ eval $(perl -V:installprivlib)
+
+ dobin onis || die "dobin failed"
+
+ insinto "${installprivlib}"
+ doins -r lib/Onis || die "doins failed"
+
+ insinto /usr/share/onis
+ doins -r lang reports/* || die "doins failed"
+
+ dodoc CHANGELOG README THANKS onis.conf users.conf
+}
+
+pkg_postinst() {
+ einfo
+ einfo "The onis themes have been installed in /usr/share/onis/*-theme"
+ einfo "You can find a sample configuration at /usr/share/doc/${PF}/onis.conf.gz"
+ einfo
+}