summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGrant Goodyear <g2boojum@gentoo.org>2002-03-15 17:22:38 +0000
committerGrant Goodyear <g2boojum@gentoo.org>2002-03-15 17:22:38 +0000
commit0122f6495c315269a948ead4a5ae1589c09252ba (patch)
treee63161d34fa36a5c58ab25c5fc209d5944b34c04 /net-irc/irssi
parentadding missing patch. the r8 ebuild was copied to r9, but the patch wasn't, w... (diff)
downloadgentoo-2-0122f6495c315269a948ead4a5ae1589c09252ba.tar.gz
gentoo-2-0122f6495c315269a948ead4a5ae1589c09252ba.tar.bz2
gentoo-2-0122f6495c315269a948ead4a5ae1589c09252ba.zip
Sandbox problems fixed; new version.
Diffstat (limited to 'net-irc/irssi')
-rw-r--r--net-irc/irssi/files/digest-irssi-0.7.98.4-r11
-rw-r--r--net-irc/irssi/files/digest-irssi-0.8.41
-rw-r--r--net-irc/irssi/irssi-0.7.98.4-r1.ebuild72
-rw-r--r--net-irc/irssi/irssi-0.8.4.ebuild72
4 files changed, 146 insertions, 0 deletions
diff --git a/net-irc/irssi/files/digest-irssi-0.7.98.4-r1 b/net-irc/irssi/files/digest-irssi-0.7.98.4-r1
new file mode 100644
index 000000000000..696fc7f4bc94
--- /dev/null
+++ b/net-irc/irssi/files/digest-irssi-0.7.98.4-r1
@@ -0,0 +1 @@
+MD5 b0d761ec1c55d9057cd65c1fb46eb670 irssi-0.7.98.4.tar.bz2 623133
diff --git a/net-irc/irssi/files/digest-irssi-0.8.4 b/net-irc/irssi/files/digest-irssi-0.8.4
new file mode 100644
index 000000000000..adba7db2c168
--- /dev/null
+++ b/net-irc/irssi/files/digest-irssi-0.8.4
@@ -0,0 +1 @@
+MD5 b78413f8596dc2ec190ed7e831a746a8 irssi-0.8.4.tar.bz2 695167
diff --git a/net-irc/irssi/irssi-0.7.98.4-r1.ebuild b/net-irc/irssi/irssi-0.7.98.4-r1.ebuild
new file mode 100644
index 000000000000..21df4ab77217
--- /dev/null
+++ b/net-irc/irssi/irssi-0.7.98.4-r1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Tom von Schwerdtner <tvon@etria.org>
+# $Header: /var/cvsroot/gentoo-x86/net-irc/irssi/irssi-0.7.98.4-r1.ebuild,v 1.1 2002/03/15 17:22:38 g2boojum Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A modular textUI IRC client with IPv6 support."
+SRC_URI="http://irssi.org/files/${P}.tar.bz2"
+HOMEPAGE="http://irssi.org"
+
+DEPEND="virtual/glibc
+ >=dev-libs/glib-1.2.0
+ sys-libs/ncurses
+ perl? ( sys-devel/perl )
+ nls? ( sys-devel/gettext )"
+
+
+src_compile() {
+
+ # Note: there is an option to build a GUI for irssi, but according
+ # to the website the gui is no longer developed, so that option is
+ # not used here.
+
+ # Edit these if you like
+ myconf="--without-servertest --with-bot --with-proxy --with-ncurses"
+
+ if [ -z "`use nls`" ]
+ then
+ myconf="${myconf} --disable-nls"
+ fi
+ if [ "`use perl`" ]
+ then
+ myconf="${myconf} --enable-perl=yes"
+ fi
+ if [ "`use ipv6`" ]
+ then
+ myconf="${myconf} --enable-ipv6"
+ fi
+
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --sysconfdir=/etc \
+ ${myconf} || die "./configure failed"
+
+ emake || die
+}
+
+src_install () {
+
+ myflags=""
+ if [ "`use perl`" ]
+ then
+ R1="s/installsitearch='//"
+ R2="s/';//"
+ perl_sitearch="`perl -V:installsitearch | sed -e ${R1} -e ${R2}`"
+ myflags="${myflags} INSTALLPRIVLIB=${D}/usr"
+ myflags="${myflags} INSTALLARCHLIB=${D}/${perl_sitearch}"
+ myflags="${myflags} INSTALLSITELIB=${D}/${perl_sitearch}"
+ myflags="${myflags} INSTALLSITEARCH=${D}/${perl_sitearch}"
+ fi
+
+ make DESTDIR=${D} \
+ docdir=/usr/share/doc/${PF} \
+ gnulocaledir=${D}/usr/share/locale \
+ ${myflags} \
+ install || die
+
+ dodoc AUTHORS ChangeLog README TODO NEWS
+}
diff --git a/net-irc/irssi/irssi-0.8.4.ebuild b/net-irc/irssi/irssi-0.8.4.ebuild
new file mode 100644
index 000000000000..9015538229df
--- /dev/null
+++ b/net-irc/irssi/irssi-0.8.4.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Tom von Schwerdtner <tvon@etria.org>
+# $Header: /var/cvsroot/gentoo-x86/net-irc/irssi/irssi-0.8.4.ebuild,v 1.1 2002/03/15 17:22:38 g2boojum Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A modular textUI IRC client with IPv6 support."
+SRC_URI="http://irssi.org/files/${P}.tar.bz2"
+HOMEPAGE="http://irssi.org"
+
+DEPEND="virtual/glibc
+ >=dev-libs/glib-1.2.0
+ sys-libs/ncurses
+ perl? ( sys-devel/perl )
+ nls? ( sys-devel/gettext )"
+
+
+src_compile() {
+
+ # Note: there is an option to build a GUI for irssi, but according
+ # to the website the gui is no longer developed, so that option is
+ # not used here.
+
+ # Edit these if you like
+ myconf="--without-servertest --with-bot --with-proxy --with-ncurses"
+
+ if [ -z "`use nls`" ]
+ then
+ myconf="${myconf} --disable-nls"
+ fi
+ if [ "`use perl`" ]
+ then
+ myconf="${myconf} --enable-perl=yes"
+ fi
+ if [ "`use ipv6`" ]
+ then
+ myconf="${myconf} --enable-ipv6"
+ fi
+
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --sysconfdir=/etc \
+ ${myconf} || die "./configure failed"
+
+ emake || die
+}
+
+src_install () {
+
+ myflags=""
+ if [ "`use perl`" ]
+ then
+ R1="s/installsitearch='//"
+ R2="s/';//"
+ perl_sitearch="`perl -V:installsitearch | sed -e ${R1} -e ${R2}`"
+ myflags="${myflags} INSTALLPRIVLIB=${D}/usr"
+ myflags="${myflags} INSTALLARCHLIB=${D}/${perl_sitearch}"
+ myflags="${myflags} INSTALLSITELIB=${D}/${perl_sitearch}"
+ myflags="${myflags} INSTALLSITEARCH=${D}/${perl_sitearch}"
+ fi
+
+ make DESTDIR=${D} \
+ docdir=/usr/share/doc/${PF} \
+ gnulocaledir=${D}/usr/share/locale \
+ ${myflags} \
+ install || die
+
+ dodoc AUTHORS ChangeLog README TODO NEWS
+}