summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNathan Phillip Brink <binki@gentoo.org>2011-12-31 13:41:41 +0000
committerNathan Phillip Brink <binki@gentoo.org>2011-12-31 13:41:41 +0000
commitd3df589fb27df428f02a54060427867e369c39b8 (patch)
tree80e44d40d648cfb7943e15d0d53431ea689e9f37 /net-irc/eggdrop
parentDrop ia64 support #345433 (diff)
downloadgentoo-2-d3df589fb27df428f02a54060427867e369c39b8.tar.gz
gentoo-2-d3df589fb27df428f02a54060427867e369c39b8.tar.bz2
gentoo-2-d3df589fb27df428f02a54060427867e369c39b8.zip
Bump to eggdrop-1.6.21 (bug #338211) including fixes for LDFLAGS (bug #335230) and most parallel make issues (bug #295302). Many thanks to Adam (from Anope) for updating the patches tarball and the SSL patch and adding fixes for bug #196337.
(Portage version: 2.2.0_alpha82-r1/cvs/Linux x86_64)
Diffstat (limited to 'net-irc/eggdrop')
-rw-r--r--net-irc/eggdrop/ChangeLog12
-rw-r--r--net-irc/eggdrop/eggdrop-1.6.21.ebuild104
2 files changed, 114 insertions, 2 deletions
diff --git a/net-irc/eggdrop/ChangeLog b/net-irc/eggdrop/ChangeLog
index 4572475402f3..79ea9484da41 100644
--- a/net-irc/eggdrop/ChangeLog
+++ b/net-irc/eggdrop/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-irc/eggdrop
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/eggdrop/ChangeLog,v 1.86 2010/06/17 21:52:12 patrick Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/eggdrop/ChangeLog,v 1.87 2011/12/31 13:41:41 binki Exp $
+
+*eggdrop-1.6.21 (31 Dec 2011)
+
+ 31 Dec 2011; Nathan Phillip Brink <binki@gentoo.org> +eggdrop-1.6.21.ebuild:
+ Bump to eggdrop-1.6.21 (bug #338211) including fixes for LDFLAGS (bug
+ #335230) and most parallel make issues (bug #295302). Many thanks to Adam
+ (from Anope) for updating the patches tarball and the SSL patch and adding
+ fixes for bug #196337.
17 Jun 2010; Patrick Lauer <patrick@gentoo.org> eggdrop-1.6.18-r3.ebuild,
eggdrop-1.6.19.ebuild:
diff --git a/net-irc/eggdrop/eggdrop-1.6.21.ebuild b/net-irc/eggdrop/eggdrop-1.6.21.ebuild
new file mode 100644
index 000000000000..15e32e3622af
--- /dev/null
+++ b/net-irc/eggdrop/eggdrop-1.6.21.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/eggdrop/eggdrop-1.6.21.ebuild,v 1.1 2011/12/31 13:41:41 binki Exp $
+
+EAPI=4
+
+inherit eutils
+
+MY_P="eggdrop${PV}"
+PATCHSET_V="1.0"
+
+DESCRIPTION="An IRC bot extensible with C or TCL"
+HOMEPAGE="http://www.eggheads.org/"
+SRC_URI="ftp://ftp.eggheads.org/pub/eggdrop/source/1.6/${MY_P}.tar.bz2
+ http://dev.gentoo.org/~binki/distfiles/${CATEGORY}/${PN}/${P}-patches-${PATCHSET_V}.tar.bz2"
+
+KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~ppc ~sparc ~x86"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="debug mysql postgres ssl static vanilla"
+REQUIRED_USE="vanilla? ( !mysql !postgres !ssl )"
+
+DEPEND="dev-lang/tcl
+ !vanilla? (
+ mysql? ( virtual/mysql )
+ postgres? ( dev-db/postgresql-server )
+ ssl? ( dev-libs/openssl )
+ )"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ if use vanilla; then
+ rm -f "${WORKDIR}"/patch/[1-6]*.patch || die
+ fi
+
+ EPATCH_SUFFIX="patch" epatch
+
+ # fix bug #335230
+ sed -i \
+ -e '/\$(LD)/s/-o/$(CFLAGS) $(LDFLAGS) &/' \
+ src/mod/*.mod/Makefile* src/Makefile.in || die
+}
+
+src_configure() {
+ use mysql || ( echo mysql ; echo mystats ) >>disabled_modules
+ use postgres || echo pgstats >>disabled_modules
+ use static && ( echo rijndael ; echo twofish ) >>disabled_modules
+
+ econf $(use_with ssl)
+
+ emake config
+}
+
+src_compile() {
+ local target=""
+
+ if use static && use debug; then
+ target="sdebug"
+ elif use static; then
+ target="static"
+ elif use debug; then
+ target="debug"
+ fi
+
+ emake ${target}
+}
+
+src_install() {
+ local a b
+ emake DEST="${D}"/opt/eggdrop install
+
+ for a in doc/*; do
+ [ -f ${a} ] && dodoc ${a}
+ done
+
+ for a in src/mod/*.mod; do
+ for b in README UPDATES INSTALL TODO CONTENTS; do
+ [[ -f ${a}/${b} ]] && newdoc ${a}/${b} ${b}.${a##*/}
+ done
+ done
+
+ dodoc text/motd.*
+
+ use vanilla || dodoc \
+ src/mod/botnetop.mod/botnetop.conf \
+ src/mod/gseen.mod/gseen.conf \
+ src/mod/mc_greet.mod/mc_greet.conf \
+ src/mod/stats.mod/stats.conf \
+ src/mod/away.mod/away.doc \
+ src/mod/rcon.mod/matchbot.tcl \
+ src/mod/mystats.mod/tools/mystats.{conf,sql} \
+ src/mod/pgstats.mod/tools/{pgstats.conf,setup.sql}
+
+ dohtml doc/html/*.html
+
+ dobin "${FILESDIR}"/eggdrop-installer
+ doman doc/man1/eggdrop.1
+}
+
+pkg_postinst() {
+ elog "Please run /usr/bin/eggdrop-installer to install your eggdrop bot."
+}