summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2013-02-06 16:42:07 +0000
committerMike Gilbert <floppym@gentoo.org>2013-02-06 16:42:07 +0000
commitcb6283bff312a6c89e61b29c5438e0b7db9e33cf (patch)
tree52cb46cc77b8b196af42ca55e3b05a4956b975cf /net-im
parentRemove old. (diff)
downloadgentoo-2-cb6283bff312a6c89e61b29c5438e0b7db9e33cf.tar.gz
gentoo-2-cb6283bff312a6c89e61b29c5438e0b7db9e33cf.tar.bz2
gentoo-2-cb6283bff312a6c89e61b29c5438e0b7db9e33cf.zip
Don't install tests, bug 455250.
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'net-im')
-rw-r--r--net-im/turses/ChangeLog8
-rw-r--r--net-im/turses/files/turses-0.2.11-tests.patch28
-rw-r--r--net-im/turses/turses-0.2.11-r1.ebuild41
3 files changed, 76 insertions, 1 deletions
diff --git a/net-im/turses/ChangeLog b/net-im/turses/ChangeLog
index 79a1e5a856d0..45eefc126306 100644
--- a/net-im/turses/ChangeLog
+++ b/net-im/turses/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-im/turses
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/turses/ChangeLog,v 1.3 2013/01/24 08:41:59 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/turses/ChangeLog,v 1.4 2013/02/06 16:42:07 floppym Exp $
+
+*turses-0.2.11-r1 (06 Feb 2013)
+
+ 06 Feb 2013; Mike Gilbert <floppym@gentoo.org>
+ +files/turses-0.2.11-tests.patch, +turses-0.2.11-r1.ebuild:
+ Don't install tests, bug 455250.
*turses-0.2.11 (24 Jan 2013)
diff --git a/net-im/turses/files/turses-0.2.11-tests.patch b/net-im/turses/files/turses-0.2.11-tests.patch
new file mode 100644
index 000000000000..1d72b944ad82
--- /dev/null
+++ b/net-im/turses/files/turses-0.2.11-tests.patch
@@ -0,0 +1,28 @@
+commit c26c750103e6965bb2334938d77f213ebc2bd862
+Author: Mike Gilbert <floppym@gentoo.org>
+Date: Sun Feb 3 13:52:58 2013 -0500
+
+ Exclude tests from installation
+
+ https://bugs.gentoo.org/show_bug.cgi?id=455250
+
+diff --git a/MANIFEST.in b/MANIFEST.in
+new file mode 100644
+index 0000000..b562f73
+--- /dev/null
++++ b/MANIFEST.in
+@@ -0,0 +1 @@
++recursive-include tests *.py
+diff --git a/setup.py b/setup.py
+index 52fe1a1..705a485 100644
+--- a/setup.py
++++ b/setup.py
+@@ -63,7 +63,7 @@ setup(name=NAME,
+ description="A Twitter client for the console.",
+ long_description=long_description,
+ keywords="twitter client, curses, console, twitter",
+- packages=find_packages(),
++ packages=find_packages(exclude=["tests"]),
+ entry_points={
+ 'console_scripts':
+ ['turses = turses.cli:main']
diff --git a/net-im/turses/turses-0.2.11-r1.ebuild b/net-im/turses/turses-0.2.11-r1.ebuild
new file mode 100644
index 000000000000..f96cab4f4f4a
--- /dev/null
+++ b/net-im/turses/turses-0.2.11-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/turses/turses-0.2.11-r1.ebuild,v 1.1 2013/02/06 16:42:07 floppym Exp $
+
+EAPI=4
+
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils eutils vcs-snapshot
+
+DESCRIPTION="Command line twitter client"
+HOMEPAGE="https://github.com/alejandrogomez/turses"
+SRC_URI="https://github.com/alejandrogomez/${PN}/tarball/v${PV} -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="
+ dev-python/oauth2
+ dev-python/setuptools
+ dev-python/tweepy
+ dev-python/urwid
+ test? (
+ dev-python/mock
+ dev-python/nose
+ dev-python/tox
+ )
+
+"
+RDEPEND=""
+
+DOCS="AUTHORS HISTORY.rst README.rst"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-tests.patch"
+ distutils_src_prepare
+}