summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-09-04 06:20:23 +0000
committerJustin Lecher <jlec@gentoo.org>2010-09-04 06:20:23 +0000
commit3c5ec113873c6d766411723ec373a96cbe1cee1f (patch)
tree38dcac8788ba9c652c8bc2752325b4c7cd94bf3b /net-im
parentx86 stable wrt bug #335207 (diff)
downloadgentoo-2-3c5ec113873c6d766411723ec373a96cbe1cee1f.tar.gz
gentoo-2-3c5ec113873c6d766411723ec373a96cbe1cee1f.tar.bz2
gentoo-2-3c5ec113873c6d766411723ec373a96cbe1cee1f.zip
Version Bump
(Portage version: 2.2_rc74/cvs/Linux x86_64)
Diffstat (limited to 'net-im')
-rw-r--r--net-im/gajim/ChangeLog8
-rw-r--r--net-im/gajim/files/0.14-python-version.patch10
-rw-r--r--net-im/gajim/gajim-0.14.ebuild109
3 files changed, 126 insertions, 1 deletions
diff --git a/net-im/gajim/ChangeLog b/net-im/gajim/ChangeLog
index 6e70f2eff1ab..8b170a0de869 100644
--- a/net-im/gajim/ChangeLog
+++ b/net-im/gajim/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-im/gajim
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/gajim/ChangeLog,v 1.99 2010/08/07 17:25:57 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/gajim/ChangeLog,v 1.100 2010/09/04 06:20:23 jlec Exp $
+
+*gajim-0.14 (04 Sep 2010)
+
+ 04 Sep 2010; Justin Lecher <jlec@gentoo.org>
+ +files/0.14-python-version.patch, +gajim-0.14.ebuild:
+ Version Bump
07 Aug 2010; Raúl Porcel <armin76@gentoo.org> gajim-0.13.3.ebuild,
gajim-0.13.4.ebuild, gajim-0.13.4-r1.ebuild:
diff --git a/net-im/gajim/files/0.14-python-version.patch b/net-im/gajim/files/0.14-python-version.patch
new file mode 100644
index 000000000000..30ee445d405c
--- /dev/null
+++ b/net-im/gajim/files/0.14-python-version.patch
@@ -0,0 +1,10 @@
+diff --git a/scripts/gajim.in b/scripts/gajim.in
+index e163a9b..73dc9e0 100644
+--- a/scripts/gajim.in
++++ b/scripts/gajim.in
+@@ -30,4 +30,4 @@ fi
+ [ "$APP" = "gajim-history-manager" ] && APP="history_manager"
+
+ cd "@GAJIM_SRCDIR@"
+-exec "@PYTHON@" -OO $APP.py "$@"
++exec "@PYTHON@@PYTHON_VERSION@" -OO $APP.py "$@"
diff --git a/net-im/gajim/gajim-0.14.ebuild b/net-im/gajim/gajim-0.14.ebuild
new file mode 100644
index 000000000000..474133f6d346
--- /dev/null
+++ b/net-im/gajim/gajim-0.14.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/gajim/gajim-0.14.ebuild,v 1.1 2010/09/04 06:20:23 jlec Exp $
+
+EAPI="2"
+
+PYTHON_DEPEND="2"
+PYTHON_USE_WITH="sqlite xml"
+inherit autotools eutils python versionator
+
+DESCRIPTION="Jabber client written in PyGTK"
+HOMEPAGE="http://www.gajim.org/"
+SRC_URI="http://www.gajim.org/downloads/$(get_version_component_range 1-2)/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="avahi crypt dbus gnome idle libnotify nls spell srv trayicon X xhtml"
+
+COMMON_DEPEND="
+ x11-libs/gtk+:2
+ >=dev-python/pygtk-2.16.0"
+
+DEPEND="${COMMON_DEPEND}
+ >=sys-devel/gettext-0.17-r1
+ >=dev-util/intltool-0.40.1
+ dev-util/pkgconfig"
+
+RDEPEND="${COMMON_DEPEND}
+ dev-python/pyopenssl
+ dev-python/sexy-python
+ crypt? (
+ app-crypt/gnupg
+ dev-python/pycrypto
+ )
+ dbus? (
+ dev-python/dbus-python
+ dev-libs/dbus-glib
+ libnotify? ( dev-python/notify-python )
+ avahi? ( net-dns/avahi[dbus,gtk,python] )
+ )
+ gnome? (
+ dev-python/libgnome-python
+ dev-python/gnome-keyring-python
+ trayicon? ( dev-python/egg-python )
+ )
+ idle? ( x11-libs/libXScrnSaver )
+ srv? (
+ || (
+ dev-python/libasyncns-python
+ net-dns/bind-tools )
+ )
+ spell? ( app-text/gtkspell )
+ xhtml? ( dev-python/docutils )"
+
+pkg_setup() {
+ if ! use dbus; then
+ if use libnotify; then
+ eerror "The dbus USE flag is required for libnotify support"
+ die "USE=\"dbus\" needed for libnotify support"
+ fi
+ if use avahi; then
+ eerror "The dbus USE flag is required for avahi support"
+ die "USE=\"dbus\" needed for avahi support"
+ fi
+ fi
+ python_set_active_version 2
+}
+
+src_prepare() {
+ # install pyfiles in /usr/lib/python2.x/site-packages/gajim
+ # upstream: http://trac.gajim.org/ticket/5460
+ # Should be in 0.14
+# epatch "${FILESDIR}/${PN}-0.13-autotools-enable-site-packages_option.patch"
+ epatch "${FILESDIR}"/${PV}-python-version.patch
+ eautoreconf
+ echo '#!/bin/sh' > config/py-compile
+}
+
+src_configure() {
+ local myconf
+
+ if ! use gnome; then
+ myconf+=" $(use_enable trayicon)"
+ fi
+
+ econf \
+ $(use_enable nls) \
+ $(use_with X x) \
+ --docdir="/usr/share/doc/${PF}" \
+ --libdir="$(python_get_sitedir)" \
+ --enable-site-packages \
+ ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ rm "${D}/usr/share/doc/${PF}/"{README.html,COPYING} || die
+ dohtml README.html || die
+}
+
+pkg_postinst() {
+ python_mod_optimize $(python_get_sitedir)/${PN}
+}
+
+pkg_postrm() {
+ python_mod_cleanup $(python_get_sitedir)/${PN}
+}