summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2009-05-10 11:35:02 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2009-05-10 11:35:02 +0000
commit202c24e9ba447f0c9203570d67465d62f321c1ca (patch)
tree7753b3759d5c85db753f66c422ecdcebcfc6478b /net-im/twittare
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-202c24e9ba447f0c9203570d67465d62f321c1ca.tar.gz
gentoo-2-202c24e9ba447f0c9203570d67465d62f321c1ca.tar.bz2
gentoo-2-202c24e9ba447f0c9203570d67465d62f321c1ca.zip
Moved from sunrise overlay. Fixes bug 265833
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'net-im/twittare')
-rw-r--r--net-im/twittare/ChangeLog11
-rw-r--r--net-im/twittare/metadata.xml12
-rw-r--r--net-im/twittare/twittare-0.7.42.ebuild50
3 files changed, 73 insertions, 0 deletions
diff --git a/net-im/twittare/ChangeLog b/net-im/twittare/ChangeLog
new file mode 100644
index 000000000000..a90ad5eb0933
--- /dev/null
+++ b/net-im/twittare/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for net-im/twittare
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/twittare/ChangeLog,v 1.1 2009/05/10 11:35:02 hwoarang Exp $
+
+*twittare-0.7.42 (10 May 2009)
+
+ 10 May 2009; Markos Chandras <hwoarang@gentoo.org>
+ +twittare-0.7.42.ebuild, +metadata.xml:
+ Moved from sunrise overlay. Fixed LDFLAGS on custom makefile. Port it to EAPI 2. Fixes bug 265833 . Thanks
+ to Dominik George <gentoo@naturalnik.de> for the initial ebuild.
+
diff --git a/net-im/twittare/metadata.xml b/net-im/twittare/metadata.xml
new file mode 100644
index 000000000000..d5f9562e2df2
--- /dev/null
+++ b/net-im/twittare/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>qt</herd>
+<maintainer>
+<email>hwoarang@gentoo.org</email>
+<name>Markos Chandras</name>
+</maintainer>
+<longdescription lang="en">
+</longdescription>
+</pkgmetadata>
+
diff --git a/net-im/twittare/twittare-0.7.42.ebuild b/net-im/twittare/twittare-0.7.42.ebuild
new file mode 100644
index 000000000000..bde130a56555
--- /dev/null
+++ b/net-im/twittare/twittare-0.7.42.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/twittare/twittare-0.7.42.ebuild,v 1.1 2009/05/10 11:35:02 hwoarang Exp $
+
+EAPI="2"
+
+inherit qt4
+
+DESCRIPTION="Twitter client for Linux using Qt4"
+HOMEPAGE="http://www.twittare.com"
+SRC_URI="http://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc"
+
+DEPEND="x11-libs/qt-core:4
+ x11-libs/qt-gui:4
+ x11-libs/libnotify"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ # fix LDFLAGS issue
+ sed -i "s/-fpic/${LDFLAGS}\ -fpic/" "${S}"/libtwnotification/makefile || die "sed failed"
+ sed -i "s/-shared/${LDFLAGS}\ -shared/" "${S}"/libtwnotification/makefile || die "sed failed"
+}
+
+src_configure() {
+ eqmake4
+}
+
+src_compile() {
+ emake -C libtwnotification || die "emake libtwnotification failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ dobin twittare || die "dobin failed"
+ dolib.so libtwnotification/libtwnotification.so || die "dolib.so failed"
+ insinto /usr/share/applications
+ doins twittare.desktop || die "doins twittare.desktop failed"
+ insinto /usr/share/pixmaps
+ doins pixmaps/twittare-blue.png pixmaps/twittare-pink.png || die "doins pixmaps failed"
+ insinto /usr/share/${PN}
+ doins -r lang/ || die "doins lang failed"
+ if use doc; then
+ dodoc NEWS README ChangeLog || die "dodoc failed"
+ fi
+}