summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2009-12-17 14:56:01 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2009-12-17 14:56:01 +0000
commitfd4a63ae3b5bc815871b81aaa00ffd354b3a2754 (patch)
tree97b1a244c0cd181506c15bba9529ce7666f6dc99 /net-im/qutim
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-fd4a63ae3b5bc815871b81aaa00ffd354b3a2754.tar.gz
gentoo-2-fd4a63ae3b5bc815871b81aaa00ffd354b3a2754.tar.bz2
gentoo-2-fd4a63ae3b5bc815871b81aaa00ffd354b3a2754.zip
More fixes on insecure RPATH issues ( bug #297250 )
(Portage version: 2.2_rc59/cvs/Linux x86_64)
Diffstat (limited to 'net-im/qutim')
-rw-r--r--net-im/qutim/ChangeLog8
-rw-r--r--net-im/qutim/files/fix_insecure_rpath.patch14
-rw-r--r--net-im/qutim/qutim-0.2.0-r3.ebuild (renamed from net-im/qutim/qutim-0.2.0-r2.ebuild)2
3 files changed, 22 insertions, 2 deletions
diff --git a/net-im/qutim/ChangeLog b/net-im/qutim/ChangeLog
index c8b5a02fe228..387fb730bb05 100644
--- a/net-im/qutim/ChangeLog
+++ b/net-im/qutim/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-im/qutim
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/qutim/ChangeLog,v 1.4 2009/12/15 20:46:11 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/qutim/ChangeLog,v 1.5 2009/12/17 14:56:01 hwoarang Exp $
+
+*qutim-0.2.0-r3 (17 Dec 2009)
+
+ 17 Dec 2009; <hwoarang@gentoo.org> -qutim-0.2.0-r2.ebuild,
+ +qutim-0.2.0-r3.ebuild, files/fix_insecure_rpath.patch:
+ More fixes on insecure RPATH issues ( bug #297250 )
*qutim-0.2.0-r2 (15 Dec 2009)
diff --git a/net-im/qutim/files/fix_insecure_rpath.patch b/net-im/qutim/files/fix_insecure_rpath.patch
index 36f062980a2d..14c8273ecbbe 100644
--- a/net-im/qutim/files/fix_insecure_rpath.patch
+++ b/net-im/qutim/files/fix_insecure_rpath.patch
@@ -12,3 +12,17 @@ Index: qutim-0.2.0/CMakeLists.txt
LIST (APPEND CMAKE_MODULE_PATH "cmake")
LIST (APPEND CMAKE_MODULE_PATH "${CMAKE_CURRENT_SOURCE_DIR}/cmake")
SET (QT_USE_QTNETWORK true)
+Index: qutim-0.2.0/plugins/jabber/CMakeLists.txt
+===================================================================
+--- qutim-0.2.0.orig/plugins/jabber/CMakeLists.txt
++++ qutim-0.2.0/plugins/jabber/CMakeLists.txt
+@@ -11,6 +11,9 @@ file( GLOB_RECURSE QUTIM_UI src/*.ui )
+
+ SET (JABBER_LIBS "")
+ SET (JABBER_INCLUDE_DIR "")
++SET (CMAKE_INSTALL_RPATH_USE_LINK_PATH TRUE)
++SET (CMAKE_SKIP_BUILD_RPATH TRUE)
++SET (CMAKE_BUILD_WITH_INSTALL_RPATH TRUE)
+
+ if( GLOOX_SHARED OR NOT GLOOX_PATH )
+ SET( GLOOX_REQUIRED )
diff --git a/net-im/qutim/qutim-0.2.0-r2.ebuild b/net-im/qutim/qutim-0.2.0-r3.ebuild
index 629bb06ea0fb..78a9369eb669 100644
--- a/net-im/qutim/qutim-0.2.0-r2.ebuild
+++ b/net-im/qutim/qutim-0.2.0-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/qutim/qutim-0.2.0-r2.ebuild,v 1.1 2009/12/15 20:46:11 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/qutim/qutim-0.2.0-r3.ebuild,v 1.1 2009/12/17 14:56:01 hwoarang Exp $
EAPI="2"