summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavide Pesavento <pesa@gentoo.org>2012-04-09 22:26:02 +0000
committerDavide Pesavento <pesa@gentoo.org>2012-04-09 22:26:02 +0000
commit20d4d9c7efaf3ea6eccb8172fcd035efa07412b4 (patch)
tree330561b8665bbf3c22d7141f32b9b4a801be7818 /net-im/qutim
parentVersion bump (diff)
downloadgentoo-2-20d4d9c7efaf3ea6eccb8172fcd035efa07412b4.tar.gz
gentoo-2-20d4d9c7efaf3ea6eccb8172fcd035efa07412b4.tar.bz2
gentoo-2-20d4d9c7efaf3ea6eccb8172fcd035efa07412b4.zip
Fix building with system jreen (part of bug 411111).
(Portage version: 2.2.0_alpha100/cvs/Linux x86_64)
Diffstat (limited to 'net-im/qutim')
-rw-r--r--net-im/qutim/ChangeLog6
-rw-r--r--net-im/qutim/files/qutim-0.3.0-fix-linking-with-system-jreen.patch10
-rw-r--r--net-im/qutim/qutim-0.3.0.ebuild6
3 files changed, 20 insertions, 2 deletions
diff --git a/net-im/qutim/ChangeLog b/net-im/qutim/ChangeLog
index 309dceab7aad..be96d0cee615 100644
--- a/net-im/qutim/ChangeLog
+++ b/net-im/qutim/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-im/qutim
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/qutim/ChangeLog,v 1.14 2012/04/06 19:53:57 pesa Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/qutim/ChangeLog,v 1.15 2012/04/09 22:26:02 pesa Exp $
+
+ 09 Apr 2012; Davide Pesavento <pesa@gentoo.org>
+ +files/qutim-0.3.0-fix-linking-with-system-jreen.patch, qutim-0.3.0.ebuild:
+ Fix building with system jreen (part of bug 411111).
*qutim-0.3.0 (06 Apr 2012)
diff --git a/net-im/qutim/files/qutim-0.3.0-fix-linking-with-system-jreen.patch b/net-im/qutim/files/qutim-0.3.0-fix-linking-with-system-jreen.patch
new file mode 100644
index 000000000000..89b082ecdfa0
--- /dev/null
+++ b/net-im/qutim/files/qutim-0.3.0-fix-linking-with-system-jreen.patch
@@ -0,0 +1,10 @@
+--- protocols/jabber/CMakeLists.txt
++++ protocols/jabber/CMakeLists.txt
+@@ -6,6 +6,7 @@
+ if( SYSTEM_JREEN )
+ find_package( PkgConfig )
+ pkg_check_modules( JREEN REQUIRED libjreen )
++ link_directories( ${JREEN_LIBRARY_DIRS} )
+ else()
+ ADD_SUBDIRECTORY(jreen)
+ LIST(APPEND INCLUDE_DIRS "${JREEN_INCLUDE_DIRS}") \ No newline at end of file
diff --git a/net-im/qutim/qutim-0.3.0.ebuild b/net-im/qutim/qutim-0.3.0.ebuild
index b325d66f1035..95f21d5ea91e 100644
--- a/net-im/qutim/qutim-0.3.0.ebuild
+++ b/net-im/qutim/qutim-0.3.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/qutim/qutim-0.3.0.ebuild,v 1.1 2012/04/06 19:53:57 pesa Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/qutim/qutim-0.3.0.ebuild,v 1.2 2012/04/09 22:26:02 pesa Exp $
EAPI=4
@@ -65,6 +65,10 @@ DEPEND="${RDEPEND}
doc? ( app-doc/doxygen )
"
+PATCHES=(
+ "${FILESDIR}/${P}-fix-linking-with-system-jreen.patch"
+)
+
src_prepare() {
base_src_prepare