summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHannes Mehnert <hannes@gentoo.org>2002-11-04 13:34:57 +0000
committerHannes Mehnert <hannes@gentoo.org>2002-11-04 13:34:57 +0000
commita5d6ea439c308951ee5c159a1234f3ced9ad5dbd (patch)
tree6253dd7e014df46cae533dceb117c4c784d41a6f /net-im/kopete
parentInitial import. (diff)
downloadgentoo-2-a5d6ea439c308951ee5c159a1234f3ced9ad5dbd.tar.gz
gentoo-2-a5d6ea439c308951ee5c159a1234f3ced9ad5dbd.tar.bz2
gentoo-2-a5d6ea439c308951ee5c159a1234f3ced9ad5dbd.zip
fix for >=qt-3.1
Diffstat (limited to 'net-im/kopete')
-rw-r--r--net-im/kopete/ChangeLog6
-rw-r--r--net-im/kopete/files/kopete-0.5-qt-3.1.patch121
-rw-r--r--net-im/kopete/kopete-0.5.ebuild9
3 files changed, 131 insertions, 5 deletions
diff --git a/net-im/kopete/ChangeLog b/net-im/kopete/ChangeLog
index 676a1433767a..bd84fc9358ea 100644
--- a/net-im/kopete/ChangeLog
+++ b/net-im/kopete/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-im/kopete
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-im/kopete/ChangeLog,v 1.5 2002/10/30 18:32:35 hannes Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/kopete/ChangeLog,v 1.6 2002/11/04 13:34:57 hannes Exp $
+
+ 04 Nov 2002; Hannes Mehnert <hannes@gentoo.org> kopete-0.5.ebuild:
+ fix for >=qt-3.1, thanks to heliosc@mindspring.com (Rayiner Hashem)
+ for submission (bug #10173)
30 Oct 2002; Hannes Mehnert <hannes@gentoo.org> kopete-0.5.ebuild,
kopete-0.4.1.ebuild: added IUSE, fixed header, marked as stable
diff --git a/net-im/kopete/files/kopete-0.5-qt-3.1.patch b/net-im/kopete/files/kopete-0.5-qt-3.1.patch
new file mode 100644
index 000000000000..c4257e92c090
--- /dev/null
+++ b/net-im/kopete/files/kopete-0.5-qt-3.1.patch
@@ -0,0 +1,121 @@
+--- kopete/protocols/icq_new/icqprotocol.cpp.orig 2002-11-04 12:49:11.000000000 +0100
++++ kopete/protocols/icq_new/icqprotocol.cpp 2002-11-04 12:52:52.000000000 +0100
+@@ -86,17 +86,17 @@
+
+ engine->owner->Uin = mPrefs->uin().toULong();
+ engine->storePassword( mPrefs->passwd() );
+- engine->ServerHost = mPrefs->serverAdress();
++ engine->ServerHost = mPrefs->serverAdress().latin1();
+ engine->ServerPort = mPrefs->serverPort();
+
+ if ( mPrefs->useProxy() )
+ {
+ engine->ProxyType = mPrefs->proxyType();
+- engine->ProxyHost = mPrefs->proxyServerAdress();
++ engine->ProxyHost = mPrefs->proxyServerAdress().latin1();
+ engine->ProxyPort = mPrefs->proxyPort();
+ engine->ProxyAuth = mPrefs->proxyAuth();
+- engine->ProxyUser = mPrefs->proxyAuthUser();
+- engine->ProxyPasswd = mPrefs->proxyAuthPassword();
++ engine->ProxyUser = mPrefs->proxyAuthUser().latin1();
++ engine->ProxyPasswd = mPrefs->proxyAuthPassword().latin1();
+ }
+ else
+ {
+@@ -118,7 +118,7 @@
+
+ ICQUser *mySelf = static_cast<ICQUser*>(engine->owner); //new ICQUser();
+ mySelf->Uin = mPrefs->uin().toULong();
+- mySelf->Nick = mPrefs->nickName();
++ mySelf->Nick = mPrefs->nickName().latin1();
+ engine->setInfo(mySelf);
+ KopeteMetaContact *meta = new KopeteMetaContact();
+ QString protocolId = id();
+@@ -266,8 +266,8 @@
+ }
+ */
+
+- user->Alias = alias;
+- user->Nick = alias; // initial nickname setting
++ user->Alias = alias.latin1();
++ user->Nick = alias.latin1(); // initial nickname setting
+
+ ICQContact *contact = new ICQContact(protocolId, metaContact, user, this);
+ KopeteContact *c = contact;
+@@ -395,7 +395,7 @@
+ }
+
+ if ( !alias.isEmpty() && QString(user->Alias.c_str()).isEmpty() )
+- user->Alias = QString(alias);
++ user->Alias = QString(alias).latin1();
+
+ QString protocolId = this->id();
+ ICQContact *contact = new ICQContact( protocolId, meta, user, this);
+@@ -424,7 +424,7 @@
+ kdDebug() << "[ICQProtocol] findGroup(), creating group " << groupName << "." << endl;
+ ICQGroup *tmpG = new ICQGroup();
+ ICQGroup *group = engine->getGroup(engine->contacts.getGroupId(tmpG), true);
+- group->Name = groupName;
++ group->Name = groupName.latin1();
+ delete tmpG;
+ return group;
+ }
+@@ -1006,7 +1006,7 @@
+ }
+ if (ICQChangeStatus::getStatusMessage(this, ICQ_STATUS_NA) != "QDialog::Rejected")
+ {
+- engine->owner->AutoResponseNA = mPrefs->naMessage();
++ engine->owner->AutoResponseNA = mPrefs->naMessage().latin1();
+ if ( engine->m_state != ICQClient::Logged ) connectAttempt();
+ engine->setStatus(ICQ_STATUS_NA);
+ }
+@@ -1043,7 +1043,7 @@
+
+ if (ICQChangeStatus::getStatusMessage(this, ICQ_STATUS_OCCUPIED) != "QDialog::Rejected")
+ {
+- engine->owner->AutoResponseOccupied = mPrefs->occMessage();
++ engine->owner->AutoResponseOccupied = mPrefs->occMessage().latin1();
+ if ( engine->m_state != ICQClient::Logged ) connectAttempt();
+ engine->setStatus(ICQ_STATUS_OCCUPIED);
+ }
+@@ -1069,7 +1069,7 @@
+ }
+ if (ICQChangeStatus::getStatusMessage(this, ICQ_STATUS_DND) != "QDialog::Rejected")
+ {
+- engine->owner->AutoResponseDND = mPrefs->dndMessage();
++ engine->owner->AutoResponseDND = mPrefs->dndMessage().latin1();
+ if ( engine->m_state != ICQClient::Logged ) connectAttempt();
+ engine->setStatus(ICQ_STATUS_DND);
+ // statusBarIcon->setPixmap(dndIcon);
+@@ -1078,7 +1078,7 @@
+
+ void ICQProtocol::setAway(void)
+ {
+- engine->owner->AutoResponseAway = KopeteAway::message();
++ engine->owner->AutoResponseAway = KopeteAway::message().latin1();
+ if ( engine->m_state != ICQClient::Logged ) connectAttempt();
+ engine->setStatus ( ICQ_STATUS_AWAY );
+ }
+@@ -1106,18 +1106,18 @@
+
+ ICQUser *mySelf = new ICQUser();
+ mySelf->Uin = mPrefs->uin().toULong();
+- mySelf->Nick = mPrefs->nickName();
++ mySelf->Nick = mPrefs->nickName().latin1();
+ engine->setInfo(mySelf);
+ engine->owner->Uin = mPrefs->uin().toULong();
+
+ if ( mPrefs->useProxy() )
+ {
+ engine->ProxyType = mPrefs->proxyType();
+- engine->ProxyHost = mPrefs->proxyServerAdress();
++ engine->ProxyHost = mPrefs->proxyServerAdress().latin1();
+ engine->ProxyPort = mPrefs->proxyPort();
+ engine->ProxyAuth = mPrefs->proxyAuth();
+- engine->ProxyUser = mPrefs->proxyAuthUser();
+- engine->ProxyPasswd = mPrefs->proxyAuthPassword();
++ engine->ProxyUser = mPrefs->proxyAuthUser().latin1();
++ engine->ProxyPasswd = mPrefs->proxyAuthPassword().latin1();
+ }
+ else
+ {
diff --git a/net-im/kopete/kopete-0.5.ebuild b/net-im/kopete/kopete-0.5.ebuild
index 4de87f8b7cbb..4daa64a2713a 100644
--- a/net-im/kopete/kopete-0.5.ebuild
+++ b/net-im/kopete/kopete-0.5.ebuild
@@ -1,15 +1,16 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/kopete/kopete-0.5.ebuild,v 1.2 2002/10/30 18:32:35 hannes Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/kopete/kopete-0.5.ebuild,v 1.3 2002/11/04 13:34:57 hannes Exp $
-inherit kde-base || die
+PATCHES="${FILESDIR}/${P}-qt-3.1.patch"
-IUSE=""
+inherit kde-base
need-kde 3
+
+IUSE=""
S="${WORKDIR}/${P}-1"
LICENSE="GPL-2"
KEYWORDS="x86"
DESCRIPTION="The KDE Instant Messenger"
SRC_URI="http://www.cron.cl/kopete/${P}-1.tar.gz"
HOMEPAGE="http://kopete.kde.org/"
-