summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2011-09-23 21:39:42 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2011-09-23 21:39:42 +0000
commit2ede93edbf87758cb786af9afae56c597d556898 (patch)
tree23b925e87d711c0b8f3fa43efff0eb636ce2b14f /net-im/choqok
parentRemove <herd>no-herd</herd>. (diff)
downloadgentoo-2-2ede93edbf87758cb786af9afae56c597d556898.tar.gz
gentoo-2-2ede93edbf87758cb786af9afae56c597d556898.tar.bz2
gentoo-2-2ede93edbf87758cb786af9afae56c597d556898.zip
Fix twitter authentication, bug 383307
(Portage version: 2.1.10.19/cvs/Linux x86_64)
Diffstat (limited to 'net-im/choqok')
-rw-r--r--net-im/choqok/ChangeLog8
-rw-r--r--net-im/choqok/choqok-1.1-r1.ebuild40
-rw-r--r--net-im/choqok/files/choqok-1.1-twitter.patch30
3 files changed, 77 insertions, 1 deletions
diff --git a/net-im/choqok/ChangeLog b/net-im/choqok/ChangeLog
index 9aaa641dd5e5..25738860e7f6 100644
--- a/net-im/choqok/ChangeLog
+++ b/net-im/choqok/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-im/choqok
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/choqok/ChangeLog,v 1.18 2011/04/12 12:53:32 tampakrap Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/choqok/ChangeLog,v 1.19 2011/09/23 21:39:42 dilfridge Exp $
+
+*choqok-1.1-r1 (23 Sep 2011)
+
+ 23 Sep 2011; Andreas K. Huettel <dilfridge@gentoo.org> +choqok-1.1-r1.ebuild,
+ +files/choqok-1.1-twitter.patch:
+ Fix twitter authentication, bug 383307
*choqok-1.1 (12 Apr 2011)
diff --git a/net-im/choqok/choqok-1.1-r1.ebuild b/net-im/choqok/choqok-1.1-r1.ebuild
new file mode 100644
index 000000000000..609e4aa82323
--- /dev/null
+++ b/net-im/choqok/choqok-1.1-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/choqok/choqok-1.1-r1.ebuild,v 1.1 2011/09/23 21:39:42 dilfridge Exp $
+
+EAPI=4
+
+if [[ ${PV} != *9999* ]]; then
+ KDE_LINGUAS="bg da de en_GB es et fr ja nb nds nl pa pl pt pt_BR ru sv tr uk zh_CN zh_TW"
+ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+ KDE_HANDBOOK="optional"
+ KEYWORDS="~amd64 ~x86"
+else
+ KDE_SCM="git"
+ KEYWORDS=""
+fi
+
+inherit kde4-base
+
+DESCRIPTION="Free/Open Source micro-blogging client for KDE"
+HOMEPAGE="http://choqok.gnufolks.org/"
+
+LICENSE="GPL-3"
+SLOT="4"
+IUSE="debug indicate"
+
+DEPEND="dev-libs/qjson
+ >=dev-libs/qoauth-1.0.1
+ indicate? ( dev-libs/libindicate-qt )
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${P}-twitter.patch" )
+
+src_prepare(){
+ mycmakeargs=(
+ $(cmake-utils_use !indicate QTINDICATE_DISABLE)
+ )
+
+ kde4-base_src_prepare
+}
diff --git a/net-im/choqok/files/choqok-1.1-twitter.patch b/net-im/choqok/files/choqok-1.1-twitter.patch
new file mode 100644
index 000000000000..823bfefc3a85
--- /dev/null
+++ b/net-im/choqok/files/choqok-1.1-twitter.patch
@@ -0,0 +1,30 @@
+commit 9053b699c33d998d3933a6c11e4ff624846620e5
+Author: Mehrdad Momeny <mehrdad.momeny@gmail.com>
+Date: Sun Jul 24 11:30:49 2011 +0800
+
+ BUG:275185 Get user friends list bug fixed
+
+diff --git a/helperlibs/twitterapihelper/twitterapimicroblog.cpp b/helperlibs/twitterapihelper/twitterapimicroblog.cpp
+index 1efbb1f..1a87d61 100644
+--- a/helperlibs/twitterapihelper/twitterapimicroblog.cpp
++++ b/helperlibs/twitterapihelper/twitterapimicroblog.cpp
+@@ -681,14 +681,18 @@ void TwitterApiMicroBlog::requestFriendsScreenName(TwitterApiAccount* theAccount
+ TwitterApiAccount* account = qobject_cast<TwitterApiAccount*>(theAccount);
+ KUrl url = account->apiUrl();
+ url.addPath( QString("/statuses/friends.xml") );
++ KUrl tmpUrl(url);
+ url.addQueryItem( "cursor", d->friendsCursor );
++ QOAuth::ParamMap params;
++ params.insert("cursor", d->friendsCursor.toLatin1());
+
+ KIO::StoredTransferJob *job = KIO::storedGet( url, KIO::Reload, KIO::HideProgressInfo ) ;
+ if ( !job ) {
+ kDebug() << "Cannot create an http GET request!";
+ return;
+ }
+- job->addMetaData("customHTTPHeader", "Authorization: " + authorizationHeader(account, url, QOAuth::GET));
++ job->addMetaData("customHTTPHeader", "Authorization: " + authorizationHeader(account, tmpUrl,
++ QOAuth::GET, params));
+ mJobsAccount[job] = theAccount;
+ connect( job, SIGNAL( result( KJob* ) ), this, SLOT( slotRequestFriendsScreenName(KJob*) ) );
+ job->start();