summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2011-11-24 21:17:29 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2011-11-24 21:17:29 +0000
commit01d503b850a410169989f7422c52377339afde8b (patch)
tree704c57c7e5bee5d5c3853c8aafe54ef1019a1da4 /net-im/choqok
parentVersion bump. Update to EAPI 4, remove psyco use flag, and add ffmpeg use flag. (diff)
downloadgentoo-2-01d503b850a410169989f7422c52377339afde8b.tar.gz
gentoo-2-01d503b850a410169989f7422c52377339afde8b.tar.bz2
gentoo-2-01d503b850a410169989f7422c52377339afde8b.zip
Version bump, thanks johu!
(Portage version: 2.1.10.37/cvs/Linux x86_64)
Diffstat (limited to 'net-im/choqok')
-rw-r--r--net-im/choqok/ChangeLog7
-rw-r--r--net-im/choqok/choqok-1.2.ebuild40
2 files changed, 46 insertions, 1 deletions
diff --git a/net-im/choqok/ChangeLog b/net-im/choqok/ChangeLog
index 793a944ea813..c404dea92724 100644
--- a/net-im/choqok/ChangeLog
+++ b/net-im/choqok/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-im/choqok
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/choqok/ChangeLog,v 1.21 2011/11/19 17:33:06 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/choqok/ChangeLog,v 1.22 2011/11/24 21:17:28 dilfridge Exp $
+
+*choqok-1.2 (24 Nov 2011)
+
+ 24 Nov 2011; Andreas K. Huettel <dilfridge@gentoo.org> +choqok-1.2.ebuild:
+ Version bump, thanks johu!
19 Nov 2011; Samuli Suominen <ssuominen@gentoo.org> choqok-1.1-r1.ebuild,
metadata.xml:
diff --git a/net-im/choqok/choqok-1.2.ebuild b/net-im/choqok/choqok-1.2.ebuild
new file mode 100644
index 000000000000..479821a2bf53
--- /dev/null
+++ b/net-im/choqok/choqok-1.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/choqok/choqok-1.2.ebuild,v 1.1 2011/11/24 21:17:29 dilfridge Exp $
+
+EAPI=4
+
+if [[ ${PV} != *9999* ]]; then
+ KDE_LINGUAS="bg bs ca ca@valencia cs da de el en_GB eo es et fa fi fr ga gl
+ hr hu is ja km lt ms nb nds nl pa pl pt pt_BR ro ru sk sq sv tr ug uk zh_CN
+ zh_TW"
+ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+ KDE_HANDBOOK="optional"
+ KEYWORDS="~amd64 ~x86"
+else
+ KDE_SCM="git"
+ KEYWORDS=""
+fi
+
+inherit kde4-base
+
+DESCRIPTION="Free/Open Source micro-blogging client for KDE"
+HOMEPAGE="http://choqok.gnufolks.org/"
+
+LICENSE="GPL-3"
+SLOT="4"
+IUSE="ayatana debug"
+
+DEPEND="dev-libs/qjson
+ >=dev-libs/qoauth-1.0.1
+ ayatana? ( dev-libs/libindicate-qt )
+"
+RDEPEND="${DEPEND}"
+
+src_prepare(){
+ mycmakeargs=(
+ $(cmake-utils_use !ayatana QTINDICATE_DISABLE)
+ )
+
+ kde4-base_src_prepare
+}