summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2009-02-07 17:42:39 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2009-02-07 17:42:39 +0000
commit77c9e12aab1b0922de25eed7cffb23070c628dd6 (patch)
treee2d5ec97d50485f10a44d6c814161250af0da08f /net-ftp
parentstable x86, bug 245861 (diff)
downloadgentoo-2-77c9e12aab1b0922de25eed7cffb23070c628dd6.tar.gz
gentoo-2-77c9e12aab1b0922de25eed7cffb23070c628dd6.tar.bz2
gentoo-2-77c9e12aab1b0922de25eed7cffb23070c628dd6.zip
Version bump, adds synchronized browsing, new iconset, and bugfixes
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'net-ftp')
-rw-r--r--net-ftp/filezilla/ChangeLog8
-rw-r--r--net-ftp/filezilla/filezilla-3.2.1.ebuild42
2 files changed, 49 insertions, 1 deletions
diff --git a/net-ftp/filezilla/ChangeLog b/net-ftp/filezilla/ChangeLog
index 446ec0d5f858..2b5dca6d1bb7 100644
--- a/net-ftp/filezilla/ChangeLog
+++ b/net-ftp/filezilla/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-ftp/filezilla
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/filezilla/ChangeLog,v 1.30 2009/01/07 20:35:32 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/filezilla/ChangeLog,v 1.31 2009/02/07 17:42:39 voyageur Exp $
+
+*filezilla-3.2.1 (07 Feb 2009)
+
+ 07 Feb 2009; Bernard Cafarelli <voyageur@gentoo.org>
+ +filezilla-3.2.1.ebuild:
+ Version bump, adds synchronized browsing, new iconset, and bugfixes
*filezilla-3.2.0 (07 Jan 2009)
diff --git a/net-ftp/filezilla/filezilla-3.2.1.ebuild b/net-ftp/filezilla/filezilla-3.2.1.ebuild
new file mode 100644
index 000000000000..9c649a72a523
--- /dev/null
+++ b/net-ftp/filezilla/filezilla-3.2.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/filezilla/filezilla-3.2.1.ebuild,v 1.1 2009/02/07 17:42:39 voyageur Exp $
+
+WX_GTK_VER="2.8"
+
+inherit eutils multilib wxwidgets
+
+MY_PV=${PV/_/-}
+MY_P="FileZilla_${MY_PV}"
+
+DESCRIPTION="FTP client with lots of useful features and an intuitive interface"
+HOMEPAGE="http://filezilla-project.org/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}_src.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE="dbus"
+
+RDEPEND="net-dns/libidn
+ >=x11-libs/wxGTK-2.8.9
+ >=app-admin/eselect-wxwidgets-0.7-r1"
+DEPEND="${RDEPEND}
+ >=sys-devel/libtool-1.4
+ >=sys-devel/gettext-0.11
+ >=net-libs/gnutls-2.0.4"
+
+S="${WORKDIR}"/${PN}-${MY_PV}
+
+src_compile() {
+ econf $(use_with dbus) || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ doicon src/interface/resources/48x48/${PN}.png || die "doicon failed"
+
+ dodoc AUTHORS ChangeLog NEWS
+}