summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonny Davies <woodchip@gentoo.org>2002-05-04 03:42:50 +0000
committerDonny Davies <woodchip@gentoo.org>2002-05-04 03:42:50 +0000
commit2410af48746e3143c1974a11fef17f96ea78de45 (patch)
treef2e0d54226a74404c9d436b91a9265078ac8ecb6 /net-ftp/vsftpd/vsftpd-1.0.1-r1.ebuild
parentadded LICENSE, SLOT, $Headers. (diff)
downloadgentoo-2-2410af48746e3143c1974a11fef17f96ea78de45.tar.gz
gentoo-2-2410af48746e3143c1974a11fef17f96ea78de45.tar.bz2
gentoo-2-2410af48746e3143c1974a11fef17f96ea78de45.zip
added LICENSE, SLOT, $Headers.
Diffstat (limited to 'net-ftp/vsftpd/vsftpd-1.0.1-r1.ebuild')
-rw-r--r--net-ftp/vsftpd/vsftpd-1.0.1-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/net-ftp/vsftpd/vsftpd-1.0.1-r1.ebuild b/net-ftp/vsftpd/vsftpd-1.0.1-r1.ebuild
new file mode 100644
index 000000000000..d5d2ab612048
--- /dev/null
+++ b/net-ftp/vsftpd/vsftpd-1.0.1-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/vsftpd/vsftpd-1.0.1-r1.ebuild,v 1.1 2002/05/04 03:42:50 woodchip Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Very Secure FTP Daemon written with speed, size and security in mind"
+SRC_URI="ftp://ferret.lmh.ox.ac.uk/pub/linux/${P}.tar.gz"
+
+DEPEND="virtual/glibc >=sys-libs/pam-0.75"
+RDEPEND="${DEPEND} sys-apps/xinetd"
+LICENSE="GPL-2"
+SLOT="0"
+
+src_unpack() {
+ unpack ${A} ; cd ${S}
+ patch -p1 < ${FILESDIR}/${P}-gentoo.diff || die "bad patchfile"
+}
+
+src_compile() {
+ make CFLAGS="${CFLAGS}" || die "compile problem"
+}
+
+src_install () {
+ dodir /home/ftp /usr/share/vsftpd/empty /var/log/vsftpd
+ doman vsftpd.conf.5 vsftpd.8
+ dosbin vsftpd
+
+ dodoc AUDIT BENCHMARKS BUGS Changelog FAQ INSTALL KERNEL-2.4.0-WARNING
+ dodoc LICENSE README README.security REWARD SIZE SPEED TODO TUNING
+ docinto security ; dodoc SECURITY/*
+ newdoc ${FILESDIR}/vsftpd.conf vsftpd.conf.sample
+ newdoc vsftpd.conf vsftpd.conf.dist.sample
+
+ insinto /etc ; doins ${FILESDIR}/ftpusers
+ insinto /etc/vsftpd ; newins ${FILESDIR}/vsftpd.conf vsftpd.conf.sample
+ insinto /etc/xinetd.d ; newins ${FILESDIR}/vsftpd.xinetd vsftpd
+ insinto /etc/pam.d ; newins ${FILESDIR}/vsftpd.pam vsftpd
+}