summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2005-11-11 14:13:10 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2005-11-11 14:13:10 +0000
commite8547e71e81c0f2c54b0dad8445a912acb74ecba (patch)
tree73eb72a5980f856272f0911172eaa1a8bdbe1441 /net-ftp/kftpgrabber
parentFix spelling issues, bug #112160. (diff)
downloadgentoo-2-e8547e71e81c0f2c54b0dad8445a912acb74ecba.tar.gz
gentoo-2-e8547e71e81c0f2c54b0dad8445a912acb74ecba.tar.bz2
gentoo-2-e8547e71e81c0f2c54b0dad8445a912acb74ecba.zip
Added patches to compile using Qt 3.3.5 (stricter uic) and GCC4 (stricter compiler).
(Portage version: 2.0.53_rc7)
Diffstat (limited to 'net-ftp/kftpgrabber')
-rw-r--r--net-ftp/kftpgrabber/ChangeLog8
-rw-r--r--net-ftp/kftpgrabber/files/kftpgrabber-0.6.0-gcc4.patch70
-rw-r--r--net-ftp/kftpgrabber/files/kftpgrabber-0.6.0-uic.patch26
-rw-r--r--net-ftp/kftpgrabber/kftpgrabber-0.6.0.ebuild11
4 files changed, 112 insertions, 3 deletions
diff --git a/net-ftp/kftpgrabber/ChangeLog b/net-ftp/kftpgrabber/ChangeLog
index d3827c95e13a..05b86b69d51b 100644
--- a/net-ftp/kftpgrabber/ChangeLog
+++ b/net-ftp/kftpgrabber/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-ftp/kftpgrabber
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/kftpgrabber/ChangeLog,v 1.7 2005/07/28 14:24:55 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/kftpgrabber/ChangeLog,v 1.8 2005/11/11 14:13:10 flameeyes Exp $
+
+ 11 Nov 2005; Diego Pettenò <flameeyes@gentoo.org>
+ +files/kftpgrabber-0.6.0-gcc4.patch, +files/kftpgrabber-0.6.0-uic.patch,
+ kftpgrabber-0.6.0.ebuild:
+ Added patches to compile using Qt 3.3.5 (stricter uic) and GCC4 (stricter
+ compiler).
28 Jul 2005; Caleb Tennis <caleb@gentoo.org> -kftpgrabber-0.5.0.ebuild:
Remove old build
diff --git a/net-ftp/kftpgrabber/files/kftpgrabber-0.6.0-gcc4.patch b/net-ftp/kftpgrabber/files/kftpgrabber-0.6.0-gcc4.patch
new file mode 100644
index 000000000000..0f51868bc0ea
--- /dev/null
+++ b/net-ftp/kftpgrabber/files/kftpgrabber-0.6.0-gcc4.patch
@@ -0,0 +1,70 @@
+Index: kftpgrabber-0.6.0/kftpgrabber/src/kftptransfer.h
+===================================================================
+--- kftpgrabber-0.6.0.orig/kftpgrabber/src/kftptransfer.h
++++ kftpgrabber-0.6.0/kftpgrabber/src/kftptransfer.h
+@@ -44,6 +44,7 @@
+ #include <kurl.h>
+
+ class KFTPSession;
++class KFTPQueueManager;
+
+ namespace KFTPQueue {
+
+@@ -61,8 +62,8 @@ This class is the base class for all tra
+ class Transfer : public QObject
+ {
+ friend class TransferDir;
+-friend class KFTPQueueManager;
+-friend class KFTPSession;
++friend class ::KFTPQueueManager;
++friend class ::KFTPSession;
+ Q_OBJECT
+ public:
+ enum Status {
+Index: kftpgrabber-0.6.0/kftpgrabber/src/kftptransferfile.h
+===================================================================
+--- kftpgrabber-0.6.0.orig/kftpgrabber/src/kftptransferfile.h
++++ kftpgrabber-0.6.0/kftpgrabber/src/kftptransferfile.h
+@@ -39,6 +39,7 @@
+ #include "kftptransfer.h"
+
+ class KFTPSessionConnection;
++class KFTPQueueManager;
+
+ namespace KFTPNetwork {
+ class Error;
+@@ -54,7 +55,7 @@ namespace KFTPQueue {
+ class TransferFile : public Transfer
+ {
+ Q_OBJECT
+-friend class KFTPQueueManager;
++friend class ::KFTPQueueManager;
+ public:
+ TransferFile(QObject *parent);
+ ~TransferFile();
+Index: kftpgrabber-0.6.0/kftpgrabber/src/widgets/filedirview/kftpfilepropsplugin.h
+===================================================================
+--- kftpgrabber-0.6.0.orig/kftpgrabber/src/widgets/filedirview/kftpfilepropsplugin.h
++++ kftpgrabber-0.6.0/kftpgrabber/src/widgets/filedirview/kftpfilepropsplugin.h
+@@ -41,6 +41,8 @@
+
+ #include "kftpclientthread.h"
+
++class KFTPSession;
++
+ /**
+ This is a plugin for displaying remote file properties using standard KDE file properties dialog.
+
+Index: kftpgrabber-0.6.0/kftpgrabber/src/widgets/kftpservermanagementlistview.h
+===================================================================
+--- kftpgrabber-0.6.0.orig/kftpgrabber/src/widgets/kftpservermanagementlistview.h
++++ kftpgrabber-0.6.0/kftpgrabber/src/widgets/kftpservermanagementlistview.h
+@@ -48,7 +48,7 @@ class KFTPSession;
+ class KListViewItem;
+ class KFTPClientThr;
+ class KActionCollection;
+-
++class KFTPServerManagementDialog;
+
+ /**
+ * @author Blacknator
diff --git a/net-ftp/kftpgrabber/files/kftpgrabber-0.6.0-uic.patch b/net-ftp/kftpgrabber/files/kftpgrabber-0.6.0-uic.patch
new file mode 100644
index 000000000000..83da5136f212
--- /dev/null
+++ b/net-ftp/kftpgrabber/files/kftpgrabber-0.6.0-uic.patch
@@ -0,0 +1,26 @@
+Index: kftpgrabber-0.6.0/kftpgrabber/src/ui/kftpqueueeditorlayout.ui
+===================================================================
+--- kftpgrabber-0.6.0.orig/kftpgrabber/src/ui/kftpqueueeditorlayout.ui
++++ kftpgrabber-0.6.0/kftpgrabber/src/ui/kftpqueueeditorlayout.ui
+@@ -322,9 +322,6 @@
+ </images>
+ <layoutdefaults spacing="6" margin="11"/>
+ <includehints>
+- <includehint>kftpserverlineedit.h</includehint>
+- <includehint>kpassdlg.h</includehint>
+- <includehint>kftpserverlineedit.h</includehint>
+ <includehint>kpassdlg.h</includehint>
+ </includehints>
+ </UI>
+Index: kftpgrabber-0.6.0/kftpgrabber/src/ui/kftpsearchlayout.ui
+===================================================================
+--- kftpgrabber-0.6.0.orig/kftpgrabber/src/ui/kftpsearchlayout.ui
++++ kftpgrabber-0.6.0/kftpgrabber/src/ui/kftpsearchlayout.ui
+@@ -240,7 +240,6 @@
+ </images>
+ <layoutdefaults spacing="6" margin="11"/>
+ <includehints>
+- <includehint>kftpserverlineedit.h</includehint>
+ <includehint>kpassdlg.h</includehint>
+ </includehints>
+ </UI>
diff --git a/net-ftp/kftpgrabber/kftpgrabber-0.6.0.ebuild b/net-ftp/kftpgrabber/kftpgrabber-0.6.0.ebuild
index 915900e8b572..431b8594efcf 100644
--- a/net-ftp/kftpgrabber/kftpgrabber-0.6.0.ebuild
+++ b/net-ftp/kftpgrabber/kftpgrabber-0.6.0.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/kftpgrabber/kftpgrabber-0.6.0.ebuild,v 1.3 2005/07/26 13:44:09 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/kftpgrabber/kftpgrabber-0.6.0.ebuild,v 1.4 2005/11/11 14:13:10 flameeyes Exp $
-inherit kde
+inherit kde eutils
DESCRIPTION="A graphical FTP client for KDE."
HOMEPAGE="http://kftpgrabber.sourceforge.net/"
@@ -18,3 +18,10 @@ DEPEND="dev-libs/openssl"
# TODO: support for dev-libs/qsa
need-kde 3.3
+
+src_unpack() {
+ kde_src_unpack
+
+ epatch "${FILESDIR}/${P}-uic.patch"
+ epatch "${FILESDIR}/${P}-gcc4.patch"
+}