summaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-04-28 04:18:02 +0000
committerMike Frysinger <vapier@gentoo.org>2004-04-28 04:18:02 +0000
commitfdc20330ce79e14544a7dc6ddfd548402a7e11a6 (patch)
tree98346e94dc3ceff512cc9ade560b02f88bf071b4 /net-fs
parentadd missing keyword (Manifest recommit) (diff)
downloadgentoo-2-fdc20330ce79e14544a7dc6ddfd548402a7e11a6.tar.gz
gentoo-2-fdc20330ce79e14544a7dc6ddfd548402a7e11a6.tar.bz2
gentoo-2-fdc20330ce79e14544a7dc6ddfd548402a7e11a6.zip
arm (and then some) KEYWORDS
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/nfs-utils/nfs-utils-1.0.6-r1.ebuild23
1 files changed, 11 insertions, 12 deletions
diff --git a/net-fs/nfs-utils/nfs-utils-1.0.6-r1.ebuild b/net-fs/nfs-utils/nfs-utils-1.0.6-r1.ebuild
index 38539f87c2a2..99a6e7443a33 100644
--- a/net-fs/nfs-utils/nfs-utils-1.0.6-r1.ebuild
+++ b/net-fs/nfs-utils/nfs-utils-1.0.6-r1.ebuild
@@ -1,29 +1,31 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/nfs-utils/nfs-utils-1.0.6-r1.ebuild,v 1.5 2004/04/13 23:07:59 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/nfs-utils/nfs-utils-1.0.6-r1.ebuild,v 1.6 2004/04/28 04:18:02 vapier Exp $
inherit gnuconfig
-IUSE="tcpd"
-
DESCRIPTION="NFS client and server daemons"
-SRC_URI="mirror://sourceforge/nfs/${P}.tar.gz"
HOMEPAGE="http://nfs.sourceforge.net/"
-RESTRICT="nomirror"
+SRC_URI="mirror://sourceforge/nfs/${P}.tar.gz"
-SLOT="0"
LICENSE="GPL-2"
-KEYWORDS="~x86 ~amd64 mips ppc64"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc mips arm hppa ~amd64 ppc64"
+IUSE="tcpd"
DEPEND="tcpd? ( sys-apps/tcp-wrappers )"
-RDEPEND="${DEPEND} >=net-nds/portmap-5b-r6 >=sys-apps/util-linux-2.11f"
+RDEPEND="${DEPEND}
+ >=net-nds/portmap-5b-r6
+ >=sys-apps/util-linux-2.11f"
src_compile() {
use ppc64 && gnuconfig_update
./configure \
--mandir=/usr/share/man \
--with-statedir=/var/lib/nfs \
- --disable-rquotad --enable-nfsv3 || die "Configure failed"
+ --disable-rquotad \
+ --enable-nfsv3 \
+ || die "Configure failed"
if ! use tcpd; then
sed -i "s:\(-lwrap\|-DHAVE_TCP_WRAPPER\)::" config.mk
@@ -82,7 +84,4 @@ pkg_postinst() {
ewarn "export list, thus assuming the default behavior, a warning will"
ewarn "be generated at export time."
echo
-
- # Running depscan since we introduced /etc/init.d/{portmap,nfs}
- /etc/init.d/depscan.sh
}