summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikael Hallendal <hallski@gentoo.org>2002-01-07 07:28:29 +0000
committerMikael Hallendal <hallski@gentoo.org>2002-01-07 07:28:29 +0000
commitc84fc1aa28989a8a8e50b79c4ccba62e2fb35ea1 (patch)
tree23d8e4f63af2e5f450a297469d78a5eefd8ee90d /net-fs/openafs
parentadded new version, removed old (diff)
downloadgentoo-2-c84fc1aa28989a8a8e50b79c4ccba62e2fb35ea1.tar.gz
gentoo-2-c84fc1aa28989a8a8e50b79c4ccba62e2fb35ea1.tar.bz2
gentoo-2-c84fc1aa28989a8a8e50b79c4ccba62e2fb35ea1.zip
s|/usr/lib/libncurses.so|-lncurses|, fixes bug #12
Diffstat (limited to 'net-fs/openafs')
-rw-r--r--net-fs/openafs/files/digest-openafs-1.2.2-r71
-rw-r--r--net-fs/openafs/openafs-1.2.2-r7.ebuild91
2 files changed, 92 insertions, 0 deletions
diff --git a/net-fs/openafs/files/digest-openafs-1.2.2-r7 b/net-fs/openafs/files/digest-openafs-1.2.2-r7
new file mode 100644
index 000000000000..e737f717084f
--- /dev/null
+++ b/net-fs/openafs/files/digest-openafs-1.2.2-r7
@@ -0,0 +1 @@
+MD5 2311dd7abe4ae72f10a592d3bb20193d openafs-1.2.2-src.tar.bz2 10027008
diff --git a/net-fs/openafs/openafs-1.2.2-r7.ebuild b/net-fs/openafs/openafs-1.2.2-r7.ebuild
new file mode 100644
index 000000000000..c841d9f25da5
--- /dev/null
+++ b/net-fs/openafs/openafs-1.2.2-r7.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Holger Brueckner <darks@fet.org>
+# /home/cvsroot/gentoo-x86/net-fs/openafs/openafs-1.1.1.ebuild,v 1.3 2001/08/31 03:23:39 pm Exp
+
+
+S=${WORKDIR}/${P}
+DESCRIPTION="The AFS 3 distributed file system targets the issues critical to
+distributed computing environments. AFS performs exceptionally well,
+both within small, local work groups of machines and across wide-area
+configurations in support of large, collaborative efforts. AFS provides
+an architecture geared towards system management, along with the tools
+to perform important management tasks. For a user, AFS is a familiar yet
+extensive UNIX environment for accessing files easily and quickly."
+
+SRC_URI="http://www.openafs.org/dl/openafs/1.2.2/openafs-1.2.2-src.tar.bz2"
+HOMEPAGE="http://www.openafs.org/"
+
+DEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.2
+ >=sys-libs/pam-0.75"
+
+ARCH=i386_linux24
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}/src/config
+ cp Makefile.i386_linux24.in Makefile.i386_linux24.in.old
+ sed -e "s|/usr/lib/libncurses.so|-lncurses|g" \
+ Makefile.i386_linux24.in.old > Makefile.i386_linux24.in
+ rm Makefile.i386_linux24.in.old
+}
+
+src_compile() {
+ ./configure --with-afs-sysname=i386_linux24 --enable-transarc-paths || die
+ make || die
+ make dest || die
+}
+
+src_install () {
+
+
+ # Client
+
+ cd ${S}/${ARCH}/dest/root.client/usr/vice
+
+ insinto /etc/afs/modload
+ doins etc/modload/*
+ insinto /etc/afs/C
+ doins etc/C/*
+
+ insinto /etc/afs
+ doins ${FILESDIR}/{ThisCell,CellServDB}
+ doins etc/afs.conf
+
+ dodir /afs
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/afs.rc.rc6 afs
+
+ dosbin etc/afsd
+
+ # Client Bin
+ cd ${S}/${ARCH}/dest
+ exeinto /usr/afsws/bin
+ doexe bin/*
+
+ exeinto /etc/afs/afsws
+ doexe etc/*
+
+ cp -a include lib ${D}/usr/afsws
+ dosym /usr/afsws/lib/afs/libtermlib.a /usr/afsws/lib/afs/libnull.a
+
+ # Server
+ cd ${S}/${ARCH}/dest/root.server/usr/afs
+ exeinto /usr/afs/bin
+ doexe bin/*
+
+ dodir /usr/vice
+ dosym /etc/afs /usr/vice/etc
+ dosym /etc/afs/afsws /usr/afsws/etc
+
+ dodoc ${FILESDIR}/README
+}
+
+pkg_postinst () {
+ echo ">>> UPDATE CellServDB and ThisCell to your needs !!"
+ echo ">>> FOLLOW THE INSTRUCTIONS IN AFS QUICK BEGINNINGS"
+ echo ">>> PAGE >45 TO DO INITIAL SERVER SETUP" fi
+}